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0. Introduction and Cookbook

The Customization Guide is intended for users who would like to design their own report forms.
The material discussed in the Guide is not covered under the free technical support clause of the
package’s license agreement (see the “Help!” chapter for more information on technical support
options).

Tip:  If you don’t have the time to create or modify your own reports, consider having GEOSYSTEM
Software design your form for you (there is a small charge for doing this).  For guidelines on
submitting forms for customization, refer to the “Help!” chapter in the User’s Guide.

This manual doesn’t need to be read like a book, front to back; rather, it is organized by task.  The
following list presents some of the more common LD4 customization tasks, along with references to
the appropriate section of the manual.

0.1 Data Entry Form Modification

➾ How do I make room for entering more characters into a particular data entry field?  If
your data entry field is part of the Project Data window or Source Data window (see Section
2.6 and Section 2.7 in the User’s Guide), then refer to Section 1.3 (page 8).  Otherwise, refer
to Section 1.4 (page 13).

0.2 Report Form Modification

➾ How do I add a groundwater symbol to my report?  See Section 4.11.6 (page 177).

➾ How do I add a new column of data to the table on my report?  See the tutorial given in
Section 8.1 (page 197).

➾ How do I change the fonts used on my report?  See Section 2.5 (page 44).  (Check out
the Head/Footing and Table tab discussions.)
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➾ How do I add something to the top or bottom of my report?  Firstly, you’ll need to add a
data entry field so that you can enter the data that you’ll be printing: see Section 1.3 (page 6)
for instructions on doing this (you may also want to look at the tutorial given in Section 1.3.1).
After you have a place where you can enter the data, you’ll need to add the data to your
report form: see Chapter 3 (page 57).

0.3 Upgrading From LOGDRAFT III (MS-DOS Drilling Log Program)

➾ Why don’t my LD4 reports look like those printed with my MS-DOS LOGDRAFT III
program?   See Chapter 6 (page 187).
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1. Data Entry Forms

While you’re entering data into a project file LD4 displays a data entry screen similar to the one
shown below.  The prompts and data entry fields that you see on the screen (such as “Boring No.:”
prompt below) are determined by a data entry form: this form must be modified if you want to add a
new data entry field to your screen or change the width of an existing field.

Figure 1.1 -- Data Entry Screen
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Data entry forms include all of the prompts and settings necessary to enter data for a project,
divided into four sections:

Section Used For

Project Data Data entry fields for data common to the entire project
such as the project number, the client’s name, etc.  (See
Section 2.6 in the User’s Guide.)

Source Data Data entry fields for data about a single source, such as
the boring’s number, the location of the boring, the date
the boring was started, etc.  (See Section 2.7 in the
User’s Guide.)

Tabulated Data Data with multiple readings taken per source.  For boring
log this is subsurface information: depths, sampling
intervals, material descriptions, etc.  (See Section 2.9 in
the User’s Guide.)

Form Settings Contains a list of settings that LD4 uses to understand
your form.

Table 1.1 -- Parts of a Data Entry Form

1.1 Data Entry Fields

The whole purpose of a data entry form is to provide you with places to enter your data.  These
places are called data entry fields.  Every data entry field has a name, a width and a type.

  Field Names

LD4 has a built-in list of names for all of the common data taken in a geotechnical investigation:
when you’re adding a new data entry field to a form try to give your new field one of the names from
LD4’s built-in list.  (All of LD4’s “add a new data entry field” screens show this list.)  If you’re adding a
new field that LD4 doesn’t have on its list you’ll need to make up a name for the new field.  LD4 has
strict rules on the names you can use for a data entry field -- they are:

1. The new field can’t have the same name as a data entry field that you’ve already added to the
form. You can use the same name for fields in different places on the form: for example, you can
have a field on the Project Data screen called 03'%8-32 and a field on the Source Data screen

called 03'%8-32, but don’t, as this will just get confusing.

 You also can’t use a field name that LD4 has already reserved for its own purposes.  LD4 will
always let you know if you try to use one of these.

2. Field names always start with a letter.

3. The rest of the field name can be any combination of letters and numbers.
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4. You may not have a space anywhere in the name.  Many of LD4’s suggested names use an
underscore in place of a space, for example, ;)00C-(, *-00C238)7 and +7C6)1%6/7.

 As examples, &03;7� and &03;7C� are acceptable field names while �&03;7 and &03;7�� are

not.

  Field Widths

LD4 needs to know the number of characters that you expect to type into each data entry field.
The program uses this information for various purposes such as determining how wide a table column
on a report needs to be to display data from a given data entry field.

  Field Types

In addition to the standard one-liner type of data entry field, LD4 also has a couple of special
fields.  The most common of these is the paragraph field, which allows you to enter more than one
line of text (see Section 2.5.3 in the User’s Guide).  Several other special types of field are used only
on the table section of the data entry form.

1.2 Creating and Modifying Data Entry Forms

Caution:  Hard disk failures happen!  If you modify or create a data entry form, be sure to save a
copy of the modified form onto a floppy disk or tape drive.

To modify a data entry form:

1. From LD4’s opening screen click on the Entry Forms tab then double-click on the report you want
to modify.

or

1. Open up a project then open a source that uses the form you want to change (see Section 2.4 in
the User’s Guide and Section 2.7.2 in the User’s Guide).

2. Choose Tools > Data Entry Forms...

or

1. Click on the  button at the lower-right of the LD4 data entry screen (see Section 2.5 in the
User’s Guide).

To create a new data entry form:

1. Following the steps given above, open up a data entry form that is similar to the form that you
want to create.

2. From Data Entry Form Designer choose Entry Form > Save As and type in the name you’ve
chosen for your new form
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or

1. From LD4’s opening screen click on the Entry Forms tab.

2. Enter a name and description for your new data entry form then click on OK.  If a form with that
name doesn’t already exist, LD4 will create a new, blank version.

or

1. While editing an existing data entry form choose Entry Form > Create from Scratch

1.3 Project and Source Data

After a data entry form has been opened or created, clicking on the Project Data or Source Data
tabs displays a screen similar to the one shown below:

Figure 1.2 -- Source Data Modification Screen

➾ The Project Data screen sets up data entry fields for data common to the entire project (such
as the project number, the client’s name, etc.), while the Source Data screen sets up data
entry fields for data about a single source (such as the boring’s number, the location of the
boring, the date the boring was started, etc.).

Data entry prompts
and fields already
placed on the form

Settings for the
currently-selected data

entry field

List of data entry
fields that may be
added to the form

Data entry field

Prompt
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➾ Because the project data entry screens and source heading data entry screens look similar,
LD4 uses the same process to modify both project and source heading sections.

To add a data entry field to the Project or Source Data screens:

1. Follow the directions given in Section 1.2 to open up the data entry form that you want to modify.

2. Click on either the Project Data or Source Data tabs -- remember that the Project Data screen is
for entering data about the entire project while the Source Data screen is for entering data about
a single source.

3. In the window where the entry prompts and fields are shown (this is the window with the rulers on
the top and left side), find a place where you can put your new data entry field.

➾ In the form designer, existing data entry fields look like this:   If you find one that extends
all the way to the right side of the screen, it’s probably taking up too much space (if you don’t tell
LD4 how wide a data entry field is to be the program extends the field all the way to the right side
of the screen).  You can try, for example, putting your new data entry prompt half-way between
the start of the existing field and the right side of the screen, even though LD4 shows the existing
data entry field taking up that space.

4. Move the mouse to the place you’ve picked for your new data entry field then click the left mouse
button.  (If you were trying to place your new field in the middle of an existing field and the field
needed the space where you tried to put the new field, LD4 won’t let you continue; you’ll need to
find another place to put your new field such as a completely blank line.)

5. Type in a prompt that will tell you during data entry what kind of data is to be entered.  For
example, if you’re adding a data entry field for entering boring numbers your prompt would be
something like

 &SVMRK�2YQFIV�

6. In the list of data entry fields that may be added to the form (this is the yellow box in the upper-
right corner of the screen), locate the field that you want to add, click the left mouse button on it
then, while holding the mouse button down, drag the mouse downwards until it is directly to the
right of the prompt that you added in the previous step.

 or

 If the list didn’t show anything similar to the data entry field you want to add, make up a name for
the new field (see Section 1.1 for guidelines) then move the mouse just to the right of the prompt
you added and click the left mouse button.  Type in an $ sign, followed by the name which you

invented.  (For example, $(6-00C63().

7. As noted earlier, LD4 automatically extends your field all the way to the right side of the screen.  If
you know that the field doesn’t need to be that wide, change the Field width in chars. setting for
the new field (you can find this setting in the Data Entry Field Properties panel at the bottom of the
screen -- see Figure 1.3).
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8. If you want to be able to enter more than one line of data into your new data entry field, change
the Field height in lines setting of the Data Entry Field Properties panel.

 

To modify a data entry field on the Project or Source Data screens

1. Follow the directions given in Section 1.2 to open up the data entry form that you want to modify.

2. Click on either the Project Data or Source Data tabs.  (Remember that the Project Data screen is
for entering data about the entire project while the Source Data screen is for entering data about
a single source.)

3. In the window where the entry prompts and fields are shown (this is the window with the rulers on
the top and left side) locate the field that you want to modify.  Remember,  data entry fields are

represented like this: .  Since all the data entry fields look the same, LD4 pops up a
small window listing the field’s name when you move the mouse cursor over the blue box at the
start of the field: use this to help you find the field you want to modify.

4. Once you’ve found the field, move the mouse over the blue box at the start of the field and click
the left mouse button.

5. LD4 responds by displaying the data entry field’s properties at the bottom of the window.
Information for a typical field is shown below:

 
 Figure 1.3 -- Data Entry Field Properties

➾ Note: to make room for entering more characters into the field, change the Field width to a
larger number.

To modify a prompt:

1. Follow the directions given in Section 1.2 to open up the data entry form that you want to modify.

2. Click on either the Project Data or Source Data tabs.  (Remember that the Project Data screen is
for entering data about the entire project while the Source Data screen is for entering data about
a single source.)

3. In the window where the entry prompts are shown (this is the window with the rulers on the top
and left side) locate the text that you want to modify then click the left mouse button on it.
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To move a field or prompt on the Project or Source Data screens:

1. Follow the directions given in Section 1.2 to open up the data entry form that you want to modify.

2. Click on either the Project Data or Source Data tabs.

3. In the window where the entry prompts are shown (this is the window with the rulers on the top
and left side) locate the prompt or data entry field that you want to move then click the left mouse
button on it.

4. While holding the left mouse button down, drag the item to its new location.

 

To delete a field or prompt from the Project or Source Data screens:

1. Follow the directions given in Section 1.2 to open up the data entry form that you want to modify.

2. Click on either the Project Data or Source Data tabs.

3. In the window where the entry prompts are shown (this is the window with the rulers on the top
and left side) locate the prompt or data entry field that you want to move then click the left mouse
button on it.

4. Choose Edit > Cut Field or Prompt or Edit > Delete Field or Prompt.
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1.3.1 Step by Step Instructions for Adding North, East and Station Fields

LD4’s profile plotting facility includes an option to produce profiles that show the spaces between
borings as proportional to the actual distances between the borings.  In order to accomplish this, a
data entry form needs at least one data entry field for entering the boring’s coordinate.  Typical forms
have three coordinate fields: northing, easting and station number.  The steps below show how these
fields are added to a data entry form.

1. Following the directions given in Section 1.2, open up the data entry form that you want to modify.

2. There are three different places on a data entry form where a new field may be placed: the
Project Data tab, the Source Data tab or the Tabulated Data tab.  Since project data is information
about the entire project and tabulated data is for data that can be taken more than once per
boring (such as “depth” or “N-value”), that leaves us with the Source Data tab: click on this tab.

3. In the window where the entry prompts are shown (this is the window with the rulers on the top
and left side), find the bottom of the existing data entry prompts and fields, and, on the first blank
line below, click the left mouse  button with the cursor in the first column.

4. Type 3TXMSREP���'SSVHW"���)EWX�

5. In the dictionary at the top of the screen, locate the entry called )%78.  Click the left mouse button

with the cursor on this entry and, while holding the mouse button down, drag the mouse to just
past the “:” of the line of text that you typed in step 4, then release the mouse button.  This should
show a blue box just to the right of “East:” : if the box doesn’t show up, try this step again and
make sure to drag the cursor to the right of the “:” before letting up on the mouse button.

6. Move the mouse cursor 10 spaces or so to the right of the blue box then click the left mouse
button.  Make sure that the cursor is on the same row as the text you entered in the previous
steps before clicking on the button.

7. Type 2SVXL�

8. In the dictionary at the top of the screen, locate the entry called 2368,.  Click the left mouse

button with the cursor on this entry and, while holding the mouse button down, drag the mouse to
just past the “:” of the line of text that you typed in step 7, then release the mouse button.  This
should show a blue box just to the right of “North:” : if the box doesn’t show up, try this step again
and make sure to drag the cursor to the right of the “:” before letting up on the mouse button.

9. Move the cursor to the first column of the next row then click the left mouse button.

10. Type �JSV�TVSJMPIW����"���7XEXMSR�
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11. In the dictionary at the top of the screen, locate the entry called 78%8-32.  Click the left mouse

button with the cursor on this entry and, while holding the mouse button down, drag the mouse to
just past the “:” of the line of text that you typed in step 10, then release the mouse button.  This
should show a blue box just to the right of “Station:” : if the box doesn’t show up, try this step
again and make sure to drag the cursor to the right of the “:” before letting up on the mouse
button.

12. LD4 must be told to use the data entered into the new fields when plotting profiles (this process is
covered in detail in Section 1.5): start by clicking on the Form Settings tab.

13. Locate the prompt that says Select the source field that accepts easting or offset
coordinates then click on the “...” button to the right of the data entry field below the prompt.

14. You should be able to find “EAST” in the drop-down dictionary: click on it.  (If you don’t find
“EAST”, consider selecting Entry Form > Abandon Changes and starting from step 1.)

15. Click on the “...” button below Select the source field that accepts northing coordinates and
click on “NORTH”

16. Click on the “...” button below Select the source field that accepts station number
coordinates and click on “STATION”.

17. Select Entry Form > Exit.
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1.4 The Table Section

After a data entry form has been opened, clicking on the Tabulated Data tab displays a screen
similar to the one shown below:

Figure 1.4 -- Tabulated Data Modification Screen

Remember that the tabulated data part of the data entry form is for data with multiple readings
taken per source.  For a boring log this is composed of subsurface data: depths, sampling intervals,
material descriptions, etc.  (See Section  2.9 in the User’s Guide.)

To add a new data entry field to the tabulated data portion of a data entry form:

1. Follow the directions given in Section 1.2 to open up the data entry form that you want to modify.

2. Click on the Tabulated Data tab.

3. In the list of data entry fields that may be added to the form (this is the yellow box shown in the
upper-right corner of the screen), locate the field that you want to add, click the left mouse button
on it then, while holding the mouse button down, drag the mouse over the section of the screen
that shows the data entry prompts and fields already placed on the form (see Figure 1.4).

List of data entry
fields that may be
added to the form

Data entry prompts
and fields already
placed on the form

Settings for the
currently-selected data

entry field

Prompt

Data entry field
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4. While you’re dragging the new data entry field, LD4 indicates the position where the new field will
be placed with an arrow.  When the arrow is in the right position, release the mouse button.

 Once you’ve released the mouse button the new field will be placed on the form.   The current
field settings panel (discussed in Section 1.4.1) will show LD4’s initial guess at the type and size
of your new data entry field.

 

To modify an existing data entry field on the tabulated data portion of a data entry form:

1. Follow the directions given in Section 1.2 to open up the data entry form that you want to modify.

2. Click on the Tabulated Data tab.

3. In the section of the screen that shows the data entry prompts and fields already placed on the
form  (see Figure 1.4), move the mouse cursor over the field that you want to modify then click the
left mouse button.

 LD4 displays the Current Field Settings panel, discussed in Section 1.4.1.

➾ Tip: to make room for entering more characters into the field, change the Field width setting to
a larger number.

 

To remove an existing data entry field from the tabulated data portion of a data entry form:

1. In the section of the screen that shows the data entry prompts and fields already placed on the
form  (see Figure 1.4), move the mouse cursor over the field that you want to modify then click the
left mouse button.

2. Select Edit > Delete Field or Edit > Cut Field.

 

To change the data entry field order:

1. In the section of the screen that shows the data entry prompts and fields already placed on the
form  (see Figure 1.4), move the mouse cursor over the field that you want to modify then click the
left mouse button.

2. While holding the left mouse button down, drag the field.  While you’re dragging the field LD4
displays an arrow indicating where the field would be placed when you release the mouse button:
when the arrow’s in the position that you want the field to move to, release the mouse button.
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1.4.1 The Field Settings Panel

The field settings panel (shown below) determines how a particular data entry field appears and
what data can be accepted in the field.  The panel is active whenever you add or modify a data entry
field on the tabulated data section of the form.

Figure 1.5 -- Field Settings Panel

➾ The Prompt field gives you three lines of text to put to the left of your data entry field.  Use
these lines to describe the data that you will typing into the field.  If a particular set of
measurement units are to be used with the data (for instance, a sampling length field that to
be entered in centimeters) be sure to add the units to your prompt.  As an example, a good
prompt for the sampling length field would be:

7EQTPI

0IRKXL

�MR��SV�GQ��

Note the “in. or cm.”: if you expect to be entering data in different units (e.g., inches  and
centimeters or pcf and kg/cm3) depending upon the dimension units setting associated with
the project (as discussed in Section 2.2.1 in the User’s Guide) make sure to that your prompt
reflects the units that you expect for both dimension units settings.

➾ Field name allows you to choose a new name for your data entry field.  (See Section 1.1.1 for
guidelines on data entry field names.)  You can also select a name from the list of names
(shown on the right of the panel) by clicking on it.

➾ Field type allows you to have select some special types of fields from a list.

If you leave Field type blank you get a one-line data entry field that accepts any type of text.
The following table shows some other selections available:
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Type Used For Used With Field Named

PARAGRAPH Creates a data entry field that holds more than one
line of text; typically used for soil description and
remarks columns.

Typically, if you have a
field named
()7'6-48-32,

;)00C238)7, 6)1%6/7,

786%8%C()7' or

18)787, you should set

the field’s type to be
4%6%+6%4,.

STRATA Creates a field for selecting stratigraphy symbols --
see Section 2.9.3 in the User’s Guide.

786%8%

STRATA_ID Automatically selects stratigraphy patterns based upon
a soil’s USCS classification.  Note: when using a
STRATA_ID field you should also have a field of type
STRATA -- see Section 4.2.1 of the User’s Guide.

97'7

STRATA_DESC Descriptions entered into this field automatically
change the legend description for the stratigraphy
symbols that are printed at the same depth.

()7'6-48-32

 SAMPLERS Creates a field for selecting symbolic representations
of sampler types -- see Section 2.9.4 in the User’s
Guide.

7%14C8=4)

WELL_ID Creates a field for selecting sections of a monitoring
well schematic -- see Section 2.9.6 in the User’s
Guide.

;)00C-(

PIPES Creates a field for selecting the second and third pipe
to go in a monitoring well schematic. (See Section
2.9.6 in the User’s Guide  for an example of a three-
pipe monitoring well.)  This field isn’t needed unless
you’ll be drawing monitoring wells with more than one
pipe installed.

4-4)� and 4-4)�

WELL_DESC Descriptions entered into this field automatically
change the legend description for the monitoring well
section that is at the same depth.

;)00C()7'

YN Creates a field that accepts yes/no answers 86%27-8-32 (for

selecting between sudden
and gradual stratigraphy
transitions)

MISC Creates a field for selecting items from the MISC
graphic symbols library.  Included for backwards
compatibility purposes.

(not normally used)

Table 1.2 -- Field Types
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You can also use Field type to set up a field whose contents depends upon an equation: for
example, if you want to have a field for plasticity index that is automatically filled in when the
liquid and plastic limit fields are entered, the plasticity index’s field type would be 00�40.

Fields that use an equation such as 00�40 are useful for checking results during data entry.

If this capability isn’t needed, you can eliminate the calculated field from your data entry form
and still print the results on your reports: LD4 has the ability to print the results of equations
on boring logs, etc. so you can set up your report form to print the results of calculating 00�

40 (see Section 4.6).

Another common data entry field that can use a Field type equation is the 2:%09) field, which

can be set up to automatically display the results of adding the second and third blow counts.
Assuming you’ve set up fields called &03;7�, &03;7� and &03;7�) by setting the 2:%09)’s

“Field type” to

&03;7��&03;7�

This automatically calculates N-values; however, if you get into a situation where the third
blow count couldn’t be determined (for example, with an N-value of ����z) the user can

override the program’s calculated N-value by typing in ����z.  LD4 won’t change the ����z

unless the user types in a new value for either BLOWS2 or BLOWS3.

You can also set up a field that utilizes a popup picklist, which would allow you to choose
during data entry from a list of available selections.  This option is covered in Section 1.4.2.
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➾ The Field width prompt allows you to choose a maximum width in characters for data entered
into that field.  Each field’s width should be set as small as possible in order to make efficient
use of the space available on the data entry screen.  As a default, LD4 suggests a field width
of five characters -- this is sufficient for most numeric data.  The following table lists the widths
suggested for some common fields:

Field Field Name Width Why

Stratigraphy
patterns

STRATA � this gives a maximum of 5 soil patterns per
entry because soil pattern names are all one
character

Sampler type SAMPLERS � the as-shipped sampler names are all one
character

Monitor well
construction
field

WELL_ID �� well sections have names that the program
limits to 13 characters

Second & third
well pipes
column

PIPES2 and

PIPES3

� pipe names have a maximum of 8 characters

Atterberg limits PL, LL and PI � or � use 2 characters if you are rounding your
values to the nearest whole number or 4
characters if you are rounding to 1 decimal
place

Grain size
distribution data

PER10, PER40,

PER200, etc.

� or � use 2 characters if you are rounding your
values to the nearest whole number or 4
characters if you are rounding to 1 decimal
place

Table 1.3 -- Suggested Field Widths
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1.4.2 Step by Step Instructions for Adding a Miscellaneous Tests Data Entry Field

“LEGPROFA” (one of the profile forms shipped with LD4) includes a column for plotting
miscellaneous laboratory testing data.  Because most custom data entry forms don’t have a
miscellaneous data entry field, you’ll probably need to add a new data entry field to take full
advantage of the form.

1. Follow the directions given in Section 1.2 to open up the data entry form that you want to modify.

2. There are three different places on a data entry form where a new field can be placed: on the
Project Data tab, the Source Data tab or the Tabulated Data tab.  Since project data is information
about the entire project and source data is for data taken once per boring, this leaves us with the
Tabulated Data tab (because you’ll want to be able to enter more than one miscellaneous test
result per boring): click on this tab.

3. Locate “MTESTS” in the dictionary at the top-right of the screen: click the left mouse button with
the cursor on this entry and, while holding the left mouse button down, drag the entry into the
middle of the screen, past the last data entry prompt already shown.  You should see an up-arrow
just past the prompt -- when it is in the correct position, let up the mouse button.

4. LD4 suggests that the new data entry field be made 20 characters wide.  “LEGPROFA” was
designed for a 10 character wide field so (for the sake of demonstration -- it doesn’t really matter
how wide the field is) we need to adjust the field’s width: locate the Field width prompt at the
bottom of the screen and change the number from �� to ��.

5. Choose Entry Form > Exit.
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1.4.3 Picklists

Several common table entry fields require specific data such as shear test method codes (,4 for

hand penetrometer, 8: for torvane, 99 for unconsolidated undrained, etc.) or casing selection (2<,

&<, etc.).  You’ll want to make sure that data entry in these fields is limited to applicable values so

that, for example, 5> can’t be entered as a shear test method.  LD4 supports this through picklist data

entry fields, which are fields that A) restrict data entry to a specific set of choices and B) at the user’s
request, pop up a menu of available choices.

Figure 1.6 -- Shear Test Method Picklist
The user must select between the HP, TV, UC and UU test method codes

Picklists are stored in the same files as your legend information so you might want to review
Chapter 4 in the User’s Guide before proceeding.  (As an aside: there’s no major reason why picklists
are a part of legend files -- picklists don’t show up on hardcopy legend printouts -- but it does make
transferring files to another computer somewhat easier.)

To set up a data entry field to use a picklist, follow the directions given below:

1. Open a project file.

2. Choose Legend > Edit the Default Legend.  If this selection isn’t available then you’ve created a
custom legend for the project: you should choose Legend > Revert to the Default Legend (so that
the modifications you’ll be doing are to the default legend and consequently affect all future
projects), then select Legend > Edit the Default Legend.

3. Select Legend > Add a New Legend Table.
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4. Select “List of items for popup menu during data entry”.

5. As a name for the list, enter a one-word abbreviation that describes how the list will be used (e.g.,
7,)%6 for a list of shear test types or '%7-2+ for a list of casing types).  Make a note of the

abbreviation -- you’ll need it later.

6. LD4 will display a standard data entry screen (similar to the one shown below) with cards holding
Item and Description prompts.  In the Item fields, enter the picklist codes that you want to type in
during data entry (e.g., ,4, 8:, etc. for shear test method codes).  In the (IWGVMTXMSR fields,

enter a short description -- the description will appear on the popup picklist menu.  Picklists do not
appear on printed legends so you don’t need to be too careful with how the descriptions are
worded.

 
 Figure 1.7 -- Picklist Setup

7. After the picklist entries have been added, select Tools > Data Entry Forms then (if it isn’t
automatically opened), open the data entry form to be modified.

8. Click on the Tabulated Data tab then, if you haven’t yet done so, add the data entry field that will
use the picklist.  (See Section 1.4 for instructions.)  When asked for the Field type, enter the
abbreviation that you used in Step 5.

9. Save the data entry form and open the data entry screen for a boring that uses the form: you
should see your new data entry field accompanied on the right by a button.  Clicking on the button
should show a menu of selections.

 You can change or add selections with Legend > Edit the Default Legend.
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1.5 Form Settings

The data entry form editor’s Form Settings screen controls some basic settings about the form.
Clicking on the Form Settings tab displays a screen similar to the one shown below:

Figure 1.8 -- Form Settings
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Field Use
Singular word or phrase that
describes the sources that will
use this data entry form (e.g.,
"Boring", "Test pit", "Well", etc.)

Provides LD4 with a generic name for all of the  sources that use
the data entry form.  For example, if the form was designed for
entering data for test pits the phrase 8IWX�TMX would all cause the

program to call all of the sources using the data entry form “Test
Pits”.  Commonly, &SVMRK is used.

Enter the name of a source data
entry field that can be used to get
each source’s name (normally,

this is &36-2+); multiple field

names may be used by separating
each with a "+" sign.

This is the name of the source field into which the source’s name
will be entered.  For each source, LD4 lists the contents of this field
in the Sources panel on the data entry screen (see the Source Data
Modification screen discussed in Section 1.3 and also Section 2.5
of the User’s Guide).  Normally the name would be &36-2+;

however, you can also list multiple fields by separating then with a
� sign (for example, &36-2+�78%8-32 causes LD4  to combine

the contents of the &36-2+ and 78%8-32 fields to get the source’s

name).
For sorting purposes, select a
field on the form’s tabulated data
section that will be unique for
each row of data entered.

LD4 automatically sorts the tabulated section of the source (see the
Tabulated Data screen discussed in Section 1.4)  on the field you
specify at this prompt -- typically, select ()48, as the sort field so

the program orders your data by increasing depth.
If it exists, select the source data
field that accepts elevation data

This is the field on the Source Data Modification section (discussed
in Section 1.3) which is used to determine the boring’s elevation
when drawing elevation-adjusted profiles: normally )0):%8-32.

Select the source data field that
accepts easting or offset
coordinates

This is the field on the Source Data Modification section that will be
used for entering the source’s east or offset coordinate.  Normally
this field is called )%78, however, leave this field blank if you are

not entering the physical coordinates of your sources.
Select the source data field that
accepts northing coordinates

The field on the Source Data Modification section where the
source’s north coordinate will be entered. Normally this is called
2368,, however, leave this field blank if you are not entering the

physical coordinates of your sources.
Select the source data field that
accepts station number
coordinates

The field on the Source Data Modification section where the
source’s station number (and possibly, station offset) will be
entered.  Normally this is called 78%8-32; however, leave this field

blank if you are not entering the physical coordinates of your
sources.

On plan views you may want to
represent sources that use this
data entry form with a unique type
of symbol: if so, enter the symbol
name below...

Used to distinguish sources using this data entry form on plan
views -- for instance, if the form is used to enter test pit data, a
graphic symbol can be drawn in the MISC symbols library (see
Chapter 9) that represents only test pits; when LD4 draws a plan
view it will use that symbol to represent all test pits.

Table 1.4 -- Miscellaneous Form Settings
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2. Report Forms

Users upgrading from LOGDRAFT III: Please read the section on LOGDRAFT III report
compatibility (see Chapter 6) before modifying a report you’ve designed with your old program.

When you’re ready to produce a printout from your project LD4 takes the data you’ve entered into
the project and places it onto a blank report form; the result is then sent to the printer or to an
AutoCAD .DXF file.  The blank report form that is used comes from a report form file.  Different report
form files produce different printouts: you may have one report form for printing boring logs, another
for printing monitoring well logs and still another for summarizing your testing data.  LD4 displays a list
of available report forms in the Form Settings dialog shown when you get ready to print something
(see Chapter 3 in the User’s Guide.)
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2.1 Types of Reports

LD4 report forms are divided into a number of basic types which are discussed and shown in the
following sections.

2.1.1 Single-Source Subsurface Log

Single-source reports are used for showing boring logs, monitoring well installations, rock coring
logs, etc.  These reports present a representation of the conditions encountered during a subsurface
exploration, scaled vertically with respect to depth.
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Figure 2.1 -- Single Source Subsurface Log
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2.1.2 Multi-Source Subsurface Report

Multi-source subsurface reports are also commonly called profiles.  These reports show multiple
borings on a single page, again scaled with respect to depth; they can optionally place each boring
scaled with respect to its elevation and station or north/east location.
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Figure 2.2 -- Multiple Source Subsurface Report

2.1.3 Single Source Data Summary

A single source data summary lists data entered into a single source folder, meaning that one
report is generated for boring selected for printing.  The data are listed in a tabular format that is not
scaled with respect to depth.

➾ The project summary forms discussed in Section 2.1.6 are just single source data summaries
that are automatically generated by LD4.
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2.1.4 Multiple Source Data Summary

A multi-source data summary can potentially list data from a number of different source folders on
the same page; otherwise, is identical to a single source data summary.
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Figure 2.3 -- Multi-Source Data Summary
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2.1.5 Multiple Source Graph

A multi-source graph report shows graphs of data from more than one boring, scaled by depth.
Multiple source graphs are different from profiles: each boring on a multiple source graph is plotted in
the same graph, whereas on a profile that uses graphs, each boring gets its own graph.
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Figure 2.4 -- Multi-Source Graph
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2.1.6 Project Summary

Project summary forms are special forms that are automatically generated by LD4 to show all of
the data entered into a given source folder.  These forms are useful in checking entered data against
an original driller’s log.

� ����� �� 63�60 & 79 ��� 'LUW\�6$1'<�&/$<��UHG��EURZQ�
ILQH�WR
PHGLXP�JUDLQHG��VDQG\��ZLWK�URFN
IUDJPHQWV

&$6(' ���GLDPHWHU��VFK�
���
3&9�SLSH�LQ�VWHHO
FDVLQJ

���� �� �� =$ 88 ���6�� 3 ���� ���D ��
���� &21&5(7( HQFORVHG�LQ�FRQFUHWH
���� �� �� 96 ��� &877,1*6 PLVF��FXWWLQJV6�� 3 ���� ����E ��
���� �� 8& ���6�� 3 ���� ���
���� ����� %(1721,7( EHQWRQLWH�VOXUU\6�� 3 ���� ����
���� �� 79 ���6�� 3 ���� ����
���� ��6�� 3 ���� ��
���� �� , 52&.�)5$*0(176��KDUG��GHFRPSRVHG�

JUD\�
DQJXODU��ILQH�PHGLXP�JUDYHO�VL]H

6$1' ���VDQG&�� 6 ���� �� ��

���� ��6�� 3 ���� ��
���� ��6�� 3 ���� ��
���� �� 8& ��� 6/277(' ���GLDPHWHU��VFK����

�������VORWWHG�39&
FDVLQJ

6�� 3 ���� ��

���� ��6��� 3 ���� ��
����� 63 � 96 ��� 6$1'��PHGLXP��WDQ��SRRUO\�JUDGHG�

VOLJKWO\�FRPSDFW��VXEURXQGHG
3(//(76 0HGLXP�EHQWRQLWH

FKLSV
����� �� +3 ���6��� 3 ���� ��
����� (1'
����� �� ��6��� 3 ���� �� ��
����� / /,0(6721(��YHU\�KDUG��VOLJKWO\

IUDFWXUHG�DQG�GHFRPSRVHG
5�� 9 ����

����� 79 G %RULQJ�WHUPLQDWHG�DW����IW�

6WDQGSLSH�SLH]RPHWHU�LQVWDOOHG
6WDQGSLSH�'U\�RQ�$SULO���������

'$7$�6800$5<

)LOH�QDPH� PLVF &XUUHQW�'DWH� ������� 7LPH� �����30

�'HPRQVWUDWLRQ�%RULQJ�/RJ�)RUP�
%RULQJ�1R���%�� (OHYDWLRQ��������� 'DWXP��DVVXPHG
/RFDWLRQ��6HH�$WWDFKHG�'UDZLQJ
'ULOOHU��$&(�'ULOOLQJ /RJJHG�%\��$�3��/D\QH
'ULOOLQJ�0HWKRG��+ROORZ�VWHP�DXJHU 'ULOO�'DWH��)HE����������
'HSWK�WR�:DWHU!�DW�ILUVW�FKHFN�� ���� DIWHU����KUV��������
'HSWK�WR�&DYLQJ!����� 'ULOO�5HMHFWLRQ��< <HV�"��
1RWHV��,QWHUVHFWLRQ�RI�5RXWH����DQG�KLJKZD\����

2SWLRQDO��&RRUGV�! (DVW������ 1RUWK������
6WDWLRQ���������

3URMHFW��%HUWKRXG�&RXQW\�/DQGILOO�([SDQVLRQ
3URMHFW�1R�����;������
&OLHQW��&LW\�DQG�&RXQW\�RI�%HUWKRXG
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1R�
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/LTXLG
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86&6�
6WUDWD
,'

6RLO
V\PEROV

7\SH�
RI�

VKHDU�WHVW

6KHDU�
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0RQLWRU�:HOO
,QVWDOODWLRQ
6FKHPDWLF

1RWHV

Figure 2.5 -- Project Summary
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2.1.7 Symbol Legend

Symbol legend forms are used to draw legends of the symbols utilized in a batch of reports.  See
Section 3.2.3 in the User’s Guide and Chapter 4 in the User’s Guide for details on how legends are
drawn.

���([SORUDWRU\�ERULQJV�ZHUH�GULOOHG�RQ����������XVLQJ�D
�����LQFK�GLDPHWHU�FRQWLQXRXV�IOLJKW�SRZHU�DXJHU�

���1R�IUHH�ZDWHU�ZDV�HQFRXQWHUHG�DW�WKH�WLPH�RI�GULOOLQJ�RU
���ZKHQ�UH�FKHFNHG�WKH�IROORZLQJ�GD\�

���%RULQJ�ORFDWLRQV�ZHUH�WDSHG�IURP�H[LVWLQJ�IHDWXUHV�DQG
���HOHYDWLRQV�H[WUDSRODWHG�IURP�WKH�ILQDO�GHVLJQ�VFKHPDWLF�SODQ�

���7KHVH�ORJV�DUH�VXEMHFW�WR�WKH�OLPLWDWLRQV��FRQFOXVLRQV��DQG
���UHFRPPHQGDWLRQV�LQ�WKLV�UHSRUW�

���5HVXOWV�RI�WHVWV�FRQGXFWHG�RQ�VDPSOHV�UHFRYHUHG�DUH�UHSRUWHG
���RQ�WKH�ORJV�

1RWHV�

6\PERO 'HVFULSWLRQ

6WUDWD�V\PEROV

/RZ�SODVWLFLW\
FOD\

+LJK�SODVWLFLW\
FOD\

6LOW

(ODVWLF�VLOW

'HVFULSWLRQ�QRW
JLYHQ�IRU�
�=$�

6LOW\�VDQG

/LPHVWRQH

%DVDOW
�RU�JHQHULF�URFN�

&/�IUDFWLRQ

3DYLQJ

:HOO�JUDGHG�VDQG
ZLWK�VLOW

6\PERO 'HVFULSWLRQ

6LOW\�JUDYHO

:HOO�JUDGHG
JUDYHO

6LOW\�FOD\H\
JUDYHO

6LOW\�VDQG�DQG
JUDYHO

,QRUJDQLF�VLOWV
DQG�FOD\V

)LOO

:HOO�JUDGHG
JUDYHO
DQG�VDQG

0LVF��6\PEROV

:DWHU�WDEOH
GXULQJ
GULOOLQJ

:DWHU�WDEOH�DW
ERULQJ�FRPSOHWLRQ

6RLO�6DPSOHUV

6WDQGDUG
SHQHWUDWLRQ�WHVW

6\PERO 'HVFULSWLRQ

$XJHU

&DOLIRUQLD
VDPSOHU

1R�UHFRYHU\

5RFN�FRUH

.(<�72�6<0%2/6

)LJXUH�

Figure 2.6 -- Symbol Legend Report

➾ The report shown in Figure 2.2 has a legend on it; however, that report isn’t a symbol legend
form.  In contrast to Figure 2.2, a symbol legend form only shows a legend -- it doesn’t show
data from any particular boring.

Not part of the
form -- filled in at

print time
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➾ Symbol legend forms only provide the basic outline of the printed legend.  The symbols that
are included on the printed legend aren’t determined until LD4 prints the reports for which the
legend will be drawn.  (LD4 gets the descriptions for those symbols, along with a set of legend
notes from a legend file associated with the project being printed.)  A typical symbol legend
form is shown on the following page: note that the area between the title and the bottom of
the page is used at print time by LD4 to fill in the actual symbols used by the reports just
printed.
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.(<�72�6<0%2/6

)LJXUH�

Figure 2.7 -- Typical Legend Form
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2.2 Sections of a Typical Report Form

For the purposes of editing, a LD4 report form is divided into a number of different parts, as
shown in the figure below.

�

�

�

�

�

��

��

��

��

��

�

��

��

��

��

��

��

'LUW\�6$1'<�&/$<��UHG��EURZQ��ILQH
WR

PHGLXP�JUDLQHG��VDQG\��ZLWK�URFN
IUDJPHQWV

52&.�)5$*0(176��KDUG�
GHFRPSRVHG��JUD\�

DQJXODU��ILQH�PHGLXP�JUDYHO�VL]H

6$1'��PHGLXP��WDQ��SRRUO\�JUDGHG�
VOLJKWO\�FRPSDFW��VXEURXQGHG

/,0(6721(��YHU\�KDUG��VOLJKWO\
IUDFWXUHG�DQG�GHFRPSRVHG
%RULQJ�WHUPLQDWHG�DW����IW�

6WDQGSLSH�SLH]RPHWHU�LQVWDOOHG
6WDQGSLSH�'U\�RQ�$SULO���������

����� ��

����

���GLDPHWHU��VFK�����
3&9�SLSH�LQ�VWHHO
FDVLQJ
HQFORVHG�LQ�FRQFUHWH
PLVF��FXWWLQJV

EHQWRQLWH�VOXUU\

���VDQG

���GLDPHWHU��VFK����
�������VORWWHG�39&
FDVLQJ

0HGLXP�EHQWRQLWH
FKLSV

'5,//�+2/(�/2*
352-(&7� %HUWKRXG�&RXQW\�/DQGILOO�([SDQVLRQ 352-(&7�12�� ��;������

&/,(17� &LW\�DQG�&RXQW\�RI�%HUWKRXG '$7(� )HE����������

%25,1*�12��%��

/2&$7,21� 6HH�$WWDFKHG�'UDZLQJ (/(9$7,21� ��������DVVXPHG

'5,//(5� $&(�'ULOOLQJ /2**('�%<� $�3��/D\QH

'5,//,1*�0(7+2'�

)LOH��0,6& 'DWH�3ULQWHG���������'(37+�72���:$7(5!�,1,7,$/� ���� $)7(5����+2856� ����� &$9,1*! ����

,QWHUVHFWLRQ�RI�5RXWH����DQG�KLJKZD\����

'
(
3
7
+

�P
H
WH
UV
�

'
(
3
7
+

�I
H
H
W�

'HVFULSWLRQ
6
2
,/

7
<
3
(

6
$
0
3
/
(
5
6 7(67�5(68/76

�� �� �� �� ��
3HQHWUDWLRQ��
:DWHU�&RQWHQW��
3ODVWLF�/LPLW /LTXLG�/LPLW

021,725�:(//�,167$//$7,21

'(7$,/6

/$<1(�(1*,1((563$*(���RI�aa)LJXUH�)�DD

7
K
L
V
�
L
Q
I
R
U
P
D
W
L
R
Q
�
S
H
U
W
D
L
Q
V
�
R
Q
O
\
�
W
R
�
W
K
L
V
�
E
R
U
L
Q
J
�
D
Q
G
�
V
K
R
X
O
G
�
Q
R
W
�
E
H
�
L
Q
W
H
U
S
U
H
W
H
G
�
D
V
�
E
H
L
Q
J
�
L
Q
G
L
F
L
W
L
Y
H
�
R
I
�
W
K
H
�
V
L
W
H
�

Figure 2.8 -- LD4 Boring Log Report

The following sections discuss the different parts of a typical report form.

Heading
See Section 2.3.6

Table
See Section 4

Footing
See Section 2.3.6

Text outside the
report border
See Section 5

Border style, default
fonts

See Section 2.5

Margins
See Section 2.6
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2.2.1 Report Heading and Footing

LD4’s heading and footing editor is used to modify basically all of the report form but the table
section (see Figure 2.8).  The report’s heading and footing section usually lists various data on the
project (such as the project number) along with the drilling location and conditions (such as the station
number, method of drilling and sampling, driller’s name, etc.)

➾ While the table created for one style of report form isn’t generally interchangeable with the
table created for another style of report (because, for example, a boring log’s table section
shows data scaled by depth while a summary report’s table section just shows a list of data)
the options available for the heading and footing portions of the report are identical for all of
LD4’s different report styles.

Typically the heading on the first page of each boring’s report includes detailed information
concerning the project, boring location, drilling method, groundwater depths, etc.  If the log runs over
to a second page you don’t need to repeat most of that information so the heading on the second
page and subsequent pages omits all but the most basic information.  (You can see an example of
this in Figure 2.8 -- note that most of the first page’s heading is omitted from the second page, leaving
more room for the second page’s subsurface table.)  LD4 allows you to set up report forms so that the
heading and footing shown on the first page of a boring log are different than the heading and footing
shown on subsequent (or continuation) pages, as shown in the two-page boring log report in Figure
2.9).  Both versions of the report (the first page version and the subsequent page version) are stored
in a single report form file.
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Figure 2.9 -- Report Form with Different First and Subsequent Pages
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The following table lists when LD4 uses the subsequent page heading and footings and when it
returns to using the first page heading and footing.

Report Style Uses Subsequent Page
Heading and Footing

Returns to First Page Heading and
Footing

Subsurface
Report

After the first page of each
boring.

When printing the first page of each boring.

Subsurface
Profile

Never Every page uses the First Page heading and
footing.  Since LD4 doesn’t continue borings
that run off the bottom of a profile, there is
no option to set up a subsequent page
heading and footing for the report.

Single-Source
Data Summary

After the first page of each
boring.

When printing the first page of each boring.

Multi-Source Data
Summary

After the first page printed Never.  After the first page of the summary is
printed, subsequent pages all use the
“subsequent page” heading and footing.

Multi-Source
Graph

Never Every page uses the First Page heading and
footing.  Since LD4 doesn’t continue borings
that run off the bottom of a profile, there is
no option to set up a subsequent page
heading and footing for the report.

Table 2.1 -- Uses of the Subsequent Page Heading and Footing Sections
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2.2.2 Report Tables

When you work with a report form’s table, the options that are available to you depends upon the
style of report you’re editing.

Report Style Table is Used For

Subsurface Report Reporting subsurface data.  The table is always scaled in terms of “x” feet
of physical boring per inch of page space or “x” meters of physical boring
per centimeter of page space.  Typically, a subsurface report’s table
includes a strata layer descriptions, sampling information, a stratigraphy
column, a monitoring well schematic, etc.

Subsurface Profiles Reporting subsurface data.  Again, tables are scaled in terms of “x”
feet/meters of physical boring per inch or centimeter of page space.  Even
though a profile form can be used to draw more than one boring on a page,
the same table definition is used to draw each boring.  Typically, a profile
report’s table includes a column to show the stratigraphy of each boring;
optionally, a symbolic representation of the boring’s sampling intervals and
sampling types, testing data and even graphs may be added.

Multi-Source Graph Graphing subsurface data. Tables are scaled in terms of “x” feet/meters of
physical boring per inch or centimeter of page space.  The table tells LD4
what data items are to be graphed.  Multi-source graph tables can’t include
any kind of stratigraphy representations, or print any text: they can only
print graphs.

Summaries Includes only text.  Summary tables aren’t scaled; each row of the
summary table just picks off where the last row left off.  You can’t add
stratigraphy columns, graphs, sampling types or monitoring well
schematics to the either a single or multiple-source data summary’s table.

Table 2.2 -- Uses for the Table Section
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2.3 Useful Concepts

The following sections provide some background material necessary before discussing the report
form editing process.

2.3.1 Fonts

For hardcopy reports, LD4 supports the full range of Windows TrueType fonts: these are fonts
that look the same whether they are displayed on the screen or printed on a printer.  LD4 doesn’t
support built-in, downloadable or cartridge printer fonts unless an equivalent TrueType font is supplied
by the printer manufacturer.  By not supporting printer fonts LD4 ensures maximum portability
between different hardware configurations.

➾ If a report form requiring a given font is moved to a computer that doesn’t have that font
installed, LD4 won’t complain.  Instead, the program will attempt to select an appropriate
substitute.  The report form may also be modified without having the font available -- LD4 will
keep track of the missing font and will begin using it once the form is moved back to the
original computer.

The following figure lists some fonts that are common to all versions of Windows (additional
combinations of fonts may be found on many computers).

Font Name Sample

Arial Windows is a computer virus with a
user interface

Times New
Roman

Windows is a computer virus with a user

interface
Courier

New
;MRHS[W�MW�E�GSQTYXIV�ZMVYW

[MXL�E�YWIV�MRXIVJEGI

Table 2.3 -- Built-in Windows Typefaces

➾ In addition, if you have Adobe’s ATM (Adobe Type Manager) program you can use the Type-
1 Postscript fonts that are included with software such as Adobe’s Illustrator program.
However, incompatibilities have been found between LD4 and ATM in printing text that has
been rotated from horizontal: if you have WindowsNT or Windows2000 you’re better off using
the operating system’s built-in ability to convert Type-1 fonts to TrueType.
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➾ In the interests of compatibility with LOGDRAFT III, the following fonts are always listed when
a report form created with the older program is edited:

SIMPLEX, SCRIPT, PRESTIGE, DEFAULT, HPSTICK, UNIVERS, CGTIMES,
CONDENSED, OLIVE, GARMOND, GOTHIC, CENTURY, NARROW, AVANTEGARDE.

Most of these fonts aren’t available in Windows -- choosing one of them will cause LD4 to use
a replacement font when the form is printed.

➾ When LD4 asks for a font size, the program is requesting the height of the font in points (one
point is 1/72”).  Users moving from LOGDRAFT III will recall that the old program used pitch,
or the number of characters that would fit in one inch: an easy conversion from pitch to points
is to divide 120 by the pitch (120/pitch=points).

➾ LD4 supports “normal”, bold and italic versions of each font.  Unlike Windows, the software

does not support bold italic, that is, a font that is both bold and italic.

➾  Using a fixed space font like Courier New to print your data allows you figure out exactly how
much space you need to reserve on your report for printing the contents of a data entry field
by using the following formula:

;!1
'
*4����

where:
; = width required, in inches, to print the field.

1
'
 = the maximum number of characters that may be typed into the data entry field.

*
4
 = the size, in points, of the font used to print the field.

Remember, this formula only works with a fixed-space font, which is one where every
character is the same width.  ('396-)6�2); is fixed-space, while Arial is a proportionally
spaced font.)  When you use a proportionally spaced font you can never tell the amount of
space that will be required to print a given data entry field:  printing MMMMM with a
proportionally spaced font takes up much more space than printing IIIII.

➾ If you do use a proportionally spaced font to print your data you should test out the report:
enter ;s into every data entry field of a sample boring then print the boring with your new

report form.  If the Ws don’t run too long then (like in the example below) then your report
should work with any data.

Figure 2.10 -- Field Printed in Too Narrow Space

Not enough space for the field
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➾ If you’ll using the report form to generate reports in AutoCAD .DXF format (see Section 3.2.7
in the User’s Guide) you should fixed-space fonts for everything: AutoCAD versions 13 and
older and IntelliCAD98 do not support TrueType fonts so LD4 makes substitutes a fixed-
space CAD equivalent.  Optionally, you can make up the form using proportionally spaced
fonts then save a copy (see Section 2.4) of the form that you can modify to only use fixed-
space fonts.

2.3.2 Measurement Units

Table column widths, page sizes, well construction pipe diameters and many other dimensions
may be changed as part of the report form editing process.  LD4 uses either inches or centimeters for
all dimensions; this choice is set through the Windows Control Panel (Section 1.3 in the User’s Guide
gives directions on changing the setting).  You may switch between measurement systems at any
time -- the next time you edit a report form, LD4 will convert all of your old measurements into the new
system.

2.3.3 Colors

Many parts of a LD4 report form may be designed in color; however, if the printer that is used to
produce the actual report doesn’t support color, Windows will decide how best to represent the color
using just black and white.  Often times the results may be undesirable.  It’s best to design your report
to only use black colors unless you will be using a color printer exclusively.

If your printer does support color you still may want to stick with black-and-white.  Color printouts
take longer to print and are typically more expensive to produce.  Additionally, if you will be exporting
the report to an AutoCAD-compatible .DXF file, note that the export facility supports a limited range of
colors.
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2.3.4 Paper Sizes

When setting up a report form, there are two paper sizes to consider: the as-designed page size,
and the as-printed page size.  While reports may be printed on any paper size, during the process of
designing a report form you must select a single paper size.  This selection determines the as-
designed page size: for the purpose of designing the form, the boundaries of the report page are set
to the as-designed size.

When it’s time to print the form, LD4 prints on the paper that is chosen through the standard
Windows print setting dialog (you can display this dialog just before printing by selecting Print >
Printer Setup).  By changing the print setting, the user can select a different as-printed page size.  If
the size of paper that was used to design the form doesn’t match the size of paper on which the form
is being printed, the program scales the as-designed form up or down to fit the as-printed paper.  This
allows the same form to be printed on letter-sized paper on a laserprinter and on an electrostatic
plotter on 11x17” paper.

2.3.5 Line Weights and Colors

LD4 report borders, table columns, etc. are composed of vertical and horizontal lines -- LD4
allows you to specify the weight and color of these lines.

�
�
�
�
�
�
�
� 'RXEOH�/LQHV

Figure 2.11 -- Line Weights

➾ Line weights are given in units of 1/300th of an inch: a � weight line is 1/300” thick; an �

weight line is 8/300” thick.

Note:  If you print your report at a resolution less than 300 dots-per-inch (dpi) the differences
between, for example, a � and � weight line will not be noticeable.

➾ Additionally, many lines may be drawn as “double”, meaning two parallel weight-1 lines.

➾ Note that due to current Windows limitations, all dotted and dashed lines are drawn as a 1
weight.
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2.3.6 Justification

Most of the items placed on a LD4 report form are justified, meaning that they are horizontally left,
right or center aligned, and vertically top, bottom or center aligned.  The diagram below shows the
effect of various justification selections on a groundwater symbol:

Figure 2.12 -- Effects of Justification Selections
(“V” for Vertical; “H” for Horizontal)

➾ Justification is always relative to the nearest item to the left, right, top and bottom of the item
being justified; the nearest item may be another item of text, a line, a graphical symbol, etc.

➾ When working on the report’s heading and footing, you can also select “None” for the vertical
justification: the item you’re placing is drawn at the bottom of the row where it was placed.

➾ In the report’s heading and footing, “None” horizontal justification draws the item in the
horizontal position that you placed it.

V:Top, H:Left

V:Top. H:Center

V:Top, H:Right

V:Center, H:Left

V:Center, H:Center

V:Center, H:Right

V:Bottom, H:RightV:Center, H:Left

V:Bottom, H:Center



Report Forms

42

2.3.7 Report Form Versioning

As a sort of “undo” option that lasts between editing sessions, whenever a report form is saved,
LD4 also saves several previous copies of the form.  If you find that you’ve made a mistake the last
time you edited a form and you aren’t sure exactly what you did, you can return the form to the state it
was in before you started your last editing session.

To revert a report form back to a previous version:

1. If you just want to get rid of any changes that you have made during the current editing session,
just choose Report > Abandon Changes.   If you want to go back to a version of the form older
than the one that you are currently editing, choose Report > Revert to Previous Version and
proceed to Step 2.

➾ If Revert to Previous Version isn’t available, then you are either A) editing a new form (which
of course doesn’t have any previous versions), or B) editing a LOGDRAFT III compatible
form.  LOGDRAFT III compatible forms can’t store previous versions -- if you would like to
use the versioning capability, select Sections > Form Settings and turn off the LOGDRAFT III

compatible form box.

2. LD4 will display a dialog listing the previous versions of this form that are available, in order from
newest to oldest.  (The dates and times shown for each version represent when the form was
saved with that version.)  To go back to a previous version, double-click on an entry in the list.

➾ Note that once you go back to a previous report form version any versions created after that
version are lost, including the one on which you were working.  However, this doesn’t become
permanent until you either save the form (using Report > Save) or exit (Report > Exit).  This
provides one “trick” that can be used to keep both an older and newer report version: after
reverting to a prior version, choose Report > Save As and save the form under a new name.
The original (newest) copy stays saved under the report’s original name and the older version
is saved under a newer name.

Copies of the earlier report form versions are saved in the same file as the current report form, so
they take up some file space.  Typically, this isn’t a problem, as the total report form file -- with backup
copies -- is usually smaller than 32K bytes; however, if you would like to save some file space
(perhaps because you will be e-mailing the form) or just to finalize your work, you can discard the
previous form copies by selecting Report > Strip Previous Revisions.  While this can’t be undone, you
can recover the revisions by selecting Report > Abandon Changes immediately.
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2.4 Creating and Modifying Report Forms

Caution:  Hard disk failures happen!  If you modify a report form, be sure to save a copy of the
modified form onto a floppy disk  or tape drive.

To modify a report form:

1. From LD4’s opening screen click on the Reports tab then double-click on the report you want to
modify.

or

1. Open up a project then preview a report on-screen (see Chapter 3 in the User’s Guide).

2. Choose Report > Change How This Form Looks...

or

1. Click on the  button at the lower-right of the LD4 data entry screen (see Section 2.5 in the
User’s Guide).

 

To create a new report form:

1. Choose an existing report form that looks similar to the form you want to create, then open it for
modifications by following the steps above.

2. From Report Form Designer choose Report > Save As and type in the name you’ve chosen for
your new form

or

1. From LD4’s opening screen click on the Reports tab.

2. Enter a name and description for your new report form then click on OK.  If a form with that name
doesn’t already exist, LD4 will create a new, blank version.

or

1. While modifying an existing report form choose Report > Create from Scratch.

2. Enter a name and description for your new report form.

➾ See Appendix B in the User’s Guide for guidelines on naming your new report form.

3. From the Create a New Report Form dialog (Figure 2.13) select the type of form you want to
create.



Report Forms

44

 
 Figure 2.13 -- New Report Form Dialog

➾ See Section 2.1 for a discussion of the various report types.

4. When editing a report form, LD4 looks up the data entry form associated with the report form to
figure out what data entry fields are available to be printed on the report (see Section 2.7).  From
the Data Entry Form dialog, choose the data entry form that you’ll be using with projects to be
printed with your new report.

Rather than editing whole report form at once, LD4 has separate facilities for editing the report’s
heading and footing, for editing the report’s table section and for placing small items of text anywhere
on the page, including outside the report’s border.  These facilities are discussed in the following
sections.

2.5 The Form Settings Dialog

The Form Settings dialog contains options that affect the entire report form such as the form’s
border style and the default font styles.  Choosing Sections > Form Settings displays the Form
Settings dialog -- since the dialog is tabbed, the following sections discuss each tab in detail.
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2.5.1 The Report Tab

Figure 2.14 -- The Form Settings "Report" Tab

➾ Style of report lists the report’s type -- see Section 2.1.  This setting may not be changed
once the form has been created.

➾ Form size -- LD4 reports are designed to fit within a certain page size (see Section 2.3.2).
Keep in mind that just because you’re designing a report for a given paper size it doesn’t
mean that you have to print the report on that size paper.  LD4 will adjust your report form to
fit any physical paper size.

➾ Orientation -- LD4 reports can be in either portrait orientation, which means the top of the
report runs along the short side of the paper, or landscape, which means that the top of the
report runs along the long side of the paper.

➾ LOGDRAFT III compatible form -- check this setting only if you’ll be using the form with the
old MS-DOS LOGDRAFT program.  When you save a report that uses this setting the report
looses all color  and TrueType font selections and all new reporting options not supported
with LOGDRAFT III.
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2.5.2 The Border Tab

Figure 2.15 -- The Form Settings Border Tab

The Border tab allows you to specify the thickness of the border drawn around your report -- you
can also choose a double-line border (see the example in Figure 2.16).

➾ Checking the Include company name in bottom center of border box adds the name of your
company to the bottom center of the border (again, see the example in Figure 2.16).  Note
that the company name included in the border is coded into the license file created when you
licensed the software: if your company name changes, contact GEOSYSTEM Software for an
updated license module.
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Figure 2.16 -- Report with Double-Line Border and Company Name
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2.5.3 The Head/Footing Tab

Figure 2.17 -- The Form Settings Head/Footing Tab

The Head/Footing tab determines the font that the program uses when you add text or a data to
the heading or footing of a report form.  You can always choose a different typeface or font size for
anything that you put onto the form -- the Head/Footing tab just determines the font that will be used if
you don’t choose something different.

➾ Checking the Underline the user’s data  option adds underlines to every data entry field that
you print in the report’s heading or footing, similar to the figure shown below:

Figure 2.18 -- Underlined Data Entry Field

(The boring log shown in Figure 2.1 includes a number of fields printed with an underline.)

Once again, the underline option is just a default: you can still tell LD4 omit the underline from
any single item that you add to the report (see Section 3.6).

➾ Choosing the titles and data will be located within boxes option provides an effect like the one
shown below:

Figure 2.19 -- Boxed Title and Data Field

Again, this effect is just a default that can be changed for any individual item added to the
form (see Section 3.6).
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2.5.4 The Table Tab

Figure 2.20  -- The Form Settings Table Tab

The Table tab determines the font that the program uses for the captions shown above the
report’s table, as well as the data printed in the table.   You can always choose a different typeface or
font size for anything that you place on the form: the Table tab just determines the font that will be
used if you don’t choose something different for any individual table column’s title or data.

2.5.5 Additional Form Settings for Profiles

When editing a profile form, the Form Settings dialog includes an extra tab, shown below.

Figure 2.21 - Form Settings Profile Tab

➾ Horizontal scale location:  This selection takes effect when plotting horizontally scaled profiles
(see Section 5.3.2 in the User’s Guide).  You can have the program draw a distance scale at
the top or the bottom of the profile table section, or to omit the scale altogether.
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Figure 2.22 -- Profiles with Scale at Top and Bottom

Note:  If you’re trying to add annotations to a profile for a project that doesn’t have boring location
coordinates (as discussed in Section 5.4.8 of the User’s Guide), you may want to choose the option to
drop the horizontal scale.  Otherwise, the scale will display your “fake” boring coordinates.

➾ Depth scale caption and Elevation scale caption: All profiles have scales, showing either depth
or elevation, on each side of the subsurface area.  Both elevation and depth scales have
captions that are printed on the side of the scale (“Elevation in Feet” in Figure 2.22): these
captions are entered at the Depth scale caption and Elevation scale caption prompts.

Note: When printing a profile the user can choose between scales in meters and scales in feet (see
Section 5.1 in the User’s Guide).  Since you don’t know when designing the profile form which units
will be used for the side scales, leave off the measurement units from your scale captions.  (For
example, instead of entering (ITXL� MR� JIIX for your depth scale caption, enter (ITXL� MR. )
When the profile is printed, LD4 will add the appropriate units to the end of the caption.

If you want LD4 to insert the scale units somewhere in the middle of your caption, use JIIX or
QIXIVW to mark where you want the units to go.  For example, (ITXL�MR�JIIX��170 will print out
as “Depth in feet, MSL” or “Depth in meters, MSL”, depending, of course, on the user’s choice for the
profile’s vertical scale.
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➾ Horizontal strata column offset:  This prompt allows you to choose how where LD4 will place
borings on horizontally scaled profiles.  Three options are available:  “No offset” starts plotting
each boring's information flush with the boring's horizontal coordinate,  “Center soil graphic
column at the boring location” plots each boring so that the center of the graphic soil column
is at the boring's horizontal coordinate and “Line the left edge of the soil graphic at the boring
location” plots each boring so that the left-hand side of the soil log column is at the boring's
horizontal coordinate.

The Horizontal strata column offset option is provided so that profiles showing data or
symbols on the left side of the boring's soil graphic column can have the soil graphic column
printed at the boring's horizontal coordinate, rather than having the boring data on the left of
the soil column start at the boring's horizontal coordinate with the soil column to the right of
that.

2.5.6 Additional Form Settings for Data Summaries

When editing either a single-source or multi-source summary form (see Sections 2.1.3 and
Section 2.1.4) the Form Settings dialog includes an extra tab, shown below:

�Figure 2.23 - Report Setting Summary Tab

➾ The Data table - rows of text between lines selection allows you to have horizontal lines drawn
between rows on the summary’s table, one line per source if you want to draw a line between
each boring on a multi-source summary or one line every X table rows as an aid to reading
the table.

➾ If you’ve chosen to draw lines on the table you can substitute greenbar-style shading by
checking the Rows are shaded instead of lined box.
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2.6 Margins

Choosing Sections > First Page Margins or Sections > Subsequent Page Margins displays the
Margins dialog, shown below.

Figure 2.24 -- Report Margins Dialog

The Margins dialog allows you to adjust the size of the blank space on the top, bottom, left and
right side of the report; additionally, you can adjust the height of the tabulated area of the report.

➾ For most forms you’ll want to provide a margin on the left or right edge for binding the report

into a spiral or three-hole punch binder.  If you’ll be printing logs on the front and back of the
paper, set up the left margins of the First Page Form to be 0.25” (0.64 cm.) then set up the

right margin of the Subsequent Page Form to be 0.25” (again, 0.64 cm).

If you’ll just be printing on one side of the page, set up the left margins for both forms to be
0.25” (0.64 cm.).

Note:  Inkjet printers use a paper handling method that renders a large section on the left edge of
portrait-oriented reports unusable (on landscape-oriented reports, a section along the top edge of the
report is lost).  If you’ll be printing on an inkjet you may have to use trial-and-error to get your margins
correct.

➾ The  Heading/Table margin is the blank space between the bottom of the report’s heading and
the horizontal line above the report’s table titles.  Similarly, the Table/Footing margin is the
blank space between the end of the report’s table and the top of the first title in the report’s
footing.

Note:  Providing a negative heading/table margin drops the heading down into the table’s title block.

➾ The Titles/Start of data margin allows you to specify a blank vertical space between the
bottom of the table’s title block and where the program starts printing the table’s data.
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Note:  For boring logs and other subsurface reports, if you choose to have a “continue” symbol shown
in the stratigraphy or monitoring well columns (see Section 4.6.4 and Section 4.13), LD4 requires a
minimum Titles/Start of data margin of 0.15 inches (0.38 cm).  If you select a smaller margin, LD4 will
override your selection when the report form is printed.

➾ The Table height measurement is useful for creating boring logs that show, for example,
exactly 60 vertical feet per page.  To do this:

1. Figure out the vertical scale you’ll be printing with (see Section 3.2.4 in the User’s Guide) -- this
will be “X” feet or meters per vertical inch or cm.

2. Figure your table height: if you want “Y” feet on a single page and your scale is “X” feet per inch,
your table height will be “Y/X” inches.

3. Open the Report Margins dialog for the report you’ll be printing with and enter the number you
figured in the previous step into the Table height field.  (The border of the dialog will say either
“Margins (in inches)” or “Margins (in centimeters)” -- make sure to use the correct measurement
units.)
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2.7 The Report’s Data Entry Form

Oftentimes when you’re modifying a LD4 report form you’ll be presented with a list of data entry
fields, such as the one below:

Figure 2.25 -- Dictionary

These lists, called dictionaries, give the names of data entry fields that are used to enter
subsurface, boring and project data.  You can print out what’s entered into these fields on a report,
use them in mathematical equations, use them to determine the lengths of sampling intervals, etc.  To
build this list, LD4 needs to know what items of information will be entered into your project files (so
that you only try to print data that you can actually enter).  Recall from Chapter 1 that LD4 uses a file
called a data entry form to determine what prompts and data entry fields will be shown to the user
when he’s entering data into his project.  LD4 also uses a data entry form file to determine the names
shown in a dictionary list.

LD4 uses a single data entry form file to figure out what items of data will be available for printing
with projects that use that data entry form.  While you’re editing a report form LD4 doesn’t know what
projects will be printed with the form so it can’t figure out which data entry form will be used with those
projects: you give the program this information by associating a particular data entry form with each
report form.
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Figure 2.26 -- How LD4 Builds a Dictionary
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When you’re modifying a report form, if you can’t find a data entry field’s name in the dictionary
you probably have the wrong data entry form associated with your report.  Follow the directions given
below to make sure LD4 uses the data entry form that you’ll be using with projects to be printed with
your report form:

To figure out what data entry form is associated with a report:

1. Open the report form for modification (see Section 2.4): the opening information screen
specifically lists the data entry form associated with the report.

 

To change the data entry form associated a report:

1. Choose Sections > Data Entry Form.

or

1. Click on the Can’t find  button displayed at the bottom of any dialog that shows a dictionary.
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3. Editing the Report’s Heading and Footing

A report form’s heading is the section of the form between the top of the page and the report’s
table; the report’s footing is the section between the bottom of the report’s table and the bottom of the
page.
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Figure 3.1 -- Report Heading and Footing
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3.1 The Report Heading / Footing Editor

Change your report’s heading or footing by choosing Sections > First Page Heading, Sections >
First Page Footing, Sections > Subsequent Page Heading or Sections > Subsequent Page Footing --
this brings up the Report Heading/Footing editor.

➾ When you’re creating a report form from scratch, begin  by working with the “First Page

Heading” and “First Page Footing” section.  Until you make the first modification to the
“Subsequent Pages” heading or footing, these sections of the subsequent page form
remain identical to what you’ve set up for the first page form.   Until you change the
subsequent page’s heading or footing LD4 applies any changes you make to the first page
heading/footing to the subsequent page as well.

Subsequent page heading and footing sections are usually just stripped-down versions of the
first page heading and footing (see Figure 2.8 for a good example -- notice that much of the
information from the first page’s heading isn’t repeated on the second page). Leaving your
“subsequent page” form modifications until after you’ve completed the first page heading and
footing means that you can just delete items from the subsequent page heading/footing until
you’ve removed all the unnecessary information.

As long as the heading or footing on the first page form is identical to the heading or footing
on the subsequent page form, if you make a change to the first page heading/footing the

same change will be made to the subsequent page form.  Once you make your first
modification to the subsequent page heading or footing, future changes made to the
first page form’s heading/footing will no longer be automatically copied to the
subsequent page form.

➾ You can return a subsequent page heading or footing so that it matches the first page version
by opening up the first page heading or footing and selecting Special > Make Subsequent
Pages Identical.
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Figure 3.2 -- Report Heading/Footing Editor

➾ The heading and footing sections are divided into columns -- the width of each column
depends upon the Default font for titles that you’ve selected from the Head/Footing Form
Settings tab (see Section 2.5.3).  When you place something onto a report’s heading or
footing, it always shifts to the nearest character column.

Heights of each
row, in either

inches or cms.

The rectangles
represent the

contents of data
entry fields to be

printed
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3.2 Drawing Horizontal and Vertical Lines

You can draw horizontal or vertical lines in your report’s heading or footing.  The screenshot in
Figure 3.4 shows a report form that utilizes a number of different lines.

To draw a line on the heading or footing of your report:

1. Open the report heading or screen (see Section 3.1).

2. Choose Add > Lines.

3. In the Line Properties dialog, choose the weight and color of the line to be drawn.

 
 Figure 3.3 - Line Properties Dialog

4. Move the mouse to the row and column where the line will start then click the left mouse button.

5. Move the mouse to the row and column where the line will end then click the left mouse button.

Note:  Vertical lines always “snap” to the nearest character column, as do the left and right ends of
horizontal lines.  If you change the size of the Default font for titles  the relative locations of the
report’s lines will shift around.  (For example, if you halve the default font size, a given vertical line will
be twice as close to the left-hand report margin.)
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To extend or shrink a line that you’ve already drawn:

1. Make sure that the  button is down then move the mouse cursor over the line and click the left
mouse button: “grabhandles” should appear at either end of the line.

2. Press the left mouse button with the mouse over the grabhandle at the end of the line to be
moved then, while holding the button down, drag the mouse to shift the line end.

�Figure 3.4 -- Line Selected for Modification

 

To delete a line:

1. Make sure that the  button is down then move the mouse cursor over the line and click the left
mouse button: “grabhandles” should appear at the end-points of the line.

2. Select Edit > Delete.

 

To change a line’s weight or color:

1. Make sure that the  button is down then move the mouse cursor over the line and click the left
mouse button.  The “grabhandles” shown in Figure 3.4 should appear along with the Line
Properties dialog shown in Figure 3.3.

2. The dialog shows the current weight and color for the line: once you’ve made your changes, click
anywhere on the report form to see the result.

Line selected for
moving and

editing.  Note
grabhandles
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3.3 Drawing Rectangles

LD4 also includes a tool for drawing rectangles on the heading or footing of a report.

To draw a rectangle on the heading or footing of your report:

1. Open the report heading or footing screen (see Section 3.1).

2. Choose Add > Rectangles.

3. Check the Line Properties dialog (Figure 3.3) to make sure that the correct line weight and color
are selected.

4. Move the mouse cursor to the location for the top-left corner of the rectangle then press the left
mouse button.

5. While holding the left mouse button down move the mouse cursor to the location for the bottom-
right corner of the rectangle then release the left mouse button.

➾ Once you’ve drawn a rectangle LD4 treats it as four separate lines so you can delete or move
an edge of the rectangle without affecting the other edges.
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3.4 Inserting and Deleting Rows

To delete an entire row from the report heading or footing:

1. Open the report heading or footing screen (see Section 3.1).

2. Click the mouse in the row height column on the row that you want to delete, then choose Edit  >
Delete Row.

 

To insert a row into the report’s heading or footing:

1. Open the report heading or footing screen (see Section 3.1).

2. Click the mouse in the row height column on the row that will be immediately below your new row,
then choose Edit > Insert Row.

 Note that you don’t need to go through this procedure if you’ll be adding a new row below the last
row that has something on it -- just use the blank row that’s already there.
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3.5 Adding Text and Data Entry Fields

You can add plain text or the contents of a data entry field to the heading or footing your report
form.  Many times you’ll want to do both at once:  In the example below,

         Project No.: ��E�������
the “Project No.” part remains constant for every report you print, while the “99a123.012” was typed
into a data entry field -- when setting up your report form the “Project No.:” part and the data entry
field printout are added at the same time.

To print text or a data entry field in a report’s heading or footing:

1. Open the report heading or footing screen (see Section 3.1).

2. Choose Add > Text.

3. Move the mouse cursor to the row and column where the text is to be located then click the left
mouse button.  LD4 responds by displaying the Text and Data dialog.

 
 Figure 3.5 -- Text and Data Dialog

4. Enter any kind of static text into the Text  field.  (In the example discussed earlier, 4VSNIGX�2S�

would be in the Text  field.)

 You can insert type symbols such as Greek letters, the degree symbol, etc., into the Text  field by
pressing function key F9 -- see Section 2.5.1 in the User’s Guide for details.

5. The User-entered or calculated data field is for selecting a data entry field whose contents will be
printed.  The dictionary below the field lists the data entry fields available for printing. In the
example discussed in the beginning of the section, 463.C291 (the name of the data entry field

used for entering project numbers) would be entered into the User-entered or calculated data field.

➾ The Source and Project dictionary tabs select different types of data entry fields: Source data
entry fields contain data about a single boring, test pit, etc., while Project fields contain data
about the entire project (such as the Project Number).

 The Calculated tab lists information that LD4 comes up with on its own without data entry.
Examples include the current date and time, the name of the project, etc., as well as figure and
page numbers, which are discussed in Section 3.15.
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➾ One of the most useful fields listed on the Calculated tab is BORINGEND: this field lets you
print the depth to the bottom of the boring without adding a data entry field.  LD4
automatically calculates the boring termination depth based upon the depth entered into the
last data entry card: that value is placed into BORINGEND.  If you use the Text and Data
dialog to add the text &SVMRK� XIVQMREXIH� EX� and place &36-2+)2( into the User-

entered or calculated data field, your reports will show the boring termination depth.

 Double-click on a field listed in the dictionary to include that field in your report.  If you also
entered something into the Text field, the data entry field will be printed just to the right of the Text

field’s contents.

6. Before closing the dialog, check the Title and Data Settings dialog (this is a second dialog that is
always displayed when you’re adding a piece of text or a data entry field to the report form).  The
current settings of this dialog determine where your new items will be printed, as well as the font
used to print them.  This dialog is discussed further in Section 3.6.

7. Clicking on the Place button adds the new title and/or data to the report form.
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3.6 The Text and Data Settings Dialog

The Text and Data Settings Dialog affects the appearance of any new item placed onto the
report’s heading or footing section: the current font and justification settings showing in the dialog are
attached to the new item.

Figure 3.6 -- Title and Data Settings Dialog

➾ When you click on the Place button (see Section 3.5) the new text/data field added to the
report are assigned the font and jusification settings displayed in the Text and Data Settings
dialog.

➾ If you don’t change them, the font selections given to the newly added text/data field are
those chosen in the Head/Footing tab of the Form Settings dialog discussed in Section 2.5.

Also, the font for all text or data fields that are using the default font selections can be
changed by modifying the font selections on the Head/Footing tab of the Form Settings dialog.

➾ If you change the font selections from the default values the new selections remain in effect
for any text/data field added to the report in the future: to get back to the default selections,
click on the Reset button.

➾ The Justify settings allow you, for example, to center an item of text vertically within a
rectangle.  The figure below shows the effect of some common Justify settings:

Figure 3.7 -- Justify Settings Example
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ENGINEER/ARCHITECT, DRILLING FOREMAN,  MUD INSPECTOR, etc. were set up with
“V: Center, H: None” title justify.  Look at the screen-dump of the report form’s heading shown
below: the “H: None”  horizontal justification setting ensures that ENGINEER/ARCHITECT,
DRILLING FOREMAN and  MUD INSPECTOR print out at the horizontal location where they
were placed on the report form.

Figure 3.8 -- Previous Example Report Design Screen

In contrast, notice in the printed version that CASING and SAMPLER are centered vertically
and horizontally while in the report design they are aligned to the left.  This demonstrates the
effect of the “V: Center, H: Center” justification, which centers the item both vertically and
horizontally within its surrounding borders.

See Section 2.3.6 for a further discussion of justification.

➾ Checking the Box title and data selection overrides the justification selection -- instead, LD4
automatically selects “V:Top, H:Left” justification for the title and either “V:Bottom, H:Center”
or “V:Center, H:Right” justification for the data field, depending upon the height of the box in
which the items are being placed.  The overall effect is shown below:

Figure 3.9 -- Boxed Title and Data Field
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3.6.1 Boxed Titles Split onto Two Lines

Sometimes a boxed title is split onto two lines:

Figure 3.10 -- Two-Line Boxed Title

LD4 doesn’t officially support this; however, there is a way to get the same effect:

1. Place the second line of the title on the row below the first line.  Attach your data field to the
bottom title, and make sure that both title lines are inside the same box.  The figure below shows
how our example would be set up on two rows (the shaded rectangle represents the data entry
field printout added with the bottom title):

 
 Figure 3.11 -- Two-Line Title Setup
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3.6.2 Underlining Options

Data entry fields printed in the heading or footing of a boring log are sometimes underlined
(traditionally, so they could be completed by hand); to duplicate this effect with LD4 choose either
“underlined, left justify” or “center over underline” from the Underline field on the Data Text and Data
Settings tab.

Figure 3.12 -- "Underlined, Left Justify" and "Center Over Underline"

➾ When an underlined data entry field printout  is added to the report’s heading or footing, the
underline extends to the right until it hits something (either another title or data item, a vertical
line or the right side of the form).  If you’d like to cut the underline short (for example, to leave
some blank space between the underline and a title on the right), draw a vertical line where
you want the underline to end.  Make sure before drawing the line to make the weight of the
line “invisible” so that it doesn’t actually show up on the form (see Section 3.2).  Alternatively,
you can add a title consisting of a single B (caret) symbol where you want the underline to

stop: LD4 doesn’t draw the B symbol, but it does serve to stop the underline from continuing.

The figure below shows the effect of adding a B title to stop the underline:

Figure 3.13 -- Caret Used to Stop Underline

3.6.3 The “Plot Last” Option

The Plot last checkbox on the Title and Data Settings dialog is reserved for those very rare items
for which LD4 won’t have a value until it’s done plotting the entire report page (such as a list of the
boring numbers for all of the borings plotted on a profile).

➾ Checking Plot last when printing a normal data entry field causes no noticeable effect -- the
field will just be printed after everything else on the page.
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3.6.4 Right-Aligning a Column of Text

Figure 3.14 -- Right-Aligned Column of Numbers

To produce a right-aligned column of text similar to the column of numbers in the example shown
above, follow these steps:

1. Draw a vertical line at the position where the right-edge of the column should be.  Make sure that
the line extends from the row that has the first text item to be aligned to the row that has the last
text item to be aligned.  (See Section 3.2 for line drawing instructions.)

2. Make the line weight “invisible”.

3. Make the “H:” justification for each text item to be aligned “H: right” (see Section 3.6).  Typically,
“V: none, H: right” is chosen.  This right-aligns all of the text against the line that you drew in Step
1.  Since the line’s weight is “invisible”, when the report is printed you get a nicely aligned column
of text without the line showing what the text had been aligned against.
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3.7 Modifying and Deleting Text and Data

Text and data placed into the heading or footing of a report can be modified or deleted:

To change a text item or data field already placed in a report’s heading or footing:

1. Open the report heading or footing editor (see Section 3.1).

2. Locate the title or data field to be modified.  Data entry fields, logos, groundwater symbols and
everything else that isn’t a simple piece of text is represented on-screen by a magenta rectangle:
if you move your mouse over the rectangle LD4 will pop up a hint window listing the item
represented by the rectangle.

 Note:  The hint window shown over data items sometimes lists a shorthand notation for what’s being
printed.

3. With the mouse over the item to be modified, click the left mouse button: this displays the Title
and Data Modification dialog shown in Figure 3.5.

 If the data item to be printed is something besides a data entry field (for instance, a groundwater
symbol or a logo) you’ll need to click on the Edit... button to modify the data item.

 

To change the font for a text or data item:

1. Follow the steps given in the previous list.

2. The Text and Data Settings dialog (see Section 3.6) lists the fonts used for the text item and/or
data that you’ve selected for modification: use these to change to your desired font(s).  (See
Section 2.3.1 for a discussion of fonts.)

3. Click on the Place button.

 

To delete a title or data field already placed in a report’s heading or footing:

1. Follow the instructions for modifying a title or data field (above): this displays the Title and Data
Modification dialog shown in Figure 3.5.

2. Click on the Delete  button.
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To move a title or data field already placed in a report’s heading or footing:

1. Open the report heading or footing editor (see Section 3.1).

2. Locate the title or data field to be modified.  Data entry fields, logos, groundwater symbols and
everything else that isn’t a simple piece of text is represented on-screen by a magenta rectangle:
if you move your mouse over the rectangle LD4 will pop up a hint window listing the item
represented by the rectangle.

 Note:  The hint window shown over data items sometimes lists a shorthand notation for what’s being
printed.

3. With the mouse over the item to be modified, click the left mouse button and, while holding the
button down, drag the item to its new location.

3.8 Changing the Font for Multiple Items

To change the font, size or color for multiple items simultaneously:

1. Open the report heading or footing screen (see Section 3.1).

2. Click on the  button.

3. Use the left mouse button to draw a rectangle around the items that you want to modify.

4. Use the Text and Data Settings dialog (discussed in Section 3.6) to make your changes.  Note

that if a field on the dialog is blank it means that the items you selected for modification use at
least two different settings for that field.

5. Click on the OK button to make the change, or Reset  to change all of the settings back to the
defaults chosen through the Head/Footing tab of the Form Settings dialog discussed in Section
2.5.

Note: If you want to change the font used by all of the text or data placed on the heading or footing of
a report form, see Section 2.5.
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3.9 Adding Logos and other Pictures

Logos and other pictures drawn using the Windows “Paint” program, digitized with a scanner or
created with publishing program such as Adobe’s Illustrator may be added to the heading or footing of
a report form.

➾ Picture and logo files must be in the standard Windows .BMP format -- if you are using an
illustration program it should provide a means to write this type of file.  For compatibility, LD4
also supports the black and white .PCX format used by LOGDRAFT III.

➾ If you have purchased any of the GEOSYSTEM for Windows laboratory testing modules, you

may have received a custom .BMP logo file that is shown on your lab. testing reports.  Note
that this file is encrypted so that it cannot be edited (illustration programs will display
“static” if the file is opened); LD4, however, can still use the logo.

➾ .BMP files may be color; however, note that color pictures don’t plot very well on a black-and-
white printer.  (Sometimes, due to bugs in Windows’ printer drivers, color pictures may not
print at all on black-and-white printers.)

➾ LD4 plots all picture files at a resolution of 300 pixels per inch: if your paint program says that
your picture is 600 pixels wide by 300 pixels tall, you’ll get a 2 inch by 1 inch picture on your
printout.

If your paint program reports your picture size in inches or centimeters, the measurement is
meaningless as far as LD4 is concerned (remember, LD4 measures in pixels, not in inches);
however, if the paint program also gives the picture’s resolution (in dots per inch) you can
multiply the resolution by the picture dimensions (in inches) then divide by 300 to get the size
of the picture when printed on an LD4 report.
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To add a logo or picture to the heading or footing of your report:

1. Open the report heading or footing editor (see Section 3.1).

2. Choose Add > Picture.

3. LD4 displays the Text and Data Settings dialog discussed in Section 3.6.  Make sure to set the
Justify selection correctly:   A picture placed with a “None” vertical justification (see Section 2.3.6)
will print at the bottom of the current row; if you’re drawing the picture inside a rectangle, choosing
“V: Center, H: Center” will center the picture inside the picture.  (For a further discussion of the
effects of various justification selections, refer to Section 3.11.)

 Note: If your picture file has a great deal of whitespace at the top, left, bottom or right LD4 may
not correctly justify the picture because the program treats the whitespace as part of the picture.
To correct the problem, use a picture editor to crop the picture so that there is approximately the
same amount of whitespace on the top, bottom, left and right sides of the picture.

4. Move the mouse to the location where you want the logo to appear then click the left mouse
button.  This displays the Pictures and Logos dialog, shown below:

 
�Figure 3.15 -- Pictures and Logos Dialog

5. From the dialog enter the name of your logo file into the top prompt.  Do not enter the path to the
file or the file’s extension; e.g., instead of

 6�@0(�@1=03+3�&14

 enter

 1=03+3

 Note: Picture files must be placed into the hard disk subdirectory in which LD4 is stored.  (See
Section 8.1.1 for instructions on finding this directory.)
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Alternatively, instead of showing the same picture on every report printed with the form, the report
can be designed so that a different picture is selected for each boring printed.  This is useful for
showing a picture or map of each drilling site.

To choose during data entry which picture will be drawn on the report form:

1. First off, you need a data entry field where you can type the name of the picture should be
displayed.  Use the techniques discussed in Section 1.3 to add a field to the data entry form that
you’ll be using: if you want to choose the picture on a project-by-project basis, add the field to the
data entry form’s “Project” section; otherwise, add it to the “Source” section.

2. Next, follow steps 1-4 in the previous section.

3. At the Alternatively, choose the name of the field that will be used to determine the name of the

picture at print time prompt enter the name of the data entry field you added in step 1.

 Note:  Optionally, you don’t need to add a new field.  Instead, you can give your pictures the
same name as the boring on which they will be used (e.g., &���&14, &���&14, etc.) then enter

&36-2+ into the Alternatively, choose the name... prompt.

 If you have a site map that changes on a project-by-project basis, save your site map using the
project number as the picture filename (e.g., �������E�&14) and enter 463.C291 into the

Alternatively, choose the name... prompt.

➾ Note that you may place the picture file into either in the program’s directory or in the .GEO
directory that stores your project file.

➾ During the report design process, if you select Report > Preview naturally LD4 won’t be able
to show a logo on your report because the name of the logo file won’t be known until the
report form is combined with data from a specific project file.
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3.10 Adding A Symbols Legend

If you’re building the kind of symbol legend form discussed in Section 2.1.7, after you’ve drawn
the form’s border, added a title to the top of the page and maybe added a figure number, the next
step is to add the actual legend to the page.  The legend itself is almost always added to the report
form’s heading section.

To add a legend to a new legend report form:

1. Open the report heading or footing screen (see Section 3.1).

2. Choose Add > Legend.

3. LD4 displays the Text and Data Settings dialog discussed in Section 3.6.  Set the Font, Size, Color

and Style according to how you’d like to format the descriptions printed next to each symbol on
the legend.  (See the sample legend shown in Figure 2.6 for an example of how the descriptions
are printed.)

 Ignore the Justify prompt: Legends are always printed starting at the top-left of whatever
available whitespace surrounds them.

4. Point the mouse at the top-left corner of the area where you want the legend to be printed then
click the left mouse button.  LD4 responds by displaying the dialog pictured below:

 
�Figure 3.16 -- Legend Dialog

5. Set the Symbol column title and Description column title:  These allow you to choose the captions
for each column of symbols printed on the legend.  (In the sample legend shown in Figure 2.6
“Symbol” is the title above the column of symbols and “Description” is the title above the
descriptions.)

 If want to save space on the form (and avoid stating the obvious) you can leave both of these
fields blank.
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6. Set the Number of columns:, which allows you to tell LD4 how many columns of symbols can be
fitted onto one legend page (for this prompt, a “column” is a symbol and its corresponding
description.)  The legend in Figure 2.6 was designed for three columns: Notice that as a result,
many of the descriptions can fit only one or two words on a line.  This prompt also has an �EYXS�

selection that will let LD4 make the decision on how many columns will be fitted to a single page --
this is the recommended setting.

7. Set the Symbol square dimension:, which determines the dimension of one side of the squares in
which soil and rock patterns are drawn.  The stock legend form shipped with LD4 uses 0.4 inch (1
centimeter) symbol squares.

8. Set the Omit the legend notes? selection: optionally, legends can include a set of notes on the first
page of the legend.  If you’ll be including a legend on the same page as a boring log or profile
(this option will be discussed shortly), there isn’t enough room on the page to include the notes --
check Omit the legend notes? to leave them off the report.

9. Set the To limit the legend to only particular groups of symbols... field: a normal legend report

includes all of the symbols used on the boring logs, profiles, etc., just printed (e.g., soil patterns,
groundwater symbols, sampler symbols, monitoring well sections, etc.).  You can use this field to

limit what classes of symbols appear on the legend.  To see what classes of symbols can be
printed on a legend, open a project file and click the Legend tab on the bottom of the left panel on
the data entry screen or, if Legend isn’t available, choose Legend > Edit the Default Legend.  The
classes of symbols are listed on the left panel and are usually “STRATA” (the soil and rock
symbols), “MISC” (groundwater, caving, seepage, etc. symbols), “SAMPLERS” and “WELL”
(“Notes” is not a symbol class).

 If you want to include multiple classes, enter the names of all of the classes that you want to print;
separate each name with a semicolon; for example, 786%8%�;)00.

 The normal use for this option is to limit the legend so that it only shows soil and rock symbols (by
entering 786%8% into the field) or only soil, rock and sampler symbols (by entering

786%8%�7%140)67).  This is most useful when including a legend onto the same page as a

boring log or profile.

10. Skip the If you would like to always take the symbol descriptions from a particular symbol
key file field: normally when you print a legend LD4 gets the descriptions printed next to the each
symbol on the legend from the legend file associated with the project being printed.  (Refer to
Chapter 4 in the User’s Guide for a discussion of how a legend file is associated with a given
project.) This selection is strictly for backwards compatibility.

11. Finally, click OK to add the legend to the report form.

You can also add a legend to a boring log or profile form.  (Typically, instead of presenting a
complete key to all of the symbols used on that report, legends on boring log or profile forms only
show one type of symbol such as a legend showing the types of samplers used in the boring.)  As an
example, the sample profile form called LEGPROFA includes a legend showing descriptions for the
soil/rock symbols used on the profile.
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Figure 3.17 -- Profile with Stratigraphy Legend in Lower Left

To add a legend to a boring log or profile form:

1. Open the report heading or footing editor (see Section 3.1).

2. Keep in mind that legends utilize all of the blank page space surrounding them.  If, for
example, you only want the legend to extend one-half of the way to the right side of the page,
draw a vertical line in the column where you want the legend to stop.  (If you don’t want the line
you’ve drawn to show up on your printed reports,  select “invisible” as the line’s weight as
discussed in Section 3.2.)

 The sample profile PLNPROFB includes a legend of the soil/rock symbols used on the report: as
you can see from the figure below, the legend has been included inside an (invisible) rectangle so
that some space is left between the plan rectangle (denoted by dashed lines) and the legend on
the left, and the legend and the title block on the right; without the rectangle the legend would
start just to the right of the plan box and run all the way to the title block on the right.

 
�Figure 3.18 -- Footing Design Screen showing Legend Placement

3. Choose Add > Legend.

4. LD4 displays the Text and Data Settings dialog discussed in Section 3.6.  Set the Font, Size, Color

and Style according to how you’d like to format the descriptions printed next to each symbol on
the legend.  (See the sample legend shown in Figure 2.6 for an example of how the descriptions
are printed.)

Legend placed
here.  Note
surrounding
rectangle.
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5. Point the mouse at the top-left corner of the area where you want the legend to be printed then
click the left mouse button.

6. Set the To limit the legend to only particular groups of symbols... field to the type of symbols that
you want to print on the legend.  (Typically, if you’re adding a legend to a profile, you’ll enter either
786%8% or 786%8%�7%140)67.)

 To see a list of all types of symbols that can be printed on a legend, open a project file and click
the Legend tab on the bottom of the left panel on the data entry screen or, if Legend isn’t
available, choose Legend > Edit the Default Legend.  The classes of symbols are listed on the left
panel and are usually “STRATA” (the soil and rock symbols), “MISC” (groundwater, caving,
seepage, etc. symbols), “SAMPLERS” and “WELL” (“Notes” is not a symbol class).

 If you want to include multiple classes, enter the names of all of the classes that you want to print;
separate each name with a semicolon; for example, 786%8%�;)00.

7. Finally, click OK to add the legend to the report form.

➾ Tip: A report may be set up the report to just print the legend notes, without showing any
symbols, by entering 237=1&307 into the To limit the legend to only particular groups of

symbols... field and making sure that the Omit the legend notes box is unchecked.  This is a
handy method for creating a per-project set of notes that may be included on profile reports.
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3.11 Adding a Single Graphical Symbol

Single graphical symbols may be placed into your report’s heading or footing.  This is useful, for
example, in showing keys to symbols used in the subsurface portion of the log.

➾ Graphical symbols are taken from the symbol libraries discussed in Chapter 9, which also
gives instructions on drawing new symbols.

Note:  This section contains instructions for placing a single symbol into a report’s heading or footing
section.  If you’re looking to place a symbol into the scaled subsurface table of a report see Section
4.11.6.

Figure 3.19 -- Groundwater Symbols Key

Figure 3.20 -- A Sampler Key

To add a graphic symbol to the heading or footing of a report:

1. Open the report heading or footing screen (see Section 3.1).

2. Choose Add > Symbols.

3. LD4 uses the Justify setting of the Title and Data Settings dialog to figure out where to draw  the
symbol. The figure below shows the effects of the setting (vertical justification is listed first then
horizontal):

Figure 3.21 -- Justify Setting for Symbols

 Change the Justify setting as needed (“V: None, H: None” sets the symbol so that it sits at the
bottom of the row on which it is placed.)

Top-Left

Top-Center

Top-Right

Center-Left

Center-Center

Center-Right

Bottom-RightBottom-Left

Bottom-Center
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4. Move the mouse to the location where you want the symbol to appear then click the left mouse
button.

5. From the Symbol library prompt on the “Place a symbol” dialog choose the file that holds the
symbol you want to add to the form.  The following table lists the symbol files shipped with the
stock program:

Symbol Library Usage

MISC Holds groundwater, caving and miscellaneous symbols

STRATA Holds the patterns used to represent soil and rock in the
stratigraphy column

SAMPLERS Holds the symbols used to visually represent sampler
types

PIPES Holds the symbols used to display well top caps and pipes

Table 3.4 -- Symbols Libraries

5. In the Symbol box, select the symbol that you want to display.  Tip: Clicking on the “...” button
displays the symbols stored in the symbol library that you’ve chosen.

6. Click on the Symbol size and color tab.

7. Enter the width and height of the symbol -- if you leave the Width and Height prompts blank LD4
will draw the symbol at the size in which it was originally designed.

8. Click OK to place the symbol onto the form.
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3.12 Adding Formatted Text

LD4’s most complex reporting option is its Formatted Text facility, which can be used for:

� Combining text and data.  For example

       Page 1 of 2
combines some static text (“Page” and “of”) with the sequential number of the page currently
being printed (“1”), and a count of the total number of pages to be printed (“2”).

� Formatting numeric data before printing.  This is useful, for example, in printing

    Elevation: 132.40m
With LD4’s Formatted Text options you can ensure that 2 digits are always printed to the right
of the decimal point for elevations, even if data entry personnel sometimes enter elevations to
three decimal places and at other times enter only one decimal place.

� Adding text to a report form that only shows up on certain pages of a printout, or when a given
condition is satisfied.  For example, you might want to include

    Boring Continues
on boring logs that extend over multiple pages.  Obviously, “Boring Continues” should be
omitted from the final page of each boring log.

The Formatted Text facility can also be used to format text added to the report form’s table.  Section
4.6.2 covers this option in detail.

If you’re just looking to print a simple data field, possibly with a title printed to one side, such as

         Project: Berthod National Airport
refer to the instructions given in Section 3.5.  If, however, you need to combine multiple data entry
fields into a single piece of text, reformat what’s typed into a data entry field prior to printing, only print
a piece of text under certain conditions, or any combination of these options, proceed with the
following steps.
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To add formatted text to the heading or footing of a report:

1. Open the report heading or footing editor (see Section 3.1).

2. Choose Add > Formatted Text.

3. LD4 displays the Text and Data Settings dialog discussed in Section 3.6.  Set the Font, Size,

Color, Style, Justify and Underline options according to how you’d like the new text to appear.

4. Move the mouse cursor to the row and column where the text is to be located then click the left
mouse button.  LD4 responds by displaying the Formatted Text dialog.

 
�Figure 3.22 -- Formatted Text Dialog
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5. To use the dialog, break the text you want to print into pieces.  Each piece represents either: A) a
section of text that never changes (fixed text), B) a blank space, C) a line break or D) the contents
of a data entry field or equation calculation (entered or calculated text).  The figure below shows
how this is done for each of the formatting examples discussed earlier:

 

Page 1 of 2

 

Boring Continues

 

Elevation: 132.40m

 Figure 3.23 -- Formatted Text Samples

➾ In the first example, “Page” and “of” are fixed text because they remain the same on every
page of every report printed.  “1” and “2” are calculated items because LD4 determines their
value on each report page based upon the current page count and the count of the total
number of pages to be printed.

➾ In the second example, “Boring Continues” is fixed text: Although LD4 can be set up to decide
to print “Boring Continues” based upon whether or not the page is the last page to be printed
for the boring, if it’s printed, the text always remains the same.

Fixed Text

Fixed Text
Calculated
Information

Calculated
Information

Fixed Text

Fixed Text
Data Entry

Field
Fixed Text

Blank Space

Blank Space
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➾ In the third example, “Elevation” and “m” are fixed text while the “132.40” was typed into a
data entry field.

6. To add each fixed text or data entry field piece that you obtained by breaking up your text in the
previous step, click on one of the Add buttons in the top-left of the dialog:

 To add a piece of fixed text (i.e., something that will not change):  Click on the Fixed text

button.  The dialog changes to show a field where you can type in the text.

Figure 3.24 -- Formatted Text Dialog, Fixed Text Entry

 After you’ve typed in the fixed portion of the text, choose one of the Add buttons to continue, or
click on OK.

Enter Fixed Text
Here
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 To add the contents of a data entry field, a page or figure number: Click on the
Entered/Calcd. button.  The dialog will change to show a dictionary where you can choose the
field you want to print.

Figure 3.25 -- Formatted Text Dialog, Entered/Calcd. Selection

➾ Select a data entry field to print by double-clicking on a selection in the dictionary.
(Dictionaries are discussed in Section 2.7.)

➾ You can also have the program print the results of a calculation (which is useful, for example,
for converting units  --  )0):%8-32����� converts an elevation from US to SI units):  Type

your equation into the field at the bottom of the What to print panel.

➾ Click on the It is a number selection to print the contents of a data entry field or a calculation
in a fixed format.  For example, you can make sure when printing elevations that they are
always printed with two digits to the right of the decimal..  To format your data as a number,
click on the It is a number checkbox.
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LD4 responds by showing two new prompts: Digits to the left of the decimal and Digits to the

right of the decimal.  The Digits to the left of the decimal prompt is useful when adding
formatted text to the table portion of a report: By filling in a number in this prompt, then
choosing Center horizontal justification, you get a column of numbers that are lined up, like
this:

1.4
0.9
13.0
-2.0
0

(This list was formatted with � digits to the left of the decimal).

When adding a formatted text item to the report’s heading or footing, usually the Digits to the

left of the decimal field is left blank.

Similarly, use the Digits to the right of the decimal to maintain a consistent number of digits to
the right of the decimal point.  Numbers that are entered with less than the requisite number
of digits are padded with zeros; e.g., �� printed with a format of 2 digits to the right of the

decimal shows as �����.

Numbers with more than the requisite count of digits are rounded; e.g., ������� printed with

three digits to the right of the decimal is �����.

A note on rounding:  Computerized arithmetic is inexact.  If you enter an elevation of ������� the
computer may actually store it as 1000.249999999...  When such a number is rounded to a single
decimal place the result becomes 1000.2, not 1000.3 as you would expect from 1000.25.  There’s
very little that can be done about this, with one exception: If you know that you’ll always be entering
your data to, for example, 2 decimal places, add 0.005 to the number you’re trying to print.  For
example, when printing “ELEVATION-DEPTH” and  entering ELEVATION and DEPTH to a maximum
of 2 decimal places (e.g. �������� JIIX), print “(ELEVATION-DEPTH)+0.005”.  In our original
example, if 1000.25 was stored by the computer as 1000.249999999..., adding 0.005 before printing
makes the number 1000.25499999, which when printed at one decimal place correctly rounds to
1000.3.

➾ To convert a measurement entered in decimal feet to one in feet and inches, choose the It is
a measurement in ft. and in. checkbox: this prints, for example, a measurement of ���� feet

as ��
�z.

➾ LD4 also includes a handy formatting for printing material descriptions in the subsurface
portion of a profile: Since there’s seldom room enough to print the entire description, you can
choose the It is the first sentence of a description checkbox to only print the first sentence of
each description.
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➾ The Print the text even if this is missing is important if you are combining the contents of two
or more data entry fields for printing: if nothing was entered into one of the fields, the other
field will still be printed.

As an example, if you set up a formatted text item to print “Elevation: (some elevation)m.” and
the user neglected to enter an elevation, without the Print the text even if this is missing

selection, nothing would print.  With the selection chosen,  )PIZEXMSR�� Q� would be

printed.

After you’ve selected the field or equation to be printed, choose one of the Add buttons to
continue, or click on OK.

3.12.1 Specifying Which Report Pages will Show the Formatted Text

Sometimes it’s handy to have a piece of text show up on a report only if certain conditions are
met: one example would be the “Boring Continues” message, which obviously should not be printed
on the last page of the report.

The Only print when this equation is “true” or “not zero”  field at the bottom of the formatted text
dialog is used to enter an equation that LD4 will evaluate before adding the text item to the report
page currently being printed: if the equation evaluates to true or any number besides 0 the text item
will be printed on that page.

➾ If you want your text to print on every page printed using the report form, leave this field
blank.

Some useful control equations:

Equation Usage
6)791)(# Does not print the text on the first page of each boring

log

6)791)(#!� Prints the text only on the first page of each boring log

'328-29)# Prints the text on every page of a boring log but the
last

'328-29)#!� Prints the text only on the last page of each boring’s
report

Table 3.5 -- Useful Formatted Text Control Equations

Appendix A covers LD4’s math equations; Appendix B provides a list of LD4’s built-in values such as
RESUMED?.
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3.12.2 Step by Step Instructions for the “Page 1 of 2” Example

1. Open the report heading or footing screen (see Section 3.1).

2. Choose Add > Formatted Text.

3. LD4 displays the Text and Data Settings dialog discussed in Section 3.6.  Set the Font, Size,

Color, Style, Justify and Underline options according to how you’d like the new text to appear.

4. Click on the Data tab and then choose “No underline” from the Underline box.

5. Move the mouse cursor to the row and column where the text is to be located then click the left
mouse button.

6. Click on the Fixed text button.

7. Type 4EKI into the Enter some text here that you would like to have appear...  field.

8. Click on the Space button (we want a space to appear between 4EKI and the current page

number).

9. Click on the Entered/Calcd. button.

10. Click on the Calculated dictionary tab.

11. Click on 4%+) in the dictionary. 4%+) is the name of a calculated data item that when printed

shows the number of the report page being generated, starting at 1 for the first page of the
current boring.  (The number starts over at 1 when the next boring is started.)

12. Click on the Fixed text button.

13. Type SJ into the Enter some text here that you would like to have appear... field.  (Put a space

before “SJ”.)

14. Click on the Space button.

15. Click on the Calculated dictionary tab.

16. Click on 4%+)C0 in the dictionary.  (4%+)C0 is the total count of pages that will be printed for the

current boring log.)

17. Click on the OK button.
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3.12.3 Step by Step Instructions for the “Boring Continues” Example

1. Open the report heading or footing screen (see Section 3.1).

2. Choose Add > Formatted Text.

3. LD4 displays the Text and Data Settings dialog discussed in Section 3.6.  Set the Font, Size,

Color, Style, Justify and Underline options according to how you’d like the new text to appear.

4. Click on the Data tab and then choose “No underline” from the Underline box.

5. Move the mouse cursor to the row and column where the text is to be located then click the left
mouse button.

6. Click on the Fixed text button.

7. Type &SVMRK�'SRXMRYIW into the Enter some text here that you would like to have appear...

field.

8. Type '328-29)# into the Only print when this equation is “true” or “not zero”  prompt.

 (Note: If, instead of printing “Boring Continues”, you would like to print “Boring Continued”, the
equation to enter would be 4%+)"�.)

9. Click on the OK button.
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3.12.4 Step by Step Instructions for the Formatted Elevation Example

1. Open the report heading or footing screen (see Section 3.1).

2. Choose Add > Formatted Text.

3. LD4 displays the Text and Data Settings dialog discussed in Section 3.6.  Set the Font, Size,

Color, Style, Justify and Underline options according to how you’d like the new text to appear.

 Make sure to click on the Data tab and then choose “No underline” from the Underline box.

4. Move the mouse cursor to the row and column where the text is to be located then click the left
mouse button.

5. Click on the Fixed text button.

6. Type )PIZEXMSR� into the Enter some text here that you would like to have appear...  field.

7. Click on the Space button.

8. Click on the Entered/Calcd. button.

9. From the dictionary (see Section 2.7), click on the Source tab then select “ELEVATION”.

10. Click on the It is a number checkbox.

11. Enter � for the Digits to the left of the decimal (this lets you print as large an elevation as is

necessary).

12. Enter � for the Digits to the right of the decimal (which ensures that all elevations will be printed

with two digits on the right of the decimal -- an elevation entered as 123.4 would be printed as
123.40).

13. Click on the Fixed text button.

14. Enter Q� into the Enter some text here that you would like to have appear...  field.

15. Click on the OK button.
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3.13 Adding a Plan View to a Profile

LD4 can draw plan views on profile reports and multi-source graphs.

Figure 3.26 -- Plan View

To add a plan view to a report:

1. Open the report heading or footing editor (see Section 3.1).

2. Plan views are drawn inside a boundary defined by the closest line on top, left, right and bottom
around where the plan object is placed.  Because of this you will need to begin by drawing a
rectangle around the area where the plan view will be shown.  (Try looking at how the plan was
added to the footing of the PLNPROFB report -- you will find it inside a rectangle drawn at the left-
hand corner of the footing.)

 Choose Add > Rectangles.

3. Check the Line Properties dialog (Figure 3.3) to make sure that the correct line weight and color
for the border are selected.

4. Move the mouse cursor to the row and column where top-left of the plan view will be located then

click the left mouse button.   While holding the button down, move the mouse to the row and
column of the bottom-right side of the plan view then release the mouse button.

➾ Note: LD4 draws all plan views as squares.  If the bounding box around the plan isn’t square,
then out of that rectangle the program will only use an area corresponding to the largest
square that can be fitted inside the rectangle.

5. Choose Add > Plan View.  Note: if this menu selection is not shown then you are not editing a
profile or multi-source graph report.

6. LD4 displays the Text and Data Settings dialog discussed in Section 3.6.  Set the title Font, Size,

Color and Style options according to how you’d like the labels printed next to each boring to
appear.
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7. When you have the font selection correct, move the cursor to somewhere inside the box you drew
in Step 4, then click the left mouse button.  LD4 displays the Plan View dialog, shown below:

 
 Figure 3.27 -- Plan View Dialog

8. Select a symbol to be used to represent the borings plotted on the plan.  Note that this will be just
a default selection -- it can be overridden by changing a setting on the data entry form used by the
borings plotted on the profile.  Refer to the plan view symbol discussion in Section 1.5 for more
information.

9. Enter the size of the symbol: The Width and height of the symbol gives the length of one side of
an imaginary square drawn around the symbol.  (PLNPROFB uses symbols sized 0.07 inches
(0.1778 cm.) square.)

10. If you want to just draw symbols representing each boring, without labeling the symbols with the
boring numbers, check the Omit source names box.

11. Click on the OK button to finish.
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3.14 Checkboxes

Checkboxes like the one shown below can be added to any report’s heading or footing:

Figure 3.28 -- Checkbox

➾ Each checkbox is associated with a data entry field entered into the project being printed.
While drawing the report LD4 looks up that field -- if a number besides � was typed into the

field then LD4 X’s out the box.

As an example, the project’s boring log data entry screen could have a field like Groundwater

encountered (Y/N)?: a = entered into that field gives the field a non-zero value (= is the same

as � as far as the program is concerned).  If you have a checkbox cued off of that data entry

field the box will be checked.  An 2 entered into the field gives the field a zero value (2 is the

same as � as far as the program is concerned) so the box won’t be checked; also, leaving the

field blank has the same effect as entering an 2 or �.

➾ You can also cue the checkbox off of more complex equations: a couple of examples are
listed below:

(6-00C%2+0) "�� can be used to X a checkbox called “Angled Drilling?”.

-*)���;()48,��!� can be used to X a checkbox called “Groundwater not encountered?” --

when nothing is entered into the “Groundwater depth” data entry field, the box will be
checked.  (Entering anything into the field will cause the box to not be checked.)

Appendix A provides a discussion of -*)�� and other LD4 math functions that you may find

useful when setting up a checkbox.
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To add a checkbox

1. LD4 draws the “X” inside the checkbox based upon whether or not the contents of a particular
data entry field is 0: if you haven’t yet added a data entry field for entering the checkbox field, see
Section 1.3 for instructions on doing so.  (Tip: usually the field is added to the data entry form’s
“Source” section so that you can enter data for the field once per boring.)

2. Open the report heading or footing editor (see Section 3.1).

3. Choose Add > Checkbox.

4. The Title and Data Settings dialog determines the font that will be used for the title printed next to
the checkbox: see Section 3.4 for instructions on setting this up.

5. Once you have the correct font selected for the checkbox title click the left mouse button at the
position where the checkbox is to be placed: this displays the Checkbox dialog shown below.

 
�Figure 3.29 -- Checkbox Dialog

6. At the Message to be printed next to the checkbox prompt type the title that you want to appear to
the left of the checkbox.

7. At the The box will be checked when the following equation is true prompt enter the data entry field
or equation that you want to use to control whether or not the checkbox checked.

➾ Leaving this prompt blank causes the checkbox to always be drawn without an X, which can
be useful if you need to have a checkbox on your report that will be filled in by hand.

8. Optionally, enter the width and height of the checkbox.  If you leave both fields blank the program
will choose an optimal size for you.

9. Click on the OK button.
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3.15 Figure Numbers

Note: To add a “Page 1 of 2” type of message to a report, refer to Section 3.12.

To add a “Figure x” type message to a report:

1. Open the report heading or footing editor (see Section 3.1).

2. Choose Add > Text.

3. The Title and Data Settings dialog determines the font that will be used for the title printed next to
the checkbox: see Section 3.4 for instructions on setting this up.

4. Once you have the correct font selected for the checkbox title click the left mouse button at the
position where the text is to be placed.

5. Enter *MKYVI at the Text  prompt: This is the text that will be printed to the left of the figure

number.

6. Click on the Calculated  dictionary tab then locate and click on “FIGURE” in the dictionary list.

7. Click on the OK button.

The previous instructions add a figure number that only changes on a boring-by-boring basis: all of
the pages printed for a given boring log show the same figure number (refer to Section 3.2.5 in the
User’s Guide for instructions on entering the actual figure numbers.)  You may want instead to have
figure numbers that change for each page printed; e.g., Figure B-1a for B-1’s first page, B-1b for the
second page, etc.  To do this, substitute “TPAGE” for “FIGURE” in Step 6 above then enter the
starting figure number into the Page prompt as discussed in Section 3.2.5 in the User’s Guide.
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3.16 Shaded Rectangles

To add shading to any rectangular area of the report heading or footing:

1. Begin by opening the report heading or footing editor (see Section 3.1).

2. When shading is added to a form LD4 shades up to the nearest line above, below and to the left
and right of the shading object.  Because the shading extends to the nearest lines around the
shading object, make sure that the area to be shaded is inside of a box drawn with either the line
tool (see Section 3.2) or the rectangle tool (see Section 3.3).

 In the example below, placing a shade item right underneath “CONTRACT NO.” shades the entire
rectangle around it.

 
Figure 3.30 -- Shade Item Placement

1. Once the rectangle’s drawn choose Add > Shade.

2. Move the mouse cursor to the rectangle to be shaded then click the left mouse button: this
displays the shading dialog shown below.

 
�Figure 3.31 -- Shade Dialog

Place shade item
here to shade the
rectangle around

“CONTRACT NO.”
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3. Choose a shading percentage: 0 percent is no shade, 100 is full black (the gradient in-between
isn’t linear -- Figure 3.32 shows the available shading percentages), then click on the OK button.

Figure 3.32 -- Available Shading Percentages

➾ Tip:  You can obtain an effect like the one below by placing a 100% shade into a rectangle
then placing a white-colored text item, justified “V: center; H: center” into the same rectangle.

Figure 3.33 -- Inverted Colors
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3.17 Shifting the Table Into the Heading Section

Normally, a report form’s table section extends from the left-hand margin to the right-hand
margin.  The table for SAMPLE3 is different: the heading section of the report form extends down the
right side of the subsurface table.
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MONITORING WELL LOG
WELL NO. GW-15

PROJECT: Midland City Transp. District PROJECT NO.: 1416-005

LOCATION: 15’ So. STA 3 ELEVATION: 4278.5 assumed

DRILLER: RXY Drilling DATE DRILLED: 2/12/91 DATE COMPLETED: 2/14/91

WATER DEPTH: 29 INSPECTOR: R.A.R. COMPLETION DEPTH: 41 feet

PROTECTIVE

COVER TYPE: locking

Master lock #1834

GROUT:

Type: cement/bentonite

Quantity: 18 bags

Total Depth: 3 feet

BACKFILL:

Type: cuttings

Top Depth: 3

Bottom Depth: 9.5

CASING:

Diameter: 4 in.

Length: 3

Stick Up: 3 in.

SEAL

Type: Bentonite Pellets

Quantity: 25 lbs.

Top Depth: 9.5

Bottom Depth: 12

SCREEN

Type: PVC

Diameter: 2 in.

Slot Size: .01 in.

Top Depth: 22.2

Bottom Depth: 34.1
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�Figure 3.34 - “SAMPLE3” Report Form

Subsurface
table
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for the subsurface

table
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The key to achieving this effect is to use the Add > Text menu selection place a title into the
heading of the report form at the position where you want the upper-right corner of the table to fall: the
title should be a single vertical bar (̀ ).  Below the vertical bar title, all other titles and data should be

positioned to the right of the ̀ : these items will be placed off to the right of the table.  The figure below

shows how this was done for SAMPLE3.

�Figure 3.35 -- "SAMPLE3" Report Heading

➾ “PLNPROFA” uses this option to place the plan view off to the right of the subsurface section.

Area reserved for
subsurface table

Heading on right
side of table

Vertical bar denoting
top-right corner of
subsurface table
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4. Editing the Report’s Table Section

A report form’s table is the section of the form where, for subsurface reports such as boring logs,
data are shown scaled by depth; for data summaries, the table is where rows of data are listed.
(Refer to Table 2.2 for a discussion of how tables are used for different report formats.)

Change your report’s table by choosing Sections > Table -- this brings up the Report Table editor.

Figure 4.1 -- Report Table Editor

Table columns are composed of a title block (which holds one or more titles above each column)
and the items that are actually printed within the column (such as a scale bar, material description,
monitoring well schematic, etc.).  The following sections discuss inserting, modifying and deleting
columns and editing the information contained within each column.
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4.1 Adding, Modifying and Deleting Table Columns

To select a table column for modifying:

1. Open the Report Form editor by choosing Tools > Report Forms.

2. Choose Sections > Table.

3. The Report Table editor includes a grid listing the titles of all of the columns already placed on the
table (directly underneath the “Columns on this Form” bar): to modify a given column, click on the
column’s title in the grid.  (If the column is untitled, you may need to guess at its location in the
grid: columns that don’t have a title are listed in the grid as (no title) .)

To insert a new table column:

1. To insert a new column somewhere within the set of columns already added to the report:
Following the instructions above,  select the existing table column that is to be immediately to the
right of the new column.

2. Choose Edit > Insert Column.

1. If you will be adding the new column to the right of the last column already on the table.
LD4 always maintains a blank column on the right-hand side of the table which can be modified to
create a new table: Clicking on the right-most entry in the column titles grid discussed above
opens a fresh column which can be modified (and creates a new blank column to the right of it
which, if never modified, will be removed when the report form is saved).

 

To delete an entire column:

1. Follow the instructions given for selecting a table column for modification.

2. Choose Edit > Delete Column.
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4.2 A Column’s Borders

LD4 allows you to specify the thickness of the line drawn at the top, right and bottom side of each
column.  The left column line is of course the previous column’s right-side line.  LD4 gets the
thickness of the left-hand border for the left-most column by duplicating the right-most column’s “right-
hand” line width -- this gives a balanced appearance to the column.  The figure below shows some
different combinations of border thicknesses:

Figure 4.2 -- Column Borders

➾ The table created for a subsurface profile report doesn’t have column borders.

To modify a report table column’s borders:

1. Following the directions given in Section 4.1, select the desired table column for modification.

2. To change the weight of the line drawn at the top of the column, click on the blue link shown
immediately to the right of Weight of Line at Top of Column  (this link will either be a number, the
words “(double lines)” or “(no line)”: This displays a combo box in place of the link.  Drop down the
combo box and choose a different line weight.

3. To change the weight of the line drawn on the bottom of the column, click on the blue link shown
immediately to the right of Weight of Line at Bottom of Column: LD4 displays a combo box in place
of the link which can be dropped down to choose a different line weight.

4. To change the weight of the line drawn on the right side of the column, click on the blue link
shown immediately to the right of Weight of Line at Column Right: LD4 displays a combo box in
place of the link which can be dropped down to choose a different line weight.

➾ Tip: If you’d like to have a double line at the top of the table title block but only a single line at
the bottom of the title block, as shown in Figure 4.3, you can’t just set the table’s top line width
to “(double lines)”: doing this causes the program to draw double lines at the top and the
bottom of the table title block.

“Well Construction
Diagram” and

“Sampler” have
invisible right-hand

column lines

Weight of line at top
of column is used

for both these lines

“Soil Graphic”’s
right-hand column
line is the same

weight as the weight
at the top of its

column

Double line on top
of titles

Single line on
bottom of titles
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Figure 4.3 -- Report Table

1. Instead, set the table’s top line width to the width you want to have used for the line drawn at the
bottom of the title block.

2. Next, draw a double line across the page at the bottom of the page’s heading.  (Refer to Section
3.2 for instructions)

3. Make sure that the heading/table separation is �.  (See Section 2.6.)  LD4 will place the line you

drew at the bottom of the heading directly across the top of the table.

If your table has a solid right-hand line but you don’t want a left-hand line, do the following:

1. Edit your report form, go to the table, then go to the last column on the table.

2. Add a new column to the right of the last column.  (This column will be the one LD4 uses to
determine the thickness of the left-most line on the table.)

3. Make the width of the new column ����� (inches or cms.).

4. Make the top, bottom and right line weights �.

This results in a table that is open on the left, closed on the right.
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4.3 Column Titles

Each column on an LD4 report table can have one or more titles above.  Columns can also share
titles.  The example below shows the first two columns sharing the “Sample Number and Run Length”
title, and all six columns sharing the “Sampling Data” title.

Figure 4.4 -- Table Column Titles

Two points on this example:

➾ If you do not enter a title for a given column it will share the title of the column to its left.  The
second-most column on the example (this is the column with the sampler symbols and scale
bars) has a blank title, so it shares the first column’s title (“Sample Number and Run Length”).

If you really want a blank column title -- i.e., to prevent LD4 from sharing the previous
column’s title -- enter a caret (B) as the column’s title.  LD4 will remove the caret prior to

printing the report, leaving a blank title block.

➾ Titles shown above the lowest column title (e.g., “Sampling Data” in the example) are called
“captions”.  LD4 has a slightly different method for setting these up.
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Note that the titles placed above graphs, such as the one shown below, are automatically built.
You do not need to do anything in order for these titles to appear: LD4 automatically adds the graph
scale and legend to the column title when the report is printed.  Any title that you do place into the
column is moved above the graph scale and legend.

Figure 4.5 -- Automatically Generated Graph Titles

To modify a column’s title:

1. Following the directions given in Section 4.1, select the desired table column for modification.

 It’s important to choose the correct column: if you want to modify the title directly above the table,
click on the column grid entry that lists that title.  If you want to modify a title above the lowest one,
you’ll need to go to the left-most column that uses that title.  (To modify the “Sampling Data” title
shown in Figure 4.4  you would select the “Sample Number and Run Length” column for
modification, since it is the left-most column to use that title.)

2. Once you have the correct column selected, if you will be modifying the lowest title, click on
the blue link shown to the right of the word Title in the middle of the screen.  (The link should
show the column’s title, or, if the column doesn’t have a title, it will show (none).)

 Links for column titles above the lowest are shown to the right of the word Captions, again, to edit
a title, click on the link.

 If you want to add a new title above one that already exists, choose Add > Add Column
Caption.

Graph titles are
automatically built when

the report is printed

Any title that you
add to the column
will go above the

graph titles
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3. Once the appropriate title has been chosen, LD4 will bring up the title properties page, shown
below.

 
 Figure 4.6 -- Title Properties Page

4. Enter the column’s title into the top field of the dialog (where “TEST RESULTS” is shown in the

preceding figure).  If you want the title to be spread over multiple lines, press the Enter key
at the end of each line.  (For example, to have the title “TEST RESULTS” printed on two lines,
enter 8)78, press the Enter key then enter 6IWYPXW.)

➾ Note that you can insert type symbols such as Greek letters, the degree symbol, etc., into the
title by pressing function key F9 -- see Section 2.5.1 in the User’s Guide for details.

5. LD4 always centers the title vertically.  You will need to choose a horizontal justification for the
title from the selection box next to the Align prompt.
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 The following figures demonstrate the effect of various Align settings:

     
Left Align                    Center Align

    
    Right Align              “Justified” Align

 Figure 4.7 -- Effects of Align Settings on Column Titles

➾  “Justified” text left-justifies the title, then centers the result within the column.

➾ When a title is rotated 90 degrees, instead of always being centered vertically, the title is
always centered horizontally (look at the “N-value” column in Figure 4.4); the align selection is
applied in the vertical direction so that a “Left” alignment means that the title is flush with the
bottom of the column title block and “Right” alignment means that the title is flush with the top
of the column title block.

6. Next, if you want the title to print with the font selected through the Default font for column titles

panel on the Form Settings dialog (discussed in Section 2.5.4), make sure the Use the default font

setting is checked.  Leaving this setting checked is a good idea -- that way you can change the
font for all of your column’s titles at once by changing the settings in the Default font for column

titles panel.

 If you want to change the font, uncheck the Use the default font setting then make only the
changes that you need: if you leave the Font, Style or Size boxes blank they will continue to use
the selection chosen in the Default font for column titles panel.

7. Select the angle for the title at the Angle prompt.  Note that the rotation angle is counter-
clockwise, so that a title rotated 90 degrees appears like the “N-value” title shown in Figure 4.4.

8. If the title is one above the lowest title level (i.e., it was created with the Add > Add Column
Caption selection) then there are two more settings.
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 The Omit line underneath selection determines whether or not a horizontal line is drawn dividing
the current title from the one immediately below.  This technique can be used for producing
column titles that use more than one font, as shown below (“Sampling Data” is a larger font and
“Sample Number and Run Length” is italicized): Divide the titles up by font then enter the lowest
half (“Sample Number and Run Length” in the example) as the column title and use Add > Add
Column Caption to enter the upper half (in the example, this is “Sampling Data” in the example
below) and change its font accordingly.

 
 Figure 4.8 -- Column Title Using Two Fonts

9. Finally, if the caption will span multiple columns, change the Columns spanned setting.  (For
example, in Figure 4.4, the “Sampling Data” caption spans six columns.)

10. Clicking anywhere else on the screen or adding anything else to the column will finalize your
selections.

➾ Tip: When choosing the height for the block used for a caption title (e.g., any title above the
lowest), LD4 allocates just enough vertical space to fit the title.  If you want more vertical
space (so that the title has some whitespace on top and bottom), press )RXIV after the last

line of the title then enter a caret (B).  When the title is placed at the top of the column, LD4

removes the caret and leaves a blank line.  (If you want more blank space, just press )RXIV

several times before typing the caret.)  For example, to get some whitespace at the top and
bottom of a caption that reads “ELEVATION IN FEET”, enter it as:

)0):%8-32�-2�*))8v

v

v

B
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4.3.1 Including Data in a Column Title

You can also place the results of calculations or data entry fields into column titles.  For example,
this is useful for placing the ground surface elevation at the top of an elevation scale column, as
shown below.

Figure 4.9 -- Data Placed in a Column Title

To include the results of an equation or data entry field as part of a title, place a $ in front of the

field name or equation.  For example, to include the surface elevation as part of the title above an
elevation scale column, the title would be entered like this:

)PIZEXMSR

$)0):%8-32

The “Elevation” is just text: it will appear on every report.  When LD4 sees the “@ELEVATION” it
substitutes whatever was entered into the ELEVATION data entry field for the boring being printed.  If
the user entered 169.956 into B-1’s “ELEVATION” field, when LD4 prints the elevation scale column
title for B-1’s report, the title comes out as

ELEVATION
169.956

If you want to add text on the right of a data entry field, make sure to place a space between the data
entry field’s name and the text.  For example, to add the letters “MSL” after the elevation:

)0):%8-32

$)0):%8-32170

doesn’t work: LD4 will look for a data entry field called “ELEVATIONMSL”.  Instead, enter the title as:
)0):%8-32

$)0):%8-32�170

which will produce titles like:
ELEVATION
169.956 MSL
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4.3.2 Using the “#” and “]” Symbols to Underline Data in a Column Title

Once you’ve placed some data into a column title, you may want to have it underlined --
simulating a “fill in the blank” report like the example shown below.

Figure 4.10 -- Title with Underlined Data

To underline data placed into a column title:

1. Follow the instructions given earlier for placing a data entry field into a column title (e.g., enter $

then the field name).

2. To the right of the data entry field’s name -- at the spot where you want the underline to complete
-- place either a A or a �.  Use the A symbol if you want the item to be centered (like “557.6”,

“2/23/97” and “50”  in the example); use the � symbol if you want the item to be left-justified (like

“CME-850” in the example).

 The example was produced by setting up the column title as follows:

� %TTVS\MQEXI�+VSYRH�)PIZ��$)0):%8-32��A

� (VMPP�6MK��$(6-00C6-+�����������������

� (EXI�(VMPPIH��$&(%8)�����������������A

� 8SXEP�&SVMRK�(ITXL��$&36-2+)2(�������A
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4.4 Choosing the Width of a Table Column

When a new column is added to a report’s table, LD4 automatically selects a width for that
column: First, the software makes the column wide enough so the title above the column fits.  Next,
LD4 considers the items that will be included in the column -- perhaps a scale bar, a material
description, a monitoring well schematic, etc., -- and tries to make sure that the column will be wide
enough accommodate those items.  Finally, if the sum of the widths for all of the columns on the table
are too wide or narrow to fit on the report page (taking into account the left and right margins
discussed in Section 2.6), LD4 will widen or narrow each column until the whole thing fits.

There are situations where you may want to choose your own width for a particular column.  For
example, when you create a column to show stratigraphy symbols (instructions for doing so are given
in Section 4.6.4), LD4 chooses a default column width of 0.4 inches (1 cm.), which makes for fairly
wide symbols: Many people prefer a 0.3 inch (.76 cm.) wide stratigraphy column.

To change a column’s width:

1. Following the directions given in Section 4.1, select the table column to be modified.

2. On the screen you’ll see the text Width of Column in centimeters or Width of Column in inches: To
the right of this is a blue link listing the current column width.  (If you haven’t chosen a width for
this column, the link will show “0”.)  Click on the link to select a new column width.

3. If you want to want to return to having the program choose the column’s width, change the
column width back to �.

Note that it is possible to make a table’s column width too wide, so that LD4 can’t fit the report on
the page.  If you do this, LD4 will issue a warning message (“The sum of the column widths exceeds
the width of the form”) and the table will run off the right side of the page.
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4.5 Plotting Order

Before creating a new column of data, take a moment to consider the order in which the items
that occupy the column (lines, text, graphs, etc.) will be plotted: when LD4 uses the report form to plot
an actual boring log, if there are two items that need to be plotted at the same depth -- common in the
case where a stratigraphy transition line is to be plotted and the description for the new stratigraphy
printed -- the item that was added first to the report form will be plotted first.

As an example,  a column that has the following two items in it:
Report “DESCRIPTION”
Draw a line at every depth “STRATA” is entered

produces the following effect:

Figure 4.11 -- Text Drawn First

Note that the transition lines bend below the bottom of the soil description, making the description
look as if it is for the layer above that denoted by the transition lines.  Rearranging the column to:

Draw a line at every depth “STRATA” is entered
Report “DESCRIPTION”

gives the results we were looking for:
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Figure 4.12 -- Lines Drawn First

➾ If items have been added to a column in the wrong order (like our first example), the situation
may be easily remedied: use the table editor to view the problem column (see Section 4.1)
then, in the Stuff Included in Column section of the screen, click on the first item that is out of
order and choose Edit then either Move Item Up (if you want the item printed sooner than
other items located at the same depth) or Move Item Down (if you want the item printed later
than other items located at the same depth).
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4.6 Printing Data in a Report’s Table

While a report’s table section can show scale bars, stratigraphy graphics and monitoring well
schematics, most of the information placed on the table is text: words and numbers.  (Summary report
tables only show text because, since they aren’t scaled by depth, they don’t include scale bars,
stratigraphy graphics, etc.)  Any text to be placed onto a report’s table (except for the labels on a
scale bar) is added using the facilities discussed in this section.

➾ LD4 incorporates a number of options for formatting text placed onto the report’s table, and
even (on scaled reports such as boring logs and profiles) allows you to choose the depth
where the text will appear.  These options are discussed later in this section.

To add text to a report table:

1. Prior to printing a data entry field on a report you should have modified the data entry form used
by the report (see Section 2.7) so that you can actually enter the data that you want to print.  (For
example, if you want to include a column for printing sample numbers, your data entry form must
include a place to enter -- sample numbers!)  Refer to Section 1.4 for instructions on adding the
field to a data entry form.

2. Once you have a place to enter the data you want to print, follow the directions given in Section
4.1 to select the table column where you want to print the data entry field’s contents.

3. After selecting the appropriate table column, choose Add > Add User Entered Data, Equations,
etc.: This displays the dialog shown below.

 
 Figure 4.13 -- Column Text Dialog

4. At the Print what? prompt enter the name of the data entry field that you want to print: You can
also use the dictionary below the prompt to pick the field.

➾ If you can’t find your data entry field in the dictionary then either A) You didn’t follow step 1, or
B) The data entry form that is associated with this report is not the one to you added the new
data entry field -- see Section 2.7.

 Note that you can also enter equations into the Print what? prompt: For example, entering 00�40

will print plasticity index values at all depths where LL and PL data were entered.
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➾ Note:  If LD4 reports zeros mixed in with your valid equation results, use the “Only print this
item where a specific field is not blank” selection on  the Print when tab.  For the Field, choose
one of the items in your equation -- this causes the program to only print the results of your
equation at depths where you’ve entered data for that field.

 The reason this is required is that LD4 may calculate a valid result for an equation even if one
or more of the data entry fields used in the equation were left blank because sometimes the
program automatically substitutes zeros for the blank values.  For example, in the equation
7%14C6)'�7%14C0)2, if “SAMP_LEN” was �� and no value was entered into the data entry

field named “SAMP_REC”, LD4 would report the result of the equation as 0/18=“0”.  To avoid
this, use the Print when tab to tell the program to only print the results of the equation when
the “SAMP_REC” field is not blank.

5. Click on the Justification tab and use the Horizontal justification box to choose whether the
printed data will be aligned along the left or right sides of the column or horizontally centered in
the column.

6. If you do nothing else, the new field will be printed with the font that you selected from the Table

tab on the Form Settings dialog discussed in Section 2.5.4.  If you want to use a different font,
click on the Font tab, uncheck the Use the default font? selection then select a font and size for
printing the new field.  (See Section 2.3.1 for a discussion on font selection.)

7. If you’re adding the text to a column where it could potentially wind up print on top of something
(lines or perhaps stratigraphy symbols) you may want to click on the Font tab and check the Erase

the area underneath the item box.  When this box is checked LD4 erases anything that may be
under the text.

8. If you want to rotate the text, similar to the example shown below, click on the Font tab and check
the Rotate the text 270 degrees box.

 
 Figure 4.14 -- Table Column with Rotated Data
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 Note that rotated text can be more trouble than it’s worth: A) LD4 will not wrap rotated text onto
multiple lines to fit within any particular vertical interval, B) the program will chop the text in the
middle of a word if the word runs below the bottom of the table and C) it is possible to enter more
lines of text than will fit within the left and right column boundaries.

9. Click on the OK button to complete the process.

The instructions above cover the bare minimum number of steps necessary to add a new item to
a table column.  LD4 incorporates quite a few bells and whistles that you can use to customize how,
when and where the text is printed -- these options are covered in the following sections.

4.6.1 Adjusting the Vertical Location of Text

When plotting a report that is scaled vertically by depth (such as a boring log or a profile),
normally LD4 plots text on the report’s table at the depth listed on the data entry card where the text
was entered.  (Enter a liquid limit value on a data entry card listing a depth of 5 meters and LD4 plots
the top of the liquid limit value at a depth corresponding to 5 meters. )

➾ Text added to a subsurface report’s table is placed vertically on the report using the following
formula:

�%'89%0�()48,�%773'-%8)(�;-8,�8)<8���',37)2�:)68-'%0�7'%0)�

This means that the text will move vertically if the user chooses a new vertical scale (vertical
scales are covered in Section 3.2.4 of the User’s Guide).

➾ When you add a text column to a summary report, LD4 doesn’t worry about vertical scaling:
the program just makes sure that data entered on the same row of the data entry screen all
print on the same row of the summary’s table.

Oftentimes when plotting data on a boring log, aligning the data so the top of the data is at the
entered depth isn’t quite what you’d want: as an example, sampling data such as the sample type,
sample length, recovery, etc. are usually presented vertically centered within the sampling interval.
Another example: USCS classifications are usually vertically centered between the top and bottom of
the soil layer with the classification.
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Figure 4.15 -- Centering Sampling Data and Soil Classifications

Some other vertical adjustments are also possible:

➾ Normally text is plotted so that the top of the text is at the depth where the data was taken;
however, LD4 can be set up to plot a piece of text so that the bottom of the text is at the depth
where the data was taken.  This is useful for producing effects like the one shown below,
where the depth on the right side of the column is above the line:

                       
Figure 4.16 -- Data Printed Above Entered Depth

Text printed
above the
starting
depth
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➾ LD4 also can plot text at some specified depth below where the data are taken: this is useful
for plotting sampling data at the end of the sampling interval.  In the figure below, the black
boxes in the left-hand column represent the sampling interval: note that the data on the right
(listing the sample number, blow count, density and moisture content) are shown at the end of
the sampling interval.

Figure 4.17 -- Data Offset Below Entered Depth

➾ When ruled lines are drawn down a column, (like, for example, in Figure 4.18, where the
horizontal lines are drawn spaced 1/2 cm. apart) instead of drawing data at the depth where
the readings were taken (which would possibly place the text on top of one of the lines) LD4
can be set to automatically center the text between the nearest two horizontal lines that are
below the depth where the readings were taken.

Figure 4.18 -- Text Placed Between Ruled Lines
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The table below lists all of the available vertical placement options:

Selection Usage

NORMAL This is the default selection: The top of the text is printed starting at the
depth where the item was entered.

ABOVE The opposite of “Normal”: The bottom of the text is at the depth where
the item was entered.   (See Figure 4.16.)

CENTERED Text is centered within some interval underneath the depth where the
item was entered.  Useful for centering sampling data within the
sampling interval and centering USCS classifications between the top
and bottom of the soil layer having the classification.   (See Figure
4.15.)

ABS.
CENTERED

Same as “CENTERED”, but text printed with this option does not shift
downwards to avoid overprinting something already printed on the
page.

END Text is shifted some specified distance below the depth where the item
was entered.  Useful for showing sampling data at the end of the
sampling interval.  (See Figure 4.17.)

RULED Text is centered between horizontal lines that are drawn at even
intervals down the page -- this is useful, for example, for centering
sampling data between lines drawn every 1/2 inch.  (See Figure 4.18.)

Table 4.6 -- Vertical Justification Options

To adjust the vertical location of text printed on a scaled subsurface report such as a boring log:

➾ See Section 7.1.1 for details on placing boring numbers, elevations, etc. above the
stratigraphy column on a profile report.

1. Follow the instructions given at the start of Section 4.5  to add the text to the report column.

2. While the Place a Text Item in the Current Column dialog is still displayed, click on the Justification

tab and select a vertical location option from the Vertical justification box.

 
�Figure 4.19 -- Selecting a Vertical Justification
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3. For CENTERED and ABS_CENTERED placement, you’ll need to enter the vertical interval over

which the data are to be centered into the Field for "centered", "end" or "ruled" justification
that determines the justification interval box.  This may be a number (for instance, �� centers

the data over a two foot sampling interval) but more commonly the name of a data entry field such
as 7%14C0)2 is used so that each item of data to be printed can be given a different centering

interval.  (Consider a sample that could only be driven 6 inches: if all sampling data are centered
over a 24 inch interval, data for the 6 inch sample would be shown far below the bottom of the
actual sample.  By requiring the user to enter the length of each sampler into a data entry field,
then using the results of that data entry field to calculate the centering interval, sampling data are
always shown centered over the actual sampling interval.)

➾ Note that the vertical interval is specified in terms of inches, feet, centimeters or meters of

drilling, not in terms how much paper is taken up when the interval is printed on a drilling log.

 For centering USCS classifications between the top and bottom of the soil layer having the
classification, enter

� 2<8�97'7�()48,��()48,

 as the vertical interval.  (See Appendix A for a discussion of the NXT() function.)

➾ You can also center text vertically at the exact depth where the data were taken: enter � as

the vertical justification interval.

➾ For “end” placement, enter the vertical offset from the depth where data were taken to where
the bottom of the text is to appear on the printout.  While this offset may be entered as a
number, it is usually entered as the name of a data entry field used to enter sampling lengths
(e.g., 7%14C0)2).

 Again, this offset is specified in terms of drilling depths, not in terms of how much paper is
taken up when the interval is printed on a drilling log.

➾ For “ ruled” placement, enter the vertical distance between ruled lines into the Field for
"centered", "end" or "ruled" justification that determines the justification interval field.
Again, this is measurement is in terms of the distance between the lines on paper.  (Section
4.10.4 gives instruction on adding the actual ruled lines.)

4. For “centered”, “abs. centered” or “end” placement, if you expect that you will be entering your
intervals in inches or centimeters (which is typical when entering sampling intervals), make sure
that Interval will be entered in terms of inches or centimeters... box is checked.  (If you are using
the 2<8�97'7�()48,��()48, equation to center USCS classifications, do not check the box.)
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5. Typically when LD4 prints something on a boring log’s table section, the program will
automatically shift the item downwards to avoid overprinting something (such as another piece of
text) already printed on the table.  Because shifting the text means that it will be printed below
where it should appear, you can stop the adjustment by checking the Do not move to

accommodate other items in the column  box (on the Justification tab.)

6. Click on the OK button when you’re through selecting the font, horizontal justification, etc. for the
text.

Note: If you’ll be using the “above” vertical justification option to place depths above, for example,
lines drawn at stratigraphy transition intervals, make sure that the data that you’re adding to the report
column is listed above the horizontal line item in the Stuff Included in Column list.  If it isn’t, click on the
text item (single-click) then choose Edit > Move Item Up until it is.

4.6.2 Formatting Printed Data

LD4 includes a sophisticated facility for printing text, including:

➾ Adding titles to the text (i.e., printing “NM=30” instead of just printing “30”, which can be
handy for printing test results on a profile since profiles don’t have column titles).

➾ Formatting numeric data to show a specific number of digits to the right of the decimal point:
e.g. “10”, and “11.235”  can be printed as “10.00” and “11.24” by having the program print the
data with two digits to the right of the decimal point.

➾ Printing multiple data entry fields on the same row: for example, if blow counts are entered
into four data entry fields (one data entry field for the blow count from each 6 inch/15 cm.
drive interval), they may be combined to print as “XX-XX-XX-XX”.

To format data to be printed on a report’s table as a number:

1. Prior to printing a data entry field on a report you should have modified the data entry form used
by the report (see Section 2.7) so that you can actually enter the data that you want to print.  (For
example, if you want to include a column for printing sample numbers, your data entry form must
include a place to enter -- sample numbers!)  Refer to Section 1.4 for instructions on adding the
field to a data entry form.

2. Once you have a place to enter the data you want to print, follow the directions given in Section
4.1 for selecting the table column where you want to print the data entry field.

3. After selecting the appropriate table column, choose Add > Add User Entered Data, Equations,
etc.: This displays the dialog shown in Figure 4.13.
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4. Click on the Numbers dialog tab.  This displays the dialog shown below:

 
 Figure 4.20 -- Formatting Text as Numbers

5. At the Digits to the left of the decimal point prompt, enter the number of digits that you expect to
print on the left side of the decimal point.  Note that this field doesn’t actually change how LD4
prints your data -- it merely helps the program to decide how wide the table column needs to be in
order to accommodate your data.

6. At the Digits to the right of the decimal point prompt, enter the number of digits that you want to
have appear on the right side of the decimal point.  Entering � causes the program to print your

data as whole numbers, without a decimal point.

 

To apply any other changes to user-entered data  besides simply formatting the data as numbers:

If you want to apply any other changes to your data before printing besides numeric formatting,
such as adding titles to the text (“NM=30”) or printing multiple data entry fields on the same row (31-
23-18-21), follow these instructions:

1. Once you have a place to enter the data you want to print, follow the directions given in Section
4.1 for selecting the table column where you want to print the data entry field.

2. After selecting the appropriate table column, choose Add > Add User Entered Data, Equations,
etc.: This displays the dialog shown in Figure 4.13.

3. On the Data tab, click on the Formatted button: This displays the Formatted Text dialog discussed
in Section 3.12.  Refer to the instructions given here for directions on determining how your data
will be formatted.

The following sections provide instructions for setting up the blow count and “NM=“ examples.
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  Step by step formatting instructions for adding “NM=“ before natural moisture data:

1. Follow the instructions given in Section 4.6.2 for getting the Formatted Text dialog displayed:
once the dialog is showing, click on the Fixed text button.

2. Enter 21! into the Enter some text here that you would like to appear...  field.

3. Click on the Entered/Calcd. button.

4. You should have named your natural moisture data entry field “NM”: locate “NM” in the What to

print dictionary and click on it.

5. Click on the OK button.

 

  Step by step formatting instructions for printing four blow counts on one line:

1. Follow the instructions given in Section 4.6.2 for getting the Formatted Text dialog displayed:
once the dialog is showing, click on the Entered/Calcd. button.

2. You should have named your blow count data entry fields “BLOWS1”, “BLOWS2”, “BLOWS3” and
“BLOWS4”: locate “BLOWS1” in the What to print dictionary and click on it.

3. Click on the Fixed text button.

4. Enter a � into the Enter some text here that you would like to appear... field.  (The “-” will separate

the first and second blow count.)

5. Click on the Entered/Calcd. button.

6. Click on “BLOWS2” in the What to print dictionary.

7. Click on the Fixed text button.

8. Enter a � into the Enter some text here that you would like to appear...  field.

9. Click on the Entered/Calcd. button.

10. Click on “BLOWS3” in the What to print dictionary.

11. Click on the Fixed text button.

12. Enter a � into the Enter some text here that you would like to appear...  field.

13. Click on the Entered/Calcd. button.

14. Click on “BLOWS4” in the What to print dictionary.

15. Click on the OK button.

 

  Step by step instructions for printing a key at depths where a particular test was performed
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This sequence is handy for setting up a report column indicating depths where consolidation,
shear or grain-size tests have been performed by printing a short abbreviation at these depths (“SH”
for shear, “CS” for consolidation, etc.).

1. If you’ve licensed the GEOSYSTEM for Windows lab. test module for the test that you want to list,
the lab. module will enter a flag into the project database at depths where you entered data for
that type of test -- this flag is in the form of a calculated field.

 If you don’t have the GEOSYSTEM for Windows lab. test module for the test that you want to
show, you’ll need to have a field on the tabulated portion of the data entry form where you can
enter either A) data for that test (e.g., a Shear Test Result: field) or B) a = at depths where that

test was performed (e.g., Shear Test Performed (Y=yes, blank=no):).  Refer to Section 1.4 for
instructions on adding the field.

2. Follow the instructions given earlier getting the Formatted Text dialog displayed: Once the
Formatted Text dialog is showing, click on the Fixed text button.

3. In the Enter some text here that you would like to appear... field, enter the code that you would like
to have printed (e.g., “SH” for shear, etc.).

4. Click on the OK button to closed the Formatted Text dialog.

5. Click on the Print when tab.

6. Select “Print this item only at depths where a specific data entry field is not empty”.

7. If you’ve licensed the GEOSYSTEM for Windows lab. module for the test that you want to report,
click on the Lab. Modules dictionary tab, then double-click on one of the following entries:

 (-(1)', for a mechanical grain size test

 (-(,=( for a hydrometer test

 (-('327 for a swell-consolidation test

 1%<()27 for a Proctor test

 00 for an Atterberg limits test

 (-(7,)%6 for a shear test

 If you haven’t licensed the appropriate GEOSYSTEM for Windows lab. module, locate in the
dictionary the data entry field that you added in Step 1 and double-click on it.

4.6.3 Selecting Which Data Will be Printed

Usually, when you want to print a data entry field on a report’s table you want to print the contents
of that field at every depth where the user entered some data.  (For example, if you’ve set up a table
column to print natural moistures, and the user enters natural moisture data at 2, 4 and 6 meter
depths, you want to print all three moisture values.)  However, there are some special cases where
you will want only print some of the data that’s been entered.
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As an example, suppose you’ve set up a table column to print the depths at which samples were
taken.  If you follow the instructions given in Section 4.5 to print the ()48, data entry field, your table

column will show quite a few more depths than you want because LD4 will print the depths of all
subsurface data entered for the boring: in addition to the sampling depths, you’ll get the depths of
stratigraphy transitions, monitoring well installation depths, etc.

To compensate for this, LD4 includes some options for deciding exactly which data will be
printed.

➾ Print Always This is the default selection: if you enter 4 depths, LD4 prints 4 depths.

➾ Print this item only at depths where a specific data entry field is not empty  This option
is the one that you would use to restrict printing data to only those depths that correspond to
the start of sampling intervals.

➾ Print this item only at depths where a specific field is empty This option is useful for
ensuring that your data doesn’t overprint something already printed in the column.

➾ Print this item at depths entered into another data entry field  This option is used for
printing groundwater depths and “date checked” notes entered into the source data section of
the boring log data entry screen.  Since data entered here aren’t automatically associated
with subsurface depths, you need to have a data entry field for entering a depth for each item
that you want print on the subsurface table.  (If you want to print the groundwater “date
checked”, you’ll need to have a field for entering the depth where this will be printed --
obviously for the groundwater “date checked” you’ll want to use the groundwater depth field. )

This option can also be used for automatically adding a “Boring Terminated” message to the
bottom of a column of material descriptions -- you can use the calculated field called
“BORINGEND” as the depth where the message will be printed.

➾ Don’t print unless something else is printed on the same row: Only available on
summary reports (see Section 2.1).   This allows you to exclude data such as depths from a
report unless they occur in conjunction with some other data on the same report line.  Similar
to “Print this item only at depths where a specific data entry field is not empty”, but you don’t
have to specify a data entry field -- you’re telling LD4 to exclude the item unless anything else
is available for printing on the same row.

To limit which data will be printed in a report column:

1. Follow the instructions given at the start of Section 4.5  to add the text to the report column.

2. While the “Place a Text Item in the Current Column” dialog is still displayed, click on the Print

when tab.
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�Figure 4.21 -- Limiting Which Data Will be Printed

3. Make a selection from the box at the top of the dialog -- see the list at the beginning of this section
for an explanation of the selections.

4. If your selection involved only printing data at depths where another data entry field was
empty/not empty or at depths specified by another field: use the dictionary shown in the middle of
the dialog to select the field that needs to be empty/not empty or that will be used to specify your
depths.

➾ If (rather than printing your data only at depths where another data entry field was not blank)
you want to print your data at depths where the data in another data entry field is not zero,
enter this equation into the Field prompt: -2>���JMIPHREQI�, where “fieldname” is the

name of the field that will control whether or not your data is to be printed. (Appendix A covers
INZ() as well as a number of other LD4 math functions.)

5. If you’re using the “Print this item only at depths where a specific field is/is not empty” selections,
you can also choose to have the program print the value that was entered for that item at the

boring termination depth by checking the Also print at the bottom-of-boring depth? box.  This
option is exclusively used for printing depths: for example, if you have a column to print sampling
depths, by checking this box you can also print the boring termination depth at the bottom of the
column -- if the box is left unchecked, the termination depth won’t print in the column (because the
column is printing only depths corresponding to sampling intervals, and no sample is taken at the
boring termination depth).

 (Note that you could accomplish the same effect by adding another item to the report column that
prints DEPTH,  choosing to only print DEPTH at depths entered into another data entry field, and
choosing &36-2+)2( as the field that determines the depth where the item is to be printed.)

6. The Print when tab includes one more selection useful when printing depths: Consider the case
where a column has been set up to print the depths of stratigraphy transitions.  Since the first
stratigraphy interval begins at 0 meters, the first depth printed in the column will be “0” , which

isn’t very useful.  Checking the Skip printing on the top of the first page? box causes the
program to not print whatever you’re trying to print if it was entered into the first data entry card
(e.g., at a depth of “0”).

7. If you’re printing stratigraphy transition depths, you may want to use an effect similar to the one
shown below:
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 Figure 4.22 -- Stratigraphy Depths

 To get effect of vertically centering the depths within the horizontal transition lines, click on the
Justification tab, choose “Centered” as the Vertical justification then enter � at the Field prompt.

 Finally, click on the Effects tab and check the Vertically centered over lines drawn at the same

depth tab.

 

  Step by step instructions for adding a “Boring Terminated” message to the bottom of a
material description column

1. Follow the directions given in Section 4.1 for selecting the material description column.

2. After selecting the appropriate table column, choose Add > Add User Entered Data, Equations,
etc.

3. Click on the Formatted button.

4. Click on the Fixed text button.

5. Enter &36-2+�8)61-2%8)( into the Enter some text here... field.

6. If you want to print the depth of the bottom of the boring, enter &36-2+� 8)61-2%8)(� %8

instead of &36-2+�8)61-2%8)( then: click on the Space button, then click on the Entered/Calcd.

button, enter &36-2+)2( into the What to print box, click on the Space button, click on the Fixed

text button then enter *X� (or 1�, depending upon whether the report form will be used for

printing data taken in US or SI units).

7. Click on the OK button.

8. Click on the Print when tab.

9. Choose “Print this item only at depths entered into another data entry field”.

10. Enter &36-2+)2( into the Depths specified by field.

11. Select the justification and font that you want for the note then click on the OK button.
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  Step by step instructions for printing the depths of stratigraphy transitions or the beginning
of sampling intervals

1.  stratigraphy:printing transition depthsFollow the directions given in Section 4.1 for selecting the
material description column.

2. After selecting the appropriate table column, choose Add > Add User Entered Data, Equations,
etc.

3. Enter ()48, into the Print what? field.

4. Click on the Print when tab.

5. Choose “Print this item only at depths where a specific data entry field is not empty”.

6. LD4 will need some method of figuring out which depths will be printed.  If you’re printing
stratigraphy transition depths you can tell the program to look at the data entry field where you’re
choosing the patterns to be shown in the “Graphic Log” report column (normally this field is
named 786%8%): choosing 786%8% at Field prompt will cause LD4 to print out the depths where

you’ve selected strata patterns for your “Graphic Log” column.

 If you don’t include a “Graphic Log” column on your report, obviously you won’t be selecting strata
patterns so you’ll need to have some other field that LD4 can look at to decide when to print
depths.  One alternative is to have LD4 print out the depths where you’ve entered material
descriptions (enter ()7'6-48-32 at the Field prompt); a second alternative, if you’ve followed

the directions given in Section 4.10 for adding a Transition prompt to your data entry form (so that
you can draw horizontal lines at stratigraphy changes), is to choose 86%27-8-32 at the Field

prompt..

 If you want to print the starting depths for sampling intervals, at the Field prompt you’ll need to
enter the name of one of the data entry fields you use for entering sampling data: 7%14C0)2 (the

sampling length data entry field), 7%14C8=4) or 7%140)C8=4) (the sample type data entry field)

or 7%14C291 all usually work.  Use the dictionary shown below the Field prompt to pick out one of

these fields.

7. Select the justification and font that you want for the note then click on the OK button.
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  Plotting sample numbers in bold if the corresponding sample was sent to a lab

This example utilizes many of LD4’s printing options to print the numbers of any samples that
were sent to the lab in bold face type.

1. First off, you need to add a data entry field to the Tabulated Data section of the data entry form
that you’ll be using (Section 1.4 provides directions for doing this).  Name the new field
0%&C7%140), use 0EF�WEQTPI��=!=IW��FPERO!2S�# as the prompt, make it 1 character

wide, and choose =2 as the field type. (Naturally, you’ll also need a data entry field for entering

sample numbers.)

2. Open your report form (see Section 2.4) then follow the directions given in Section 4.1 for
selecting report column where you want to print sample numbers.

3. After selecting the appropriate table column, choose Add > Add User Entered Data, Equations,
etc.

4. Enter 7%14C291 at the Print what? prompt.

5. Click on the Justification tab.

6. Choose “CENTERED” for the Horizontal justification.

7. Click on the Print when tab.

8. Choose “Print this item only at depths where a specific field is empty”.

9. Choose 0%&C7%140) from the dictionary -- if 0%&C7%140) isn’t listed, review Step 1.

10. Click on the Font tab and choose a non-bold face.  (Uncheck the Use the default font box then
select “Regular” as the Style.)

11. Click on the OK button.

12. Choose Edit > Copy Table Object.

13. In the Stuff Included in Column section of the screen, you should now have two entries labeled
“Report SAMP_NUM”: click on one.

14. Click on the Print when tab and change the selection to “Print this item only a depths where a
specific data entry field is not empty.”

15. Click on the Font tab and choose a bold face. (Uncheck the Use the default font box then select
“Bold” as the Style.)
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4.6.4 Text Effects

The “Place a Text Item in the Current Column” dialog has a tab labeled Effects that provides a
couple of specialized options for printing text in a report table column.

Figure 4.23 -- Effects Tab

➾ The Vertically centered over lines drawn at the same depth option is used to produce effects
like the one shown below.  Normally, LD4 will never overlap two items (such as the first
horizontal line and the “30.39m.” text); the only way around this is to check Vertically centered

over lines drawn at the same depth box.  (An example of how this option is used is given in
Section 4.6.3.)

 
Figure 4.24 -- Stratigraphy Depths
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➾ The Length of pointer drawn leftwards from the left side of this column option produces the
effect shown below:

                      
Figure 4.25 -- Pointers

Pointers are used to locate data such as the blow counts and stratigraphy depths in the figure
above.

➾ In order to use the pointer option, the data being printed must be either left or right justified
(see Section 4.5).

Pointers
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4.7 Adding a Stratigraphy Column

A stratigraphy column provides a graphic representation of the stratigraphy layers encountered
during drilling.

Figure 4.26 -- Stratigraphy Column with "Continued" and Drill Rejection Symbols

To add a stratigraphy column to a report’s table:

1. Before adding the column, you need to make sure that you have a field on the table section of
your data entry form where you can select stratigraphy patterns during data entry.  If you haven’t
yet done so, add two data entry prompts to the table section of the data entry form you’ll be using
(see Section 1.4 for instructions):

 Prompt: 97'7

 ��� 'PEWWMJMGEXMSR

 Field name: 97'7

 Field type: 786%8%C-(

 Field width: �

 
 

(The first step adds a field for entering USCS classifications -- when a classification is entered,
LD4 will automatically look up an appropriate set of stratigraphy patterns for that classification.  If
you don’t enter USCS classifications, skip the step.)
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 The second field that needs to added to the table:
 
 Prompt: 7XVEXE

 7]QFSPW

 Field name: 786%8%

 Field type: 786%8%

 Field width: �

 
 (This is the prompt where you’ll be entering the stratigraphy patterns.)

2. You may want to add one more field: Figure 4.26 shows a “drill rejected” symbol at the bottom of
the column.  In order to show a drill rejection symbol you need to have a data entry prompt on the
Source Data Window where you can indicate -- once per boring -- whether or not the drill rejection
symbol should be  shown.  Using the instructions given in Section 1.3, open your data entry form,
click on the Source Data tab then add the following prompt:

 (VMPP�6INIGXMSR�)RGSYRXIVIH��=!=IW�#

 
 To the right of the prompt, drag the 6).)'8 entry from the dictionary at the top of the screen.

3. Following the directions given in Section 4.1, select the table column where you want to add the
stratigraphy representation.

4. Select Add > Add Symbolic Representation of Soil/Rock Layers.  This displays the Symbolic
Strata Representation dialog shown below:

 
 Figure 4.27 -- Symbolic Strata Representation Dialog

5. Enter 786%8% at the Name prompt.

6. If you chose to add a drill rejection symbol at the bottom of the boring, click on the Refusal symbol

tab, check the Include the option to show a “drill refusal” symbol at the end of the boring?  box
then type 6).)'8 into the Name:  field.

7. If you would like to have a “continued” symbol to appear at the top and bottom of the stratigraphy
column if the boring runs over to multiple pages (this symbol is shown on the top of the column in
Figure 4.26), click on the Continued symbol tab and check the selection box.
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➾ Selecting the option to include the continue symbol causes the program to create a 0.25 inch
(0.64 cm.) gap at the top and bottom of the report table so that the symbol has a place to
appear.

8. Click on the OK button.

 

Tip:  When you create a stratigraphy column that is less than 0.4 inches (1 cm.) wide, LD4 will
automatically compress the stratigraphy patterns drawn in the column so that more of the pattern fits
into the space -- this allows complex or wide patterns to still be readable at column widths as small as
0.2 inches (0.5 cms).

4.8 Adding Sampler Symbols to a Table Column

In the interest of brevity, many reports, instead of listing each sample’s type (e.g., “BAG
SAMPLE”, “SPLIT SPOON”, etc.) show a small symbol intended to represent the sample type.  A
typical sampler symbols column is shown below:

Figure 4.28 -- Typical Sampler Symbols Column
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To add a sampler symbols column to a report:

1. Before adding the sampler symbols, you need to make sure that you have fields on the table
section of your data entry form so that, during data entry you can A) select the type of sampler
used, and B) enter the length of the sampler (LD4 plots sampler symbols so that the length of the
symbol is proportional to the length of the actual sampling interval).  If you haven’t yet done so,
add two data entry prompts to the table section of the data entry form that you’ll be using (see
Section 1.4 for instructions):

 Prompt: 7EQTPI

 8]TI

 Field name: 7%14C8=4)

 Field type: 7%140)67

 Field width: �  (the default sample symbol names are 1 character long)

 
 This field allows you to specify the type of sampler taken.  Note that LD4 has an option to use just

a single type of symbol (for example, a black square) for showing all of the sampling intervals: If
you want to use this option, you can omit the SAMP_TYPE field.

 
 The second field that needs to added to the table:
 
 Prompt: 7EQTPI

� ��� 0IRKXL

 ��� �MR��SV�GQ��

 Field name: 7%14C0)2

 Field type: (blank)
 Field width: �

 
2. Following the directions given in Section 4.1, select the table column where you want to add the

sampler symbols.

3. Select Add > Add Symbolic Representation of Sampler Types.  This displays the Sampler
Symbols dialog shown below:

 
 Figure 4.29 -- Sampler Symbols Dialog
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4. If you want to use a single type of symbol to represent all of the sampling intervals taken, choose

the symbol from the If you will only be using one sampler symbol, choose that symbol: field.
Otherwise, leave this prompt blank.

5. If you want to select the type of sampler taken for each sampling interval, enter 7%14C8=4) into

the Otherwise, choose the variable that will be used to select the sampler type: field.

6. Click on the Sampler length tab.

 
 Figure 4.30 -- Sampler Length Tab

7. Enter 7%14C0)2 into the Select the field where the sampler lengths will be entered: field.

8. If you will be entering your sampling lengths in inches or centimeters (as opposed to entering

them in feet or meters), check the Check if the sampler lengths will be entered in inches or
centimeters: box.
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4.9 Adding a Scale of Depths or Elevations to a Table

LD4 supports several different scale bar types:

             

              
Figure 4.31 -- Scale Types
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➾ Any scale bar may be set up to show either depth below ground level or elevation, in either
meters or feet.  The units used (meters or feet) don’t depend upon what units were used
when entering your project’s data: if you entered your drilling depths in feet your report can
still include a scale of depths in meters -- LD4 does the conversion from feet to meters for
you.

➾ Scale bars may also be configured to omit the numbers normally plotted every five tick marks
(as shown in the last example).

➾ If a scale bar is placed in the center of a table column, it (the scale) can be configured to
show depths on one side of the bar and elevations on the other.

To add a scale bar to a report’s table:

1. Following the directions given in Section 4.1, select the table column where you want to add the
scale bar.

2. Select Add > Add Depth and/or Elevation Scale: this displays the Symbolic Strata Representation
dialog shown below.  (If you don’t see this menu selection, you’re probably trying to add a scale
bar to a summary report, which, because the report’s table is not scaled vertically by depth,
doesn’t support scales.)

 
 Figure 4.32 -- Scale Dialog

3. The first choice to make is whether the scale will be in feet or meters:  remember that the scale
bar doesn’t care whether or not your drilling data was taken in feet or meters.  Click on either
“Feet” or “Meters” in the Scale units box.

4. Next, choose the type of scale to be printed:

 Left places the scale bar along the left edge of the column with the scale ticks extending
rightwards.

 Right places the bar on the column’ s right edge with the scale ticks extending leftwards.



Editing the Report’s Table Section

140

 Both draws tick marks from the left side of the column across to the right side of the column,
except for the tick marks where depth or elevation labels will be printed.  Tick marks at depths
where labels will be printed are split in the middle to make room for the labels.

 Both, Labels Above is similar to Both, except that all tick marks are drawn from the left to the right
of the column (the labels are drawn above their respective tick marks).

 Center splits the column down the center and draws one scale bar to the left of the split and a
second on the right.  (The first example at the start of this section is a centered scale.)

5. The Auto-select the number of minor scale ticks per major tick box requires a little explanation.
When a new scale is added to a report form, LD4 asks for the number of minor (i.e., small) ticks
that will be drawn between each labeled (or major) tick.  Typically, for a scale showing feet you
would choose 5 minor tick marks between each scale label and one scale label per inch so, for
example, when printed on a report scaled at 5 feet per vertical inch, a scale tick is printed for each
foot of boring.  If the same scale is printed with a vertical scale of 3 feet per inch, one scale tick
represents 3/5 of a foot which isn’t very handy.  What you really want is to have 3 scale ticks per
inch with a 3 feet per inch scale (making each scale tick represent 1 foot of boring); similarly, at a
scale of 4 feet per inch, you want 4 scale ticks per inch.

 Checking Auto-select the number of minor scale ticks per major tick causes LD4 to ignore your
selection for the number of scale ticks per vertical inch in favor of its own selection.

6. The Line weight of major ticks selection allows you to select the weight of the labeled scale ticks.
Typically, scales are set up to use weight 3 lines.

7. Next, click on the First side tab.  (For Center scale types, this tab determines what kind of scale
(depth or elevation) is shown on the left-hand of the two scale bars; for all other scale types, this
tab determines the kind of scale printed in the whole column.)

 
�Figure 4.33 -- "First side" Scale Dialog

8. In the Scale of what? box,  select what will go on the scale bar’s labels (depth or elevation).  If you
choose Depth, with no labels or Elevation, with no labels LD4 will plot just the scale ticks.
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9. Optionally, you can select the length of the tick mark that LD4 draws at labeled scale intervals by
entering a measurement into the  by entering a measurement into the Tick length field.  (LD4 uses
half this length to draw the tick marks in-between the labeled intervals.)

 If you leave the field blank, or enter �, LD4 will select a tick length that is appropriate for the size

of font that you select for the scale labels (the larger the font size, the longer the scale ticks).

➾ Tip: You can “trick” the program into creating  scales that don’t use tick marks by choosing
����� as the length of the scale’s ticks.  (You can’t use ����� because this causes the

program to pick its own tick length.)

 
 Figure 4.34 -- Scale Bar Without Tick Marks

10. Next, enter the number of labeled scale intervals per 2 inches (for scales in feet) or 10 cms. (for
scales in meters) into the major: field.  (If you have chosen a to draw the scale without showing
labels, major: only selects how many of the longer scale ticks will be drawn in the interval.)

11. At the minor plus major: field enter the number of unlabeled scale tick marks PLUS the number of
labeled scale tick marks that will be drawn within the interval (either every 2 inches or 10
centimeters).

➾ LD4 limits the major and minor scale tick counts to whole numbers.

Scale Bar Without
Tick Marks
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➾ If you don’t want smaller tick marks drawn in between your labeled scale ticks, set the number
of minor ticks to �.

12. If your scale type is “Center”, click on the Second side tab and repeat the previous steps for the
scale bar to be shown on the right half of the column.

13. Finally, if you want your scale labels to be drawn in a different font than the one chosen as the
default font (see Section 2.5.4), click on the Font tab, uncheck the Use the default font box and
choose a different font.

 

You can use a scale to draw tick marks on the side of a column used for presenting other data,
similar to the example shown below.

Figure 4.35 -- Scale Ticks in a Description Column

  To get this effect:

1. Add a scale to the column.

2. Choose to place the scale on the right side of the column.

3. For the First side of the scale, choose a scale of “Depth, with no labels”.

4. Choose the length of the tick marks.

5. At the Ticks per 10 cm.> major or Ticks per 2 in.> major prompt, select the number of ticks you
want displayed.

6. Choose � minor ticks.
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4.10 Placing Horizontal Lines Across a Column

A common addition to the subsurface table of a drilling log report is a series of horizontal lines to
denote stratigraphy transitions, sampling intervals, boring termination depths, etc.

➾ Horizontal lines may be solid, dotted or dashed, may be of differing line weights (see Section
2.3.5), and may be colored.

➾ Horizontal lines can only be drawn across a single table column at a time.  If, for example,
you want your lines to extend across two columns then you must add the same type of
horizontal line to each column.

➾ When adding a new horizontal line item to a column, keep in mind that the order in which you
add drawing objects to a column does matter.   For example, when adding stratigraphy
transition lines to a column where material descriptions will be printed, add the transition lines
to the column before adding the material descriptions.

Conversely, if you’re using the “Above” vertical justification option to place text above a line,
as discussed in Section 4.6.1, the order is reversed: add the text to the column first, then the
lines.

Refer to Section 4.5 for instructions on rearranging the order in which items are printed in a
column.

Following is a list of the different horizontal line drawing options supported by LD4:
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1. LD4 can draw a horizontal line at each depth where data was entered for a particular data
entry field.

 This is useful for drawing horizontal lines across soil transition lines -- LD4 draws a transition line
at every depth where you choose a new soil pattern combination.

 

Silty, sandy 
clay, some
gravel.  

Tan, sandy 
silt, grading
to sandy
clay

 Figure 4.36 -- Soil Transition Lines

 Refer to Section 4.10.1 for instructions on setting this option up.

2. Horizontal lines can be drawn across a column at even vertical intervals of “X” depth
units.

 This option can be used, for  instance, to draw a horizontal line across the column for each five
feet of boring.  Note that since the vertical intervals for this type of line are specified in scaled
depth units the actual vertical distance between successive horizontal lines will depend upon the
vertical scale chosen for the report.  (See Section 3.2.4 in the User’s Guide for a discussion of the
effect the vertical scale choice has on a subsurface log.)

 
 Figure 4.37 -- Horizontal Lines Drawn at Regular Intervals

 Refer to Section 4.10.4 for instructions on setting this option up.
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3. Horizontal lines can be drawn to delineate the top and bottom of sampling intervals.

 This option draws a horizontal line at the start of each sampling interval and a horizontal line at
the end of each sampling interval.

 

S-1

S-2

S-3

 Figure 4.38 -- Horizontal Lines Used to Delineate Sampling Intervals

 Refer to Section 4.10.2 for instructions on setting this option up.

4. Horizontal lines can be drawn across a column at evenly spaced vertical intervals,
measured in either inches or centimeters.

 This option gives results similar to option 2, but, since the intervals are specified in terms of
inches of paper, the distance between the lines does not depend upon the report’s vertical scale.

 Refer to Section 4.10.4 for instructions on setting this option up.

5. A single horizontal line can be drawn at a specific depth.

 This option can be used to indicate the boring termination depth, the caving depth, etc.

 

Boring terminated at 
32.5 feet.  Hole was 
dry on completion.

Backfilled after 48 
hours.

 Figure 4.39 -- Single Horizontal Line Drawn at Boring Termination

 Refer to Section 4.10.5 for instructions on setting this option up.
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6. Horizontal lines can be drawn offset below specific depths.

 This option takes a depth and draws a horizontal line at some specific offset below that depth.  As
an example, this option can be used to draw a line at the bottom of a sampling interval.

S-1

S-2

S-3

Figure 4.40 -- Lines Drawn at the Bottom of Sampling Intervals

 Refer to Section 4.10.3 for instructions on setting this option up.

4.10.1 Drawing Stratigraphy Transition Lines

A common use of the option to draw a horizontal line across a column at each depth where a
particular data entry field is completed is to draw stratigraphy transition lines.   These lines are
typically placed in the material description column: at every depth where a new soil or rock layer was
encountered, the program draws a horizontal line.

➾ As you can see from the bottom-most line in Figure 4.36, LD4 will bend the lines downward to
accommodate any extra-long descriptions that may intrude into the space where the line is
supposed to appear.  (The left end of the line is always located at the correct depth.)

LD4 may or may not bend the right ends of a transition line back upwards to the correct
depth, depending upon whether or not the next column to the right also has a horizontal line
to be drawn at the same depth.

To draw transition lines in a given report column:

In order to draw these lines, LD4 needs to be able to figure out the depths of the various layers
encountered.  If your report features a stratigraphy column (discussed in Section 4.7) then you’re all
set: you can tell the program to draw a transition line at each depth where a new set of stratigraphy
symbols was chosen.
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➾ LD4 gets the depths for each line by looking at the contents of the Depth data entry field in
each card where it finds a new entry in the Strata Patterns field.

If you don’t have a stratigraphy column or if you’d like to be more selective as to when the
transition lines are drawn, first you’ll need to add a new data entry field to the subsurface table so that
you can flag the depths where you want transition lines to be drawn.  Following the instructions given
in Section 1.4, add a new field to the table section of the data entry form you’ll be using:

 Prompt: 7XVEXMKVETL]

� 8VERWMXMSR

� �=!=IW��&PERO!2S�

 
 With this prompt you can draw a solid line when anything at all is entered into the field.

Optionally, if you would like to choose between a solid and a dotted or dashed line so that you
can denote whether the transition was sudden or gradual, enter the following prompt instead:

 
� Prompt: 7XVEXMKVETL]�8VERWMXMSR

� �=!7YHHIR��2!+VEHYEP�

� &PERO!2SRI�

 
 No matter what you chose for the prompt, enter the rest of the information below:
 
 Field name:  86%27-8-32

 Field type: =2

 Field width: �

Whether you want to draw the transition lines at depths where you’ve selected a new stratigraphy
pattern or where you enter something into a “Transition” field, continue with the directions below:

1. Follow the directions given in Section 4.1 for selecting the table column where you want to add
the lines.

2. Select Add > Add Horizontal lines

3.  Draw a line at every depth where a given data entry field is filled inChoose “Draw a line at every
depth where a given data entry field is filled in” from the Type box.  LD4 displays the dialog shown
in Figure 4.41:
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 Figure 4.41 -- Line Insert Dialog

4. You want to set up your form so that a horizontal line is drawn across the column every time a
new soil or rock layer starts:

➾ If you want to draw the lines at every depth where you select a new set of stratigraphy
patterns, enter 786%8% into the Field prompt.

➾ If you want to draw the lines at depths where you entered something into a “Transition”
prompt, enter 86%27-8-32.

➾ A third option is to draw a horizontal line at every depth where you’ve entered a material
description -- to use this option, enter ()7'6-48-32 into the Field prompt.

5. At the Style prompt, select the style of line that to be drawn.  If you’re going to be using the
“sudden or gradual” transition prompt discussed earlier, select either “Data entry picks
solid or dashed” (if you want the gradual transition line to be dashed) or “Data entry picks
solid or dotted” (if you want the gradual transition line to be dotted).

6. Next, at the top Weight and Color prompt, select the thickness and color of the lines (note that all
the lines drawn need to be the same weight and color) -- refer to Section 2.3.5 for an introduction
to LD4’s line weight scheme.  (Typically, transition lines are weight 1 or 2.)

7. If you’ve chosen the “Data entry picks solid or dashed” or “Data entry picks solid or dotted”
selections, at the Solid/dotted or dashed selection field prompt enter the name of the data entry
field where a = or � will be entered for solid lines and a 2, � or nothing will be entered for dashed

or dotted lines.  (If you’re adding stratigraphy transition lines, this field’s name will be
86%27-8-32.)
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➾ Tip: Rather than plotting sudden/gradual transition lines, you can have LD4 plot solid/dotted
lines in a description column so that at depths where you’ve entered a material description but
no stratigraphy change a dotted line will appear above the description; at depths where
you’ve entered a material description and a new set of stratigraphy patterns a solid line will
appear above the description.  Do this by entering -*)���786%8%� at the Solid/dotted or

dashed selection field prompt.

8. Most reports also include a horizontal line drawn at the boring termination depth.  Since you won’t
be choosing a new set of stratigraphy patterns at the end of the boring, the horizontal line setups
discussed so far won’t produce a horizontal line at the bottom of the boring.  To add it, choose
anything but “(No line)” as the Style in the To draw a line at the boring termination depth... section
of the dialog, then select a weight and color for the boring termination line.  Typically, boring
termination lines are drawn with a thicker line -- usually a weight 3.

4.10.2 Drawing Lines to Denote the Sampling Intervals

When presenting the results of tests performed on samples taken from a boring it’s helpful to
draw horizontal lines at the top and bottom of the sampling intervals then center the test results within
the two lines (see Figure 4.38).

To draw lines delimiting the top and bottom of sampling intervals in a given report column:

To draw sampling interval lines on a report, LD4 needs to be able to figure out the lengths of each
sampling interval, meaning that you need to have a data entry field to enter sampling lengths.  If you
haven’t yet done so, follow the instructions given in Section 1.4 to add a new field to the table section
of the data entry form you’ll be using:

 Prompt: 7EQTPI

� 0IRKXL

� �MR��SV�GQ��

 Field name: 7%14C0)2

 Field type:   (leave this field blank)
 Field width: �

 
Once you have your data entry field, continue with the steps below:

1. Follow the directions given in Section 4.1 for selecting the table column where you want to add
the lines.

2. Select Add > Add Horizontal lines
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3. Choose “Draw a pair of lines showing sampling intervals” from the Type box.  LD4 displays the
following dialog:

 
 Figure 4.42 -- Line Insert Dialog

4. At the What is the data entry field that provides the depth to the top of the sampling interval?

prompt, enter ()48,.  (On data entry cards where a sampling length is entered, LD4 will check

the Depth data entry field to determine the depth of the top of the sampling interval.)

5. At the What is the data entry that the program should use to determine the interval between the top

and bottom lines? prompt, enter 7%14C0)2.  (LD4 will look at the data entry field named

7%14C0)2: on data entry cards where this field has been filled in, the program will take the

contents of the field (e.g., ��) to be the length of a sample that starts at the depth entered into the

field selected in the previous step.)

6. Check the Check here if the interval is entered in inches or centimeters box if you will be entering
sampling lengths in inches or centimeters; if you’ll be entering sampling lengths in feet or meters,
leave the box unchecked.

7. Typically, Control field is left blank.  The option is used only if you don’t want LD4 to draw the
sampling interval lines for every sample taken.  This is useful, for example, in a table column
reporting RQD values -- since rock coring lengths are entered into the same data entry field as
soil sampling lengths, without some way to distinguish between rock and soil sampling, LD4
would draw sampling interval lines in your RQD column for the soil samples as well.
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 To fix this (e.g., to avoid drawing sampling interval lines in an RQD column for soil samples) you
need to enter an expression into Control field that  is true (or evaluates to any number but 0) only
at depths where you want the program to draw the lines.  A typical equation would be something
like

 7%14C8=4)!l6z

 which is true at depths where you choose the sample type named “R” .  Another possibility is

 -*)���65(�

 which evaluates to 1 at depths where something was entered into the RQD data entry field -- thus
the program only draws the lines at depths where A) a sampling length was entered and B) an
RQD value was entered.  Finally,

 -*)���65(�!�

 evaluates to 1 at depths where an RQD value was not entered, so LD4 will draw the lines at
depths where A) a sampling length was entered and B) an RQD value was not entered.  This
option would be useful for drawing the sampling interval lines only in report table columns devoted
to listing soil sampling data.

➾ The LD4 Math Appendix provides a comprehensive discussion of the equations used above.

8. Finally, at the Style selection, choose between drawing  solid, dashed or dotted lines, then choose
a Weight and Color for the lines.  (Section 2.3.5 provides a discussion of line weights and colors.)

➾ A common reporting option is to draw test results centered vertically between the top and
bottom sampling interval lines.  Once you’ve added the lines to a table column, refer to
Section 4.6.1 for instructions on how to print the test results with a “CENTERED” vertical
justification.

4.10.3 Drawing Lines At the Bottom of Sampling Intervals

LD4 has a line drawing option similar to the one used to draw horizontal lines at the top and
bottom of bottom of sampling intervals, except only the bottom line (showing the end of the sampling
interval) is drawn (see Figure 4.40 for a sample).  The steps necessary for adding these types of lines
are identical to those discussed in Section 4.10.2

➾ A common reporting option is to draw lines denoting the end of sampling intervals; test results
are listed just above the lines.  To do this, refer to Section 4.6.1 for instructions on how to
print the test results with an “END” vertical justification, then add the lines to the column.



Editing the Report’s Table Section

152

4.10.4 Drawing Evenly Spaced Horizontal Lines

Some boring log forms feature ruled horizontal lines as an aid to filling in the forms by hand, like
this fragment taken from the State of Connecticut Department of Transportation boring log report:

Figure 4.43 -- Text Placed Between Ruled Lines

LD4 has two options for drawing ruled lines: A) the lines may be drawn a fixed vertical distance
apart -- for example, every 0.2 vertical inch of paper, or B) the lines may be drawn for every “X” feet
or meters of drilling (e.g., draw a line at intervals of 1 foot).

➾ If you use option A, the vertical distance between the lines remains the same, regardless of
the vertical scale at which the log is printed.  This means that if the scale is changed, the
drilling distance represented by two consecutive lines changes: lines 0.2 inches apart on a log
using a vertical scale of 5 feet per inch represents 1 foot of drilling (0.2 inches * 5 feet/inch);
the same lines on a log using a vertical scale of 10 feet per inch represents 2 feet (0.2 inches
* 10 feet/inch).  Because of this, option A is typically used on reports designed to be printed
with a specific vertical scale.

When centering text within ruled lines (like the text in Figure 4.43) the ruled lines are always
designed to be a fixed vertical distance apart.

➾ Because option B specifies the distance between ruled lines in terms of drilling distance, as
the vertical scale is changed, so does the distance between the ruled lines.
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To add ruled lines to a column:

1. Follow the directions given in Section 4.1 for selecting the table column where you want to add
the lines.

2. Select Add > Add Horizontal lines

3. Choose either “Draw a line every "x" vertical inches/cms.” (for option A) or “Draw a line every "x"
scaled depth units” (for option B) from the Type box.  LD4 displays the following dialog:

 
 Figure 4.44 -- Line Insert Dialog

4. Enter the desired Vertical distance between horizontal lines: remember that if you chose “Draw a
line every "x" vertical inches/cms.”, this measurement is in terms of distance on paper; if you
chose “Draw a line every "x" scaled depth units”, then the measurement is in terms of drilling
distance.

5. Finally, at the Style selection, choose between drawing  solid, dashed or dotted lines, then choose
a Weight and Color for the lines.  (Section 2.3.5 provides a discussion of line weights and colors.)

➾ A common reporting option is to draw test results centered vertically between the nearest two
ruled lines.  Once you’ve added the lines to a table column, refer to Section 4.6.1 for
instructions on how to print the test results with a “RULED” vertical justification.
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4.10.5 Drawing a Horizontal Line at a Specific Depth

Many report forms draw a thick horizontal line across the entire report table at the boring
completion depth.  LD4 includes an option to draw a line at this depth or at any depth (such as a
groundwater or caving depth) typed into a data entry field in the source data section of the data entry
screen.

To draw a horizontal line at a specific depth, such as the boring completion depth:

1. Follow the directions given in Section 4.1 for selecting the table column where you want to add
the lines.

2. Select Add > Add Horizontal lines

3. Choose “Draw a line at a single depth” from the Type box.  LD4 displays the following dialog:

 
�Figure 4.45 -- Line Insert Dialog

4. At the Field prompt, enter the name of the data entry field where you want the program to get the
depth at which the line is to be drawn.  (To draw a line at the boring completion depth, enter
&36-2+)2(.)

5. At the Style selection, choose between drawing  a solid, dashed or dotted line, then choose a
Weight and Color for the line.  (Section 2.3.5 provides a discussion of line weights and colors.)
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4.11 Adding a Graph to a Report’s Table

You can graph one or more items of data in any column of a LD4 subsurface report’s table.  The
vertical scale on an LD4 graph is always “Depth” just like any other item on the subsurface table.
Each item being graphed can have its own horizontal scale, or two or more items can share the same
horizontal scale.  Figure 4.46 shows a column where four items are being graphed: notice the
different graphing options.  Also note that the “Penetration”, “Water Content” and “Plastic
Limit”/”Liquid Limit” graphs share a common horizontal scale while the “Shear Test” graph uses a
different scale.

Figure 4.46 -- Graph Column Example

➾ Each report table column can graph an unlimited number of different items (pl/ll values, water
contents, shear test results, etc.).   However, every item that will be graphed must be added
to the column separately.  Instead of telling LD4 “draw a graph of PL/LL values, water
contents and shear test results”, you must add three separate items to the column: A) a graph
of PL/LL values, B) a graph of water contents and C) a graph of shear test results.
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➾ Note that the order in which graphs are added to a column is important.  If three graphs are
added to the same table column, the key (which identifies the marker used to graph the data,
as well as the horizontal graph scale) of the graph added last will appear on top of the graph
keys listed in the column’s title block.  (For example, Figure 4.46 was created by first adding a
graph of plastic and liquid limit to a table column, then adding a graph of moisture contents
and a graph of shear test results to the same column.)  So, when creating a table column
containing graphs of multiple results (Atterberg limits, water contents, etc.) add the graphs in
bottom-to-top order from how you want their corresponding keys to appear in the column title
block.

If, after adding a number of graphs to a column, the order appears to be incorrect; e.g., the
graph titles are out of order, refer to Section 4.5 for directions on rearranging the column.

To add a graph to a report’s table:

1. Before adding the graph, you need to make sure that you have a data entry field on the table
section of your data entry form so that you can type in the data to be graphed.  If you haven’t yet
done so, add the field to the data entry form that you’ll be using (see Section 1.4 for instructions).
For graphs of bracketed items (for instance, brackets showing PL and LL values like the example
below) you’ll need data entry fields for the left-hand and right-hand data values.

 
�Figure 4.47 -- Graph Bracket

2. Follow the directions given in Section 4.1 to select the table column where you want to add the
graph.

3. Select Add > Add Graph of Data vs. Depth.

4. From the following dialog, click on the Labels tab. (The Graph what? and Markers tabs are
covered in following sections.)

 
 Figure 4.48 -- Add Graph Dialog, Markers Tab
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5. In the title block at the head of the graph column it is customary to place a key indicating what
marker was used for the item to be graphed.  (In Figure 4.46, the keys say “SHEAR STRENGTH,
TSF”, “MOISTURE CONTENT, %” and “PLASTIC LIMIT” -- “LIQUID LIMIT”.)  LD4 allows you to
place some text both to the left and right of the marker in the title -- in the following graph key,
40%78-'�0-1-8 was entered into the Title on the left of the marker field and 0-59-(�0-1-8

was entered into the Title on the right of the marker field:

 
 Figure 4.49 -- Graph Key Using Left and Right Labels

 Enter a title into either or both data entry fields.

➾ LD4 draws the left marker title flush against the left side of the column: if you want to make
some space between the left column border and the start of the title, add some spaces at the
start of the left title text.  For example, the graph title below was created by placing 12 spaces
in front of 13-7896) in the Title on the left of the marker field:

 
 Figure 4.50 -- Centered Graph Key

➾ LD4 won’t draw a key in the column title for that graph if a title isn’t entered into either the
Title on the left of the marker or Title on the right of the marker fields.  (If the graph requires a
scale, the scale will still be drawn).

➾ “User-selectable marker” graphs (discussed later) do not support a title on the right of the
marker.

➾ Multi-source graph reports don’t support titles at the top of the graph column because multi-
source graphs use different markers to denote the same data item depending upon which
boring is being plotted.  Instead, a graph key is added to the form’s heading or footing -- see
Section 7.3.2 for instructions.
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6. LD4 supports two horizontal graph scaling options: linear and semi-log (both scaled linearly in the
vertical direction relative to drilling depth).  Select one of the two graphing options at the Type of

graph prompt.

       
 Figure 4.51 -- Linear and Semi-Log Graphs

7. At the left-hand value prompt enter the scale value at the left side of the column: for most
geotechnical applications (graphing N-values, shear test results, moisture contents, etc.), this
should be �.

8. At the Right-hand value prompt enter the numeric value that would cause a marker plotted on the
graph to show up on the right side of the column.  (For N-value, natural moisture and Atterberg
limit graphs, �� or �� is common.)

➾ Note: if you’ve already added a graph to the column, LD4 will suggest using the same left and
right-hand values as the previous graph.  If you enter different values LD4 will plot a new
graph scale above the previous graph’s key at the top of the column.  (In Figure 4.46, the
shear test values graph was added with 2.4 as the right-hand graph values, while the
previous graphs in the column -- the moisture and Atterberg limits graphs -- both used 80 as
the right-hand value.)

9. For linear graphs, next enter the number of labeled vertical lines into the Labeled vertical grid

lines> Number field.   (For example, a typical graph extending from 0 on the left side to 70 on the
right side would have 6 labeled grid lines -- 10, 20, 30, 40, 50 and 60; “0” would be on the left side
of the column and “70” would be on the right side.)
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10. At the Type box you can select the type of line that will be used for the labeled vertical grid lines.
In addition to dotted, dashed and solid lines, LD4 offers a “tick marks” option that will draw tick
marks at even intervals across the graph instead of drawing vertical lines down the length of the
graph column.

11. At the Unlabeled lines > Number per labeled line field, select the number (and type) of lines that
will be drawn in-between each labeled vertical graph line.  (Because many LD4 graphs are placed
in relatively narrow table columns, it is normal to have � unlabeled lines in-between each labeled

line.)

12. In the Scale label orientation box, select a presentation method for the horizontal scale that is
plotted at the top of the graph.

13. Refer to the instructions in Section 4.11.5 if you would like to use the Choose labels for each

labeled vertical grid line option to further customize the presentation of the graph’s horizontal
scale labels (for instance, by changing the numeric labels into the “FR”, “SW”, “MW”, “HW” and
“XW” labels on SAMPLE20’s “Weathering” graph.)

14. Click on the Font & Text tab to change the typeface used for the graph scale labels.

 
 Figure 4.52 -- Add Graph Dialog, Font Tab

 When a graph is added to a column, LD4 uses the font chosen for the column’s titles to draw the
graph’s scale labels (see Section 4.3 for information on this selection); you can select a different
font by unchecking the Use the default font for graph scale labels? box.  (It’s common to select a
smaller point size for a graph’s scale labels to avoid having the labels overprint each other.)



Editing the Report’s Table Section

160

15. The Print out-of-bound values in red option highlights the text printed next any marker that would
fall off the right side of the graph by printing it in red, like the example shown below:

 
�Figure 4.53 -- Out-of-Bound Marker

 Without the Print out-of-bound values in red selection, the value still prints (“89” in the example
above) -- it just prints in black instead of red.

15. As noted in the previous step, LD4 prints out the values of any data to be graphed which would
fall past the right side of the column.   The Print the text of any graph values that aren’t strictly

numbers  option does the same for any value to be graphed that wasn’t entered as just a numeric
value.  This option is very handy for indicating SPT refusal: on an SPT graph that ranges
horizontally from 0 to 70, normally a blow count of 50/3” (since it doesn’t fall of the right side of the
graph) would just show a marker at 50; there would be no indication of refusal.  With the Print the

text of any graph values that aren’t strictly numbers  box checked,  ����z appears above the

graph marker.

 
�Figure 4.54 -- Graph Marker with Text

 With the option selected, markers placed on the graph for any value that wasn’t entered as just a
number will show the value entered above the marker.

➾ For this option to work, the values to be graphed must start out with a number -- for example,
����z.  Values that don’t start out with a number won’t print at all: 748!����z will not be

graphed.

16. Entering a measurement into the Additional space to shift the graph titles and scale upwards box
shifts the graph scale and title in column title block upwards by that amount.  This is necessary on
very rare occasions to make additional room for some custom text placed into the title block with
the “Absolute placement” facility discussed in Chapter 5.
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LD4 supports five basic graph types, as shown in the table below.  Further setup instructions for
each type are given in the sections listed in the table.

Graph
Type

Description Covered In

Bargraph Graphs data as a series of bars.  Bars may be filled
with a solid or hatch pattern, or left unfilled.

Section 4.11.3

Brackets Brackets are designed to show a minimum to
maximum range.  Typically they’re used to present
Atterberg plastic and liquid limit data.

Section 4.11.4

Discrete
Markers

Graphs data as a series of circles, squares,
triangles, etc.  Each reading graphed may be
connected to the next deeper reading by a line.

Section 4.11.1

User-
Selectable
Markers

Similar to the “Discrete Markers” graph, but,
instead of using a single symbol to graph all
readings, uses a symbol selected during data entry
for each reading to be graphed.  Normally used to
plot shear test results by using a different symbol
to represent each possible shear test type (e.g., a
square represents a torvane test, a circle
represents an unconfined compression test, etc.)

Section 4.11.2

Multi-
Source
Graphs

These graphs show the data from multiple borings
on a single table.  A special type of report form
(called a multi-source graph report) must be
created to use this type of graph.

Section 7.3

Table 4.7 -- Types of Graphs
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4.11.1 Discrete Marker Graphs

Discrete marker graphs use a symbol from the MISC graphical symbols library (such as a filled
circle or square, a diamond, triangle, etc.) to denote the data being graphed.

1. Begin by following the steps listed at the start of Section 4.11.  After setting up the Labels and
Font & text tabs, click on the Markers tab.

2. In the Graph data as box select “Discrete markers”.

3. In the Marker box, select the type of marker to be used to graph the data.

➾ You can omit the marker and just draw a line between successively deeper test values by
selecting the “No marker - line only” selection.

4. In the Size box, select the size of the resulting marker.   (.5 scale, the normal selection, draws the
graph markers 1/2 the of the size at which they were designed.)

5. Click on the Graph what? tab.

 
 Figure 4.55 -- Add Graph Dialog, Graph What? Tab

6. At the Graph what? prompt, enter the data entry field to be graphed.

7. When graphing values obtained from soil or rock samples it’s customary to vertically center each
marker halfway between the top and bottom of the corresponding sampling interval: to do this,
enter 7%14C0)2�1-236C'32:)68�� into the Distance (in ft. or m.) to offset the graph item below

the item’s starting depth  field.

➾ “MINOR_CONVERT” is initialized to “12” when plotting projects taken in feet/inches and “100”
when plotting SI projects -- this has the effect of converting the sampling length from inches to
feet and from centimeters to meters.  The “/MINOR_CONVERT”  inches-to-feet and
centimeters-to-meters part of the equation is required because the vertical offset is supposed
to be given feet or meters, not in inches or centimeters.
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8. Optionally, you can choose to connect successively deeper markers with a line: to do this, click on
the Connecting line tab.

 
�Figure 4.56 -- Add Graph, Connecting Line Tab

9. Select the type of line to be used in the Marker connecting line type.

10. You may want to avoid connecting successively deeper markers if a discontinuity lies between the
depths where the two data values were taken.  To do this you’ll need to add a field to your data
entry card to select depths where lines are not to be drawn: refer to Section 1.4 for instructions on
adding the field; give the field the name (-7'328-29-8=, the field type should be =2.

 After adding the new data entry field, return to the “Place a Graph in the Current Column” dialog
and check the Indicate during data entry that successive markers will be connected box.  Next,
enter the name of the discontinuity data entry field (it should be called (-7'328-29-8=) into the

If so, select the field that will used to specify if the markers are connected  box.
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4.11.2 User-Selectable Marker Graphs

 
�Figure 4.57 -- Add Graph Dialog, User-Selectable Markers Tab

When graphing data that may be obtained from a variety of different testing methods (like, for
example, shear test results) it’s useful to have the data marker indicate the type of test used to
produce the result.  For example, on a graph of shear test results, triaxial shear results may be plotted
as a triangle, unconfined compression results show as squares, etc. To plot this type of graph, you
need to have two entry fields per data entry card: one to select the type of test the second for entering
the test result.

1. Begin by following the steps listed at the start of Section 4.11.  After setting up the Labels and
Font & text tabs, click on the Markers tab.

2. In the Graph data as box select “User-selectable markers”.

3. In the Size box, select the size of the resulting marker.   (.5 scale, the normal selection, draws the
graph markers 1/2 the of the size at which they were designed.)

4. At the Field used to select the marker type box, select the name of the data entry field that you’ll
be using to specify the type of test performed.  (When graphing shear tests, this should be
78=4).)

5. At the For each symbol, enter the symbol ID, followed by a “,” and the symbol name:  prompt you’ll
need to establish a data entry shorthand for specifying the types of markers that will be used to
graph your data (e.g., “use a square marker to indicate vane shear tests”, etc.).

 Each type of test to be graphed will need a specific code that can be typed into your “type of test”
data entry field, along with a graph marker (e.g., square, triangle, circle, etc.) to be associated
with that test type.  In the box, you’ll need to enter (one per line) the code that you’ll use to specify
a test type (e.g., “TV” for torvane, “HP” for hand penetrometer, etc.), followed by a comma then
the name of a symbol from the MISC graphical symbols library that is to be used when plotting
data for that particular test type (Chapter 9 covers LD4’s graphical symbols libraries in detail).
(You can find the names of LD4’s graph markers by clicking on the “...” button.)
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  Following is a typical configuration for a graph of shear test values:

� ,4�*'-6'0)

� 8:�*759%6)

� 9'�*86%2+0)

� 99�

� '9��(-%132(4

 This sets up the graph so that, for example, if 9' is entered as the type of test performed,  a filled

triangle will be plotted in the graph.

6. Click on the Graph what? tab.

7. At the Graph what? prompt, enter the data entry field that will be graphed.

8. When graphing values obtained from soil or rock samples it is customary to vertically center each
value’s marker halfway between the top and bottom of the sampling interval.  To do this, enter
7%14C0)2�1-236C'32:)68�� into the Distance to offset the graph item below the item’s

starting depth  field.

4.11.3 Bargraphs

1. Begin by following the steps listed at the start of Section 4.11.  After setting up the Labels  and
Font & text  tabs, click on the Markers  tab.

 
�Figure 4.58 -- Add Graph Dialog, Bargraph Markers Tab

2. In the Graph data as  box, select “Bargraph”.
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3. Choose the type of fill for the bargraph at the Fill type box.  The available fill selections are shown
below:

    
 

    
 Figure 4.59 -- Bargraph Fill Selections

4. With “Filled”, “Hatched” and “Cross-Hatched” graphs, you have the option of either drawing each
bar down to the depth of the next reading to be graphed, or of making the height of the bar
proportional to the length of the sample from which the test reading was taken.  All of the samples
above show the bars being drawn down to the depth of the next reading, while the following figure
shows a bargraph drawn so that the height of each bar is proportional to the length of the
corresponding test sample.
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 Figure 4.60 -- Graph with Proportional Bar Heights

 If the graph is to use proportional bar heights, you will need a data entry field (on the tabulated
data portion of the data entry form to be used) where the heights of each bar can be entered.
Since typically the bar heights are proportional to the length of the soil sampling intervals, if you
already have a data entry field available for entering sample lengths, no further change is
necessary.  Otherwise, add a data entry field to the table section of the data entry form that you’ll
be using (see Section 1.4 for instructions) so that you can enter the sample lengths.

 Once the data entry field is in place, enter the name of the field (this will usually be 7%14C0)2)

into the Bar height in ft. or m. field.

 LD4 expects that the bar heights will be given terms of feet or meters of drilling.  If you will be
entering sampling lengths in inches or centimeters you must use an equation to convert the
lengths to feet or meters: adding �1-236C'32:)68 after the name of the data entry field causes

the sampling lengths to be converted from inches or centimeters to feet or meters.

 For example, since most reports will use the data entry field named SAMP_LEN to enter the
sampling lengths (and graph bar heights) the equation entered into the Bar height in ft. or m. field
will be 7%14C0)2�1-236C'32:)68�  (For a discussion of the “/MINOR_CONVERT” part of the

equation, see the Customization Guide’s Appendix A.)

5. At the Graph what? prompt, enter the data entry field that will be graphed.

➾ The Distance (in ft. or m.) to offset the graph item below the item’s starting depth  field is
seldom used with bargraphs -- for information on this field, see Section 4.11.1.

4.11.4 Brackets

For paired test results such as plastic and liquid Atterberg limit values, you’ll want to graph the
data as brackets.
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1. Begin by following the steps listed at the start of Section 4.11.

➾ Tip:  In the graph’s title area, LD4 draws the sample bracket to fit the width of the column,
minus the space taken up by the left and right bracket labels.  To make the bracket narrower,
add spaces before the left bracket label and add “^” signs after the right bracket label; e.g.,
00BBB.

2. After setting up the Labels and Font & text tabs, click on the Markers tab.

3. In the Graph data as box select “Brackets”.

4. Click on the Graph what? tab.

5. In the Left field, enter the name of the data entry field where you’ll be entering the bracket left-
side (e.g., minimum) values: for Atterberg limit graphs, this will be 40.

➾ If you’re used to entering plasticity index instead of plastic limit, set the left bracket item to
�00�4-�.

6. In the Right field, enter the name of the bracket right-side data entry field -- this should be 00 for

Atterberg limit graphs.

7. When graphing values obtained from soil or rock samples it is customary to vertically center each
value’s marker halfway between the top and bottom of the sampling interval.  To do this, enter
7%14C0)2�1-236C'32:)68�� into the Distance to offset the graph item below the item’s

starting depth  box.

8. You can select the type of horizontal line used to draw the bracket by clicking on the Connecting

line  tab and using the Bracket line type  box.
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4.11.5 Custom Graph Labels

Normally LD4 places a label above every “labeled grid line”: a graph extending from 0 to 70 with 6
labeled vertical lines will have “10”, “20”, “30”, “40”, “50” and “60” as scale labels at the top of the
column.  If the column is relatively narrow, the labels may overlap each other like in the following
example.

 
�Figure 4.61 -- Graph with Inadequate Scale Space

 There’s three options for dealing with this situation: 1) dropping every other graph line by halving
the number of labeled vertical lines, 2) selecting a smaller point size for the label’s text or 3)
dropping every other label, while retaining the lines.   To drop the labels, you’ll need to tell LD4
which labels actually should be drawn by using LD4’s custom graph scale labels option.

 One other use for setting up a graph with custom labels would be for a rock weathering graph
such as the one included in SAMPLE20.  SAMPLE20’s weathering graph, instead of showing
numbers at the top of each labeled vertical line, shows text (“FR”, “SW”, “MW”, “HW”, “XW”).
During data entry, a � is entered into the “Weathering” field to indicate FR weathering, � is

entered to indicate SW weathering, etc.  The graph’s title looks like this:

Figure 4.62 -- Custom Graph Scale Labels

To customize a graph’s scale labels:

1. First set up the graph by following the directions given in Section 4.11.

2. Next, click on the Labels  tab of the “Place a Graph in the Current Column” dialog.

3. Check the Choose labels for each labeled vertical grid line  box.
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4. In the field below, enter the labels that you want to have plotted, one label per line.  If you want to
have a label omitted, leave the line blank.  For example, if you want to plot a graph ranging from 0
on the left to 80 on the right while omitting every other label, enter

 �

 (leave this line blank)
 ��

 (leave this line blank)
 ��

 and so on.

➾ You may elect to either enter labels just for the interior grid lines or for the interior grid lines
plus the left and right edges of the graph.  If you enter two more labels than there are interior
grid lines, LD4 will place the first label against the left edge of the column and the last label
against the right edge of the column.

➾ LD4 also supports non-linear graphs: if you enter �, �, �, ��, ���, ��� as graph labels, the

program will do the work of figuring out where to plot, for example, a test result of 7.
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4.11.6 Step by Step Example: Adding an N-value Graph

This section provides instructions for adding an SPT N-value graph to a report table; with slight
modification, you can also use these instructions to add a natural moisture or Atterberg limit graph, or
even add all three graphs to the same column.

1. Before using a data entry field on a report form you must modify the data entry form used by the
report (see Section 2.7) so that it includes the field to be used.  Refer to Section 1.4 for
instructions the following data entry field:

 Prompt: 748

� ��� 2�ZEPYI

 Field name: 2:%09)

 Field type: (leave blank)
 Field width: �

2. Now that you have a field for enter N-value data, edit the report form (Tools > Report Forms) then
follow the directions given in Section 4.1 for selecting the table column where you want to add the
graph.

3. After selecting the appropriate table column choose Add > Add Graph of Data vs. Depth.

4. Select “Discrete markers” in the Graph data as box.

5. Select “Circle” in the Marker box.

6. Click on the Graph what? tab.

7. Enter 2:%09) into the Graph what? field.

8. Enter 7%14C0)2�1-236C'32:)68�� into the Distance (in ft. or m.) to offset the graph item below

the item’s starting depth  field.

9. Click on the Labels  tab.

10. Enter 748�2�ZEPYI into the Title on the left of the marker  field.

11. Select a “Linear” graph type.

12. Enter � into the Scale> Left-hand value box.

13. Enter �� into the Right-hand value box.

14. Enter � into the Labeled vertical grid lines> Number box.

15. Click on the OK button.
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4.11.7 Step by Step Example: Creating a Graph of Shear Test Results

1. When entering each shear test result you’ll also need to enter a code indicating the test method
used to produce the result (torvane, hand penetrometer, etc.).  Rather than memorizing the codes
you can set up a picklist of test methods: to do this, open a project file then choose Legend > Edit
the Default Legend.  If this selection isn’t available then you’ve created a custom legend for the
project -- you should choose Legend > Revert to the Default Legend so that the modifications
you’ll be doing will affect all future projects, then select Legend > Edit the Default Legend.

2. Select Legend > Add a New Legend Table.

3. Select “List of items for popup menu during data entry”.

4. As a name for the list, enter 78=4).

5. In the data entry cards for the table that pops up, enter the code for each test (into the Item field)
then a short description:

 Item: ,4�Description: ,ERH�4IRIXVSQIXIV

 Item: 8:�Description: 8SVZERI

 Item: 9'�Description: 9RGSRJMRIH�'SQTVIWWMSR

 Item: 99�Description: 9RGSRWSPMHEXIH�9RHVEMRIH

6. Since the graph will use a different marker for each test method (e.g., hand penetrometer tests
will be shown on the graph as circles, torvane tests will be shown as triangles, etc.) you’ll need a
key indicating which marker belongs with which test method.  You can either place the key at the
bottom of the boring log form by using the techniques discussed in Section 3.11 (add a filled circle
symbol to the footing; next to it, add the text “=Hand Penetrometer”; to the right, add a filled
square symbol, next to that add the text “=Torvane”, etc.) or you can modify the legend page so
that it includes a description for each graph marker.

 To modify the legend page, click on “MISC” in the list of legend tables shown on the left side of
the screen.

 Next, locate the data entry card that has “FCIRCLE” next to the Symbol(s) prompt.  If you can’t
find one, locate the first blank card then type *'-6'0) into the data entry field to the right of

Symbol(s).  In the Description field, type ,ERH�4IRIXVSQIXIV.

 Locate or create a card for “FTRANGLE” then type 8SVZERI into the Description field.

 Locate or create a card for “FSQUARE” then type 9RGSRJMRIH� 'SQTVIWWMSR into the

Description field.

 Finally, locate or create a card for “*” then type 9RGSRWSPMHEXIH�9RHVEMRIH into the

Description field.

7. Next we’ll need to add the data entry fields: select Tools > Data Entry Forms.
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8. Click on the Tabulated Data tab then, by following the instructions given in Section 1.4, add the
data entry fields shown below:

� First, if your data entry form doesn’t have a field for entering sampler lengths, add one:
�

 Prompt: 7EQTPI

� ��� PIRKXL

 �MR��SV�GQ��

 Field name: 7%14C0)2

 Field type: (leave blank)
 Field width: �

 
 Next, add the shear test method field:
�

 Prompt: 8]TI

� ��� SJ

 WLIEV�XIWX

 Field name: 78=4)

 Field type: 78=4)

 Field width: �
�

➾ Note: the 78=4) field type is the name of the list that we created in Step 4.  Making the field

type 78=4) causes LD4 to show a popup list of shear test types during data entry.  (Section

1.4.2 covers picklists in detail.)

 Add the test result field:
�

 Prompt: 7LIEV

� ��� WXVIRKXL

 

 Field name: 7,)%6

 Field type: (leave blank)
 Field width: �

 
9. Now it’s time to modify the report form.  Select Entry Form > Exit then Tools > Report Forms and

(if it doesn’t automatically open), open the report form to be modified.

10. Follow the directions given in Section 4.1 for selecting the table column where you want to add
the lines.

11. Select Add > Add Graph of Data vs. Depth.

12. From the Graph data as: box select “User-selectable markers”.
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13. At the Field used to select the marker type box, enter 78=4) (this is the name of the data entry

field where you’ll be entering codes to indicate which shear test method was used).

14. At the For each symbol, enter the symbol ID, followed by a “,” and the symbol name  box, enter the
following (one entry per line):

� ,4�*'-6'0)

8:�*86%2+0)

9'�*759%6)

99�

�

➾ Note that the “HP”, “TV”, “UC” and “UU” are the codes that you set up in the legend picklist in
step 5;  the symbol names should match those you entered into the Symbol(s) prompt in Step
6.

15. Click on the Graph what? tab.

16. Enter 7,)%6 into the Graph what? field.

17. Enter 7%14C0)2�1-236C'32:)68�� into the Distance (in ft. or m.) to offset the graph item below

the item’s starting depth  field.

18. Click on the Labels  tab.

19. Enter 7LIEV�8IWX�6IWYPXW into the Title on the left of the marker  field.  (The “right side” title

isn’t used for this type of graph.)

20. Choose “Linear” as the Type of graph.

21. Enter � for the left-hand scale value.

22. Enter ��� for the right-hand scale value. (If you’ve already added a grid to this column, you’ll

need to select a right-hand value that evenly divides by the number of vertical grid lines selected
for the prior grid.  In our example we’ll be using 7 grid lines which, with 1 added to take into
account the grid increment between the last grid line and the right side of the column, nicely
divides 2.4: 2.4/(1+7) gives 0.3 tsf per grid line.)

23. Enter � into the Labeled vertical grid lines> Number: field.

24. Click on the OK button to close the dialog.
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4.12 Adding Groundwater, Caving, Seepage and Other Symbols to a Table
Column

Commonly, the subsurface portion of drilling log forms features symbols indicating groundwater
and caving depths like the examples shown below.

              
Figure 4.63 -- Groundwater Symbols
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Figure 4.64 -- Groundwater and Caving Symbols Centered in a Column Border

Figure 4.65  --  Graphical Symbols Used to Indicate Seepage Depths
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To add a graphical symbol to the subsurface table:

1. First off,  if you haven’t yet done so, you will need to provide a data entry field for entering the
depth where the symbol is to be printed.  If the symbol is to appear at only a single depth (such as
the groundwater depth at first check, the depth to caving, the installation depth for a well pump,
etc.), follow the directions given in Section 1.3 to add the field to the Source Data section of the
data entry form you’ll be using.  Conversely, if the symbol can possibly appear at multiple depths
within a single boring, follow the directions given in Section 1.4 to add the field to the Table
section of the data entry form you’ll be using.

2. Follow the directions given in Section 4.1 for selecting the table column where you want to add
the lines.

➾ You can center the symbols on the border between two columns (like the example shown in
Figure 4.64) by placing the symbols in a column of their own that is 0.001 inch wide (see
Section 4.4).  Make the Weight of Line at Column Right for the symbol’s column equal to �RS

PMRI�.

➾ To produce a report where the groundwater symbols are attached to the left of a graphic log
column (like the example shown in Figure 4.63), place the symbols in a column of their own
immediately to the left of the graphic log column.  Make the Weight of Line at Column Right for
the symbol’s column equal to �RS�PMRI�.  When asked (see below), use one of the following

symbols from the MISC library: “LWATER” or “LWATERNF”.  Set the symbol’s Horizontal

justification to “Right”.

3. When the appropriate table column has been chosen, select Add > Add Graphical symbols -- this
displays the dialog shown below.

 
�Figure 4.66 -- Graphical Symbols Dialog

4. At the Symbol library prompt, select the library that holds the symbol you want to print.  (Symbol
libraries are covered in detail in Chapter 9.)  All the symbols that are of interest (groundwater,
caving and seepage) are in the “MISC” symbol library.
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5. At the Symbol prompt, select the symbol that to be printed.  (If you want to plot more than one
symbol in the column -- for instance, a groundwater symbol to indicate depth at first check and
second one to indicate depth after 24 hours -- you’ll need to go through these steps for every
symbol to be plotted.)  If you’re not sure as to which symbol you want to use, click on the “...”
button.

➾ Typical groundwater symbol usage is: ;%8)6 for the depth first encountered, ;%8)6� for the

depth when checked after 24 hours, and *;%8)6 for the final depth check.

➾ If you want to use a symbol that LD4 doesn’t yet have in its symbol libraries, consult Chapter
9 for instructions on drawing new symbols.

6. At the Field prompt, enter the name of the data entry field that will be used for finding the depth(s)
at which the symbol is to be drawn (you should have added this field in Step 1).  For symbols that
are printed once per boring (such as groundwater and caving symbols), you can find the name of
the appropriate field in the Source tab of the dictionary shown below the prompt.  For symbols
such as seepage that may be printed multiple times per boring, you can locate the name of the
appropriate field in the Table dictionary tab.

7. By default, symbols are drawn at the size in which they were designed and are shown in black.  If
you want your symbol to appear in a different size or color, continue by clicking on the Symbol

size and color tab.

 To change the symbol width or height, enter a dimension into the Width and Height fields.
Entering � into either field causes the program to plot the symbol in the size (for that dimension)

at which the symbol was designed. Note that all the symbols in the program’s symbol libraries
were designed to plot at an appropriate size without the need for entering a custom Width or
Height.

8. After printing a sample report and legend, you may need to make a final adjustment:  if the

symbol is printed with a (not in table) description next to it on the legend, refer to Chapter 4 in
the User’s Guide for instructions on entering your own description for the symbol.  (Most symbols
come from the MISC table discussed in Section 4.2.4 of the User’s Guide).
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4.13 Adding a Monitoring Well Schematic

LD4 subsurface reports (boring logs and  profiles) can include a monitoring well schematic
columns with up to three pipes per well, as shown in the example below.
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Figure 4.67 -- Example Monitoring Well Report

➾ The symbols used for the well backfill material are taken from the 786%8% graphic symbols

library.  For instructions on modifying these symbols, refer to Chapter 9.

➾ The symbols used to draw the well pipes and top caps are taken from the 4-4)7 graphics

symbols file.  It’s a very easy matter to create your own specialized pipe symbols; again, refer
to Chapter 9.

➾ The various combinations of backfill and pipe symbols available for the user to choose from
are defined through the legend facility discussed in Chapter 4 of the User’s Guide.
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To add a monitoring well column to a report form:

1. Remember: in order to print something on your report you first must be able to enter data for it.  If
you haven’t yet done so, follow the directions given in Section 1.4 to add a new field to the
subsurface section of the data entry form you’ll be using:

 Prompt: 1SRMXSVMRK

� ��� ;IPP

� ��� 7GLIQEXMG

 Field name: ;)00C-(

 Field type: ;)00C-(

 Field width: ��

 
 If you want to show multiple pipes, you’ll need to add one or two more data entry fields (so that,

for each well installation, you can pick symbols for the second and third pipes).   For additional
pipes (you can have a maximum of three pipes in the schematic), again follow the directions given
in Section 1.4 to add one or two more entry fields (depending upon whether you want to have a
maximum of two or three pipes in the schematic).

 Prompt: ;IPP

� ��� 4MTI

� ��� 2S���

 Field name: ;)00C4-4)�

 Field type: 4-4)7

 Field width: �
�

 and, if you want to have the option of adding a third pipe to a schematic:
 

 Prompt: ;IPP

� ��� 4MTI

� ��� 2S���

 Field name: ;)00C4-4)�

 Field type: 4-4)7

 Field width: �

 

2. Next, follow the directions given in Section 4.1 for selecting the table column where you want to
add the well schematic.
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3. When the appropriate table column has been chosen, select Add > Add Monitoring Well
Schematic -- this displays the dialog shown below.

 
�Figure 4.68  -- Well Schematic Dialog

4. At the Name prompt, enter the name of the data entry field where the well sections are to be
selected: This should be ;)00C-(.

5. In the Width of the well section field enter the width of the well schematic, or enter � to have the

program select an appropriate width.  By default (if you enter �), monitoring well diagrams

featuring a single pipe are drawn 0.4 inches (1 cm.) wide.  If you make your table column 0.5
inches (1.27 cm.) wide, LD4 will draw the well diagram in the center of the column with a 0.05
inch (1.2 mm) gap on the left and right of the diagram because the column width (0.5 inches)
minus the schematic width (0.4 inches) gives 0.1 inches to be used as a margin -- 0.05 inch on
each side of the schematic .

 Similarly, if you don’t select a well section width, two-pipe well diagrams are automatically drawn
0.5 inches (1.27 cm.) wide: making the column 0.6” wide (1.52 cm.) again gives a 0.05 inch gap
on the on either side of the column.  (Three-pipe well diagrams are drawn 0.6 inches (1.52 cm.)
wide.)

6. Leave the Width of the pipe within the well prompt field as � to have the software select an

appropriate width for the pipes drawn within the well; entering any other number draws the widest
pipe section at that width.

7. LD4 can include a “continue” symbol at the bottom of the well schematic if the well will be
continued onto the next page (you can see an example at the bottom of the well section in Figure
4.67).  To include the symbol, make sure that the “Continue” symbol at the top and bottom of

multi-page wells  option is selection.

➾ Note:  If you include a continue symbol as part of the monitoring well column, LD4 will shift
the start of the subsurface table downward slightly to accommodate the symbol at the top of
the well.  The subsurface section will also be terminated slightly above the horizontal line
drawn at the bottom of the table.
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8. If you want the option to have a second pipe shown within some well schematics, click on the
Second pipe tab then check the Support for a second well pipe? box and, at the Name prompt,
enter the name of the data entry field where the second well pipe sections will be chosen (this
should be ;)00C4-4)�, the name of the field you set up in step 1).

9. After setting up the second pipe, you can add the option to draw a third pipe by clicking on the
Third pipe tab: Check the Support for a third well pipe? box then enter ;)00C4-4)� into the

Name field.

➾ Note that adding the option to show a second and third pipe in a well installation schematic
doesn’t require that the pipes be drawn in every well schematic: As long as the “Well pipe no.
2” and “Well pipe no. 3” data entry fields are left blank on every data entry card for a particular
boring, the resulting report will show a well with just a single pipe.

➾ You can place piezometer or pump symbols in your well columns through the option to insert
graphics symbols as discussed in Section 4.11.6.  As an example:

To add a pump symbol to your well:

1. Following the directions given in Section 4.11.6, add a pump symbol to the same column as the
monitoring well schematic:  Your dialog should have the following settings:

 Symbol file: 1-7'

 Symbol: 4914

 Depth: 4914C()48,

 Horizontal justification: 'IRXIVIH

2. If you haven’t added a field for entering the depth to the pump in each boring, click on the Can’t

find  button (below the Depth  prompt in the “Place a Graphical Symbol in the Current Column”
dialog).  Choose I have not added my item to a data entry form, select the appropriate data entry
form, then select Data taken only once per boring, then double-click on “PUMP_DEPTH” in the
following dictionary.

➾ The SAMPLE15 report form uses the same technique add piezometer symbols.
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5. Placing Information Anywhere on the Page

If you can’t precisely place something into a report’s heading or footing, or if you need to place a
page or figure number outside the report’s border, or if you want to fit a piece of text into a column’s
title block, you’ll need to use LD4’s Absolute Placement facility.   The Absolute Placement facility
allows text, logos and lines to be placed anywhere on the printable page, including outside the report
form’s border.

To place an item of text, a logo, graphical symbol or line anywhere on a report page:

1. Choose either Sections > First Page Absolute Placement or Sections > Subsequent Page
Absolute Placement.  (Section 4.1 provides a discussion of the difference between the report’s
first page and subsequent page sections.)

➾ When you’re creating a report form from scratch, begin  by working with the “First Page

Absolute Placement” section.  Until you make the first modification to the “Subsequent
Page Absolute Placement” section, it remains identical to what you’ve set up for the
first page section.

 
 Figure 5.1 -- Absolute Placement Facility

2. To place an item, locate a blank row in the grid, click in the Text column and enter your text.
(Note that the ordering in which rows are entered is unimportant.)  Here are a couple of rules to
follow to add different items:
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➾ If your report form is tagged as being LOGDRAFT III-compatible, you will be limited to just 33
characters.  If your text is longer than 33 characters you can either A) turn off the LOGDRAFT
III compatibility option (see Section 2.5.1) or B) enter your information on multiple rows.  If
you opt for B), enter �� as the horizontal and vertical coordinate in all rows that should be

combined with the first row.

➾ To print the contents of a data entry field, enter an $ sign, followed by the name of the field

that you want to print; for example, to print the boring number, type $&36-2+ into the Text

column.

 You can also combine some fixed text with the contents of a data entry field: *MKYVI

$*-+96) prints the word “Figure”, followed by whatever was selected as the current report’s

figure number.  Another example: 4EKI�$4%+)�SJ�$4%+)C0 prints the page number of the

current page and the number of pages to be printed; e.g., “Page 3 of 5”.

➾ To place a logo or other picture somewhere on the report, enter $03+3�logoname� into the

Text column: logoname is the name of your picture file, without any extension.  The file should
be stored in the same directory as the program and can be a bitmap (e.g., a file ending in
.BMP) or monochrome .PCX.  Note that the horizontal and vertical coordinates given for the
item (as discussed in the next step) are for the top-left corner of the logo.

 Many of the sample forms (DEMOLOG for example) use $03+3�$'2%1)� -- instead of

naming a specific picture file, the “@CNAME” part tells LD4 to use a logo appropriate for
whoever is using the software.  This allows GEOSYSTEM to design forms that may be used
by many organizations; we couldn’t do this if we used, for example, $03+3�%0:)2+-2))67�

in the sample forms -- ALV Engineers would be happy with our forms while everyone else,
stuck with ALV’s logo, would be decidedly unhappy.

➾ LD4 has a rather convoluted syntax for placing a graphical symbol such as a groundwater
symbol: you’ll need to enter $symbolfile�symbolname�width in inches��height in inches�.

 symbolfile is the name of one of LD4’s graphical symbol libraries: MISC, STRATA,
SAMPLERS or PIPES, although MISC has most of the symbols that would be useful for
directly placing somewhere on a report form.  (Don’t forget to put the $ sign before the symbol

file name.)

 symbolname is the name of the symbol to be plotted: you can get the names of the symbols
stored in a particular library by using the symbol editor facility discussed in Chapter 9.

 width in inches and height in inches are the desired width and height for the symbol.  Note
that this measurement is always in inches, regardless of whether or not the program’s default
measurement system is inches or centimeters.
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 An example: $1-7'�*;%8)6������� plots a 1/10” square groundwater symbol.

➾ $(0-2)�x1�y1�x2�y2�line weight� draws a line weight thick line from (x1,y1) to (x2,y2).

line weight should be a number from 1 to 9;  the endpoint measurements are given from the
top-left of the page and are always given in inches.  (Again, don’t forget to put the @ sign
before the word DLINE.)

3. After entering the item to be printed, hit enter then type in the horizontal and vertical coordinates
of the top-left corner of the item.  When entering DLINEs, note that these coordinates are ignored
-- you may safely leave then at �; otherwise, these coordinates are from the top-left corner of the

printable page.

4. Next, select the typeface, size, style and color of the text to be plotted: DLINEs and graphical
symbols ignore these selections.

 

To delete a row from the Absolute Placement table:

1. Click on the row number: this should highlight the entire row.

2. Select Edit > Delete.
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One limitation of the absolute placement facility is that generally you can’t use it facility to place
subsurface table columns outside the border as was done with the scale on the right-hand side of the
table in the example below.
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Figure 5.2 -- Scale Outside of Report Border

Instead, you’ll need to:

1. Turn the border drawing option OFF (see Section 2.5.2)

2.  Use the line drawing options discussed in Section 3.2 to draw border lines at the left, top, right
and bottom of the heading and footing (leave as much blank space between the right border line
and the right edge of the paper as you’ll be taking up with your table column).

3. Set the “line after weight” for the column before the column that you want to be outside the border
to be the weight of your border line

4. Set the last column’s top, bottom and right line weights (e.g., the column that you want to have
appear outside the report border) to �.

scale outside
of border
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6. Compatibility with LOGDRAFT III

Users upgrading from the MS-DOS LOGDRAFT III program can use their old LOGDRAFT report
designs with LD4.

➾ When you received your LD4 upgrade, you should have received a document titled
“LOGDRAFT III Upgrade Issues”: This document contains notes on problems that you might
run into when using LOGDRAFT III-created report and data entry forms with LD4.  An up-to-
date copy of this document is also posted to the LD4 section of our web site
(www.geosystemsoftware.com).

➾ Initially, old report designs created with LOGDRAFT III won’t be able to take advantage of the
new features offered by LD4.  If color or TrueType fonts are desired, open the Form Settings
dialog (discussed in Section 2.5), click on the Report tab, and turn the “LOGDRAFT III
compatible form” selection off.   Once this is done the form will no longer be useable by the
MS-DOS LOGDRAFT program.

LD4’s report forms are located in the same hard disk subdirectory as LD4.  If LD4 is used to
modify a LOGDRAFT III report, the file must then be moved back to LOGDRAFT III’s program
directory before the report may be used with the older program: this can be done using the Windows
File Manager or Explorer programs (move all the files that have the same name as the report,
regardless of the file’s extension).  Once the modified report has been returned to the LOGDRAFT III
program directory, start LOGDRAFT III, then select Format, Design from LOGDRAFT’s opening
menu.  Next, select Edit, choose the form that has been modified with LD4, then Convert -- this
converts the report form back to a LOGDRAFT III-useable format.
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6.1 LOGDRAFT III First and Page 2,3,4... Templates

Early versions of LOGDRAFT III  required separate report forms for the first page of the report
and the subsequent pages of the report if different degrees of information was to be shown (typically
the first page listed much more information in the report’s heading and footing).  Later versions of
LOGDRAFT (and continuing with LD4) added an option to combine both report pages into a single
form; LD4 doesn’t support the separate report form feature.

Because LD4 doesn’t support separate report forms for the first and subsequent boring log
pages, users with LOGDRAFT III report designs old enough to require separate forms for the first and
subsequent pages will need to combine the forms into a single file.

To combine separate LOGDRAFT III “First Page” and “Page 2,3,4...” report forms into a single file:

1. Using LOGDRAFT III (your MS-DOS drilling log program), choose Print, then Print again and
select a project (any project will do) for printing.

2. From the “SELECT OUTPUT OPTIONS” screen,  make a note of the First Page Template and
pages 2,3,4... selections: these are the report forms that you will be modifying.  (If the two
selections are the same, e.g., “BORELOG”, then you don’t need to go through this procedure.)

3. Exit LOGDRAFT III and start your Windows LD4 package.

4. From the LD4 opening screen, choose Tools > Report Forms.

5. If LD4 doesn’t show a report selection dialog, choose Report > Open.  Once the report selection
dialog has been shown, select the form that you noted was used as the First Page Template in
LOGDRAFT III.

6. Choose Tools > Combine with Another Form.

7. Click on the Continue button.

8. From the following “Report Forms” dialog, click on the form that you noted was used as the page

2,3,4... form in LOGDRAFT III then click on the OK button.

9. On the form preview screen, click on the 1 and 2 buttons and make sure that the two pages look
similar.

10. If everything looks copacetic, select Report > Exit; if you have any doubts, Report > Abandon
Changes will reverse the procedure.
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7. Notes on Specific Report Types

Most of the Customization Guide has focused on creating drilling log reports.  LD4 also creates
other types of reports: subsurface profiles, project summaries and legends.  This chapter covers
some specifics on creating these other types of printouts.

7.1 Subsurface Profiles
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Figure 7.1 - Profile Report

Subsurface profiles are reports that can be used to show more than one boring per page.  When
you create the subsurface table for a profile report, you’re telling the program how to draw a single
boring: LD4 uses the same subsurface table entries to draw each boring.  This involves using the
Table section of the form (discussed in Chapter 4) to lay out the items that should be shown for a
single boring on the profile.  For example, LD4 drew Figure 7.1 from a report form whose subsurface
table consisted of two columns: one column containing the boring number and the stratigraphy and
the second column containing the groundwater symbols.  LD4 then used the same two table columns
to draw each boring.
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As to where the borings are drawn, this is a decision that isn’t made until the profile is actually
printed.  The same report form can be used to print borings that are elevation-adjusted and
proportionally scaled horizontally, or evenly spaced horizontally and lined up vertically.

➾ The Form Settings dialog’s Profile tab, discussed in Section 2.5.5, covers the settings used
for changing the appearance of the profile’s horizontal and vertical scales.

  Placing boring numbers, elevations, etc. above the top of each boring

Profile reports typically add the boring number to the top of the stratigraphy column, as Figure 7.1
illustrates.

➾ Because they’re centered over each boring, the boring number should be added to the center
column of the columns on the report’s table.

➾ To add boring numbers to a profile, use the Add User Entered Data, Equations, etc. facility
discussed in Section 4.6: in the Print what? field, enter &36-2+.  Select “Centered” as the

Horizontal justification.  Finally, click on the Print when tab, select “Print this item at depths
entered into another data entry field” and, in the Depths specified by field, enter 834.

To plot both boring numbers and elevations at the top of each boring on the profile:

1. Use the table editor discussed in Section 4.1 to select the table column where you want to print
the boring number and elevation (remember, this should be the center column of the set of
columns on the table).

2. After selecting the appropriate table column, choose Add > Add User Entered Data, Equations,
etc.

3. At the following dialog, click on the Formatted button.

4. Click on the Entered/Calcd. button.

5. In the What to print box, enter &36-2+.

6. Click on the Line break button.

7. Click on the Entered/Calcd. button.

8. In the What to print box, enter )0):%8-32.

9. Click on the OK button.

10. In the “Place a Text Item in the Current Column” dialog, click on the Justification tab.

11. Select “Centered” as the Horizontal justification.

12. Click on the Print when tab.

13. Choose “Print this item at depths entered into another data entry field”.
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14. In the Depths specified by field, enter 834.

15. Click on the OK button.

16. The boring number and elevation must be the first item listed in the Stuff Included in Column list.
If it isn’t, click on the entry then choose Edit > Move Item Up.  Repeat this step until “Report
“%s\n%s”,BORING,ELEVATION” is the first item in the list.

17. Now there’s two lines of text to be shown at the top of each boring: when a horizontal scale is
plotted at the top of the profile (as shown in Figure 7.1) the boring number and elevation text is
likely to run into the scale.  To avoid this, select Sections > Form Settings, click on the Profile tab
then change the Horizontal scale location to “Bottom of profile”.
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7.2 Creating a Project Summary
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Figure 7.2 -- Project Summary

LD4 has a facility for listing every single item of data entered into a project.  These reports, called
project summaries,  are useful for data entry checking and as hardcopy records.

To set up a project summary:

1. From the LD4 opening screen choose Tools > Report Forms.

2. At the “Report forms” dialog, enter 463.791 (this is the name of the report you’ll be creating -- if

the dialog already lists a form called “PROJSUM”, choose a different name).

3. Enter 4VSNIGX�HEXE�WYQQEV] into the Description field then click on the OK button.

4. At the “Create a New Report Form” dialog, click on “Project Summary” then click on the Continue

button.

5. Next, a data entry form selection dialog will be displayed.  In order to summarize your project’s
data, LD4 needs to be told what kinds of data will be entered into your project file: this is
accomplished by selecting on the data entry form that will be used with your project.

6. Click on the Continue button.

 You now have a project summary form.  This form isn’t pretty, but,  since it’s now editable just like
any other form you may want to change the form’s fonts, drop some data or maybe remove the
“greenbar” shading (see Section 2.5.6).  When you’re ready to use it, open your project, select
Print > Reports, select the borings that you want to summarize, click on the Report form tab, click
on the Summaries radio button then select your new form from the list.
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7.3 Multi-Source Graphs
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Figure 7.3 -- Multi-Source Graph

Multi-source graph reports have fairly limited uses because their subsurface table section can be
used for showing only three things: scale bars, graphs and horizontal lines.  You can’t print text such
as material descriptions on a multi-source graph: since the same table is shared by all the borings
plotted on the report page, the descriptions would overprint each other.  (Contrast this with a profile
report:  just like on a multi-source graph, borings on a profile share the same subsurface report table,
but on a multi-source graph report the borings are all plotted in the same horizontal location on the
page while on a profile report the borings are typically plotted horizontally arranged across the page.)

➾ The report shown in Figure 7.3 includes (from left to right): a scale bar, a graph, a blank
column, a graph and a scale bar -- this basically covers everything which can be shown on a
multi-source report’s subsurface table.
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➾ A multi-source graph report’s graphs use a different marker (circle, square, diamond, etc.) for
each boring plotted.  You do not have any control over which marker is associated with which
boring.

7.3.1 Adding a Graph to a Multi-Source Graph Reports

When placing a graph onto a multi-source graph form, the procedure differs slightly from that
discussed in Section 4.11:

To add a graph to the table of a multi-source graph report:

1. Begin by following the steps listed at the start of Section 4.11.  Note that multi-source graphs
don’t have column titles so the Column title box will be disabled.

2. After setting up the Labels and Font & text tabs, click on the Markers tab: this displays a different
view than is shown when setting up a regular boring log graph.

 
 Figure 7.4 -- Markers Tab for a Multi-Source Graph

3. The Maximum number of sources to graph per page box selects how many borings will be plotted
on the graph on a single page.  If you include more than one graph on your form (like, for
example, the report shown in Figure 7.3, which has graphs of N-values and water content), it’s
critical that you select the same number of sources for each graph that you add.

4. The Color box selects the color of the graph markers.

5. Continue by following the directions for setting up the Graph what? and Connecting line tabs given
in Section 4.11.1.

6. After you’ve added the graph to the report’s table section you’ll need to add a key indicating which
graph marker was associated with each boring on the report -- follow the instructions given in
Section 7.3.2.
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7.3.2 Graph Keys

On a multi-source graph the same data item is plotted with a number of different markers (circle,
square, triangle, etc.): for each boring plotted in the graph, LD4 selects a different marker type.
Looking at the graph, there’s no way to tell which boring should be associated with which marker: to
provide this key you’ll need to add a graph key like the one below to the report’s heading or footing
section.

Figure 7.5 -- Multi-Source Graph Key

To add a graph key to a multi-source graph report:

1. Open the report heading or footing editor (see Section 3.1).

2. Choose Add > Graph Key.

3. LD4 displays the Text and Data Settings dialog discussed in Section 3.6.  Set the Font, Size, Color

and Style according to how you’d like to format the boring numbers that are printed next to each
graph marker.

 Ignore the Justify prompt: graph keys are always printed starting at the top-left of whatever
available whitespace surrounds them.

4. Point the mouse at the top-left corner of the area where you want the graph key to be printed then
click the left mouse button.  LD4 responds by displaying the dialog pictured below:

 
�Figure 7.6 -- Graph Key Dialog

5. In the Title to be shown above the key field, enter a short title.  (The title appears directly above
the key to symbols: in Figure 7.5 the title is “Key to Borings”.)

6. Click on the OK button.
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7.4 Legend Forms

Many organizations have a very detailed legend page that provides (in addition to a key to
symbols): definitions of terms, generalized notes and publication references.  Typically, this type of
legend never changes and the symbols on it are general enough to apply to any boring or project
printed.  Because the legend never changes it is recommended that the form be created with a word
processor.  Paste up any symbols necessary from the program’s generic legend (as discussed in
Section 4.3 in the User’s Guide) then use a copier to make duplicates as needed.

Some legend reports include a plasticity chart on the legend to show the correlation between
USCS classifications and PI/LL ranges.  You can’t “draw” this chart with LD4; however, you can still
place the chart into the heading or footing of a legend report by using LD4’s ability to insert arbitrary
pictures onto a form.

To include a plasticity chart on a legend report:

1. Use your favorite graphics program to draw the chart or use a scanner.

2. Save the graphic as a Windows bitmap (.BMP).  Make sure to save the file to the hard disk
directory where LD4 is installed.

3. Use the Add > Pictures facility discussed in Section 3.9 to place the graphic into the heading or
footing of your legend form.
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8. Case Studies: Changing Data Entry and
Report Forms

This chapter steps through a couple of common customization tasks from start to finish in order to
provide a feel for how the overall data entry/report form editing process works.

8.1 Adding a Column of Data to a Report’s Table

Commonly, users are most interested in making slight modifications to existing log formats.  This
usually entails adding or deleting a column of data on the report’s data table.  The following section
provides a step-by-step walkthrough of the operations necessary to add new column of data to a
boring log form.  (Deleting a column is simply a somewhat easier version of the same basic operation.
)

For the example, we’ll add a column of HNU values to the stock report form called SAMPLE1.
We’ll keep the stock SAMPLE1 format intact (so that we can create additional variations on the form)
by saving the modifications into a new form called SAM1HNU.  (While the directions below cover
adding a column for HNU readings they may be easily adapted to adding any kind of data column to a
report form’s table.)

➾ The user must be able to do two things: enter the HNU values into a project file and print the
values on the report.  This means that a data entry form must be edited to add a HNU column
to the data entry screen and a report form must be edited to add the HNU column to the
hardcopy boring log form.

Since every report form uses a specific data entry form file to determine what data items are
available to be included on the report, the new data entry form with the HNU data entry column should
be created first so that when it comes time to create the new report form to print out the HNU data,
the program will know that there is a field for entering HNU values that may be printed in the new
report.
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To create a data entry form with a field for entering HNU readings:

1. Choose Tools > Data Entry Forms.

2. If the software doesn’t automatically display a form selection dialog, select Entry Form > Open.

3. Once the dialog is displayed, click on the Sample Forms button (SAMPLE1 is stored in the sample
forms directory).

4. Double-click on “SAMPLE1”.

5. To leave SAMPLE1 intact we’ll be saving the modified form under a different name: choose Entry
Form > Save As then type 7%1�,29 as the form name.  Enter a short description for the modified

form into the Description box then click on OK.

6. Since HNU readings are data that may be entered more than once per boring the new data entry
prompt will need to be placed in the tabulated data section of the entry form: click on the
Tabulated Data tab.

7. We’ll use the techniques covered in Section 1.4 to add the new field: locate the “HNU” entry in the
yellow dictionary box (in the upper-right corner of the screen) then double-click on it.  You should
see a new HNU data entry field at the end of the sample data entry card shown in the middle of
the screen.

8. Select Entry Form > Exit.

Now that the new data entry form is completed new projects can be created using the new form
(by selecting Project > Default Data Entry Form): the new projects will include a data entry field where
the user can enter HNU readings.  However, there is no way to print out the readings because, while
we’ve made space on the data entry screen for the HNU readings, we have not yet set up a hardcopy
report form that will print out the new data.  Continuing with the our example, we’ll proceed as follows.

To create a report form with a column for printing HNU readings:

1. Choose Tools > Report Forms.

2. If the software doesn’t automatically display a form selection dialog, select Report > Open.

3. Once the dialog is displayed, click on the Sample Forms button (SAMPLE1 is stored in the sample
forms directory).

4. Double-click on “SAMPLE1”.

5. Just like with the data entry form, we’ll want to leave the SAMPLE1 report form intact, so we’ll
save our modified form to a new file: choose Report > Save As then type 7%1�,29 as the report

name.  Enter a short description for the modified form into the Description box then click on OK.
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6. Currently our report form uses the SAMPLE1 data entry form to figure out what data are available
for printing (as noted in Section 2.7, LD4 looks at the data entry form to figure out what data entry
fields are used -- the contents of these fields may be printed on your report form).  The SAMPLE1
data entry form doesn’t have a field for entering HNU readings  (we added that field to the data
entry form called SAM1HNU) so we won’t be able to print HNU readings until we tell our new
report form to look in the SAM1HNU data entry form file to get its list of data entry fields.  Select
Sections > Data Entry Form, click on “SAM1HNU” and then OK.

7. Before proceeding, you may want to see how the report currently looks: select Report > Preview.
Since there may be more than one HNU reading per boring we’ll print the data in the report’s
table section (this is where the “ELEVATION/DEPTH”, “USCS” and “DESCRIPTION” titles are).
Our new HNU column can be placed to the left of the “NM” column.

8. We’re adding the HNU column to the report’s table section so select Sections > Table.

9. Directly under the bar that says “Columns on this Form” you’ll find a list of the report’s columns:
double-click on the column that says “NM”.

10. Select Edit > Insert Column.

11. Click on word (none) (it will be shown underlined, in blue, just to the right of Title:).

12. In the Title Editor box (discussed in Section 4.3) enter ,29.

13. Make sure the Align box says “Center”.

14. Select Add > Add User Entered Data, Equations, etc.

15. The yellow dictionary in the “Place a Text Item in the Current Column” dialog that pops up should
have an entry for HNU -- click on it.  (This dialog is discussed in detail in Section 4.6).

16. Click on the OK button.

17. Select Report > Exit.

Now we have the modified report form: to use it, open a project that was set up to utilize our new
data entry form (using Project > Default Data Entry Form) enter some data, then select Print >
Reports, choose the borings that you want to print, click on the Report form tab and click on
“SAM1HNU”.



Case Studies: Changing Data Entry and Report
Forms

200

8.2 Modifying a US-Units Form to Automatically Convert to Data to SI Units

LD4 report forms can be set up to produce drilling logs in SI units (meters, kPa, kg, etc.), even if
the original data were taken in US units (feet, psi, pounds, etc.).  To produce a "unit conversion"
report from a standard US unit boring log form, choose Tools > Report Forms then, if LD4 doesn’t
automatically open the report form that you want to modify, select Report > Open and choose your
report form.  Next, since you’ll want to keep your original report form intact (and save the “unit
conversion” form as a different file), select Report > Save As then select a new name for the form.
You’re giving the name to the form that converts from US to SI units so pick something appropriate
like 97�7-�'32:)68)6.

This completes the procedure for creating a duplicate report form to work with; it’s now time to
make the changes necessary to report the data on the form in the new units you’ve selected.  These
changes can be split into two parts: heading/footing changes and data table changes (see Section 2.2
for a discussion of the parts of an LD4 report form).  The following sections cover the actual changes
required.

8.2.1 Changing a Report’s Heading and Footing Section to Convert Units

  Heading/footing changes mainly consist of converting surface elevations and
groundwater/caving depths from feet to meters.  To do this you’ll want to locate where these data are
printed: take a moment to look over the heading and footing of a printed copy of your report and
identify what data will need to be converted (again, this is usually elevations and depths to
groundwater, caving, etc.).

Next, if you’re familiar with the material covered in Chapter 3 you can select Sections > First Page
Heading (if the data to be converted is in the report’s heading) or Sections > First Page Footing.
Next, move the cursor to the place where the data to be converted is shown (you’re looking for a
magenta box which, when you place the mouse cursor on top of it, displays a small hint window
saying something like “ELEVATION” or “WDEPTH1” or “CDEPTH”, etc.) then click on the box.  You
should get a popup dialog with the data that you’re looking for in the User-entered or calculated data

field.
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If you’re not that familiar with the material covered in Chapter 3 you can have the program guide
you to the data to be converted: choose Search > Find.  In the following dialog, you’ll want to describe
what you’re looking for -- for the elevation data type in )0):%8-32; for any kind of depth data

(groundwater depths, etc.) just type in ()48,.  Clicking on the Search button displays a list of the

things in your report form that contain your search phrase.  Next, in the search results box look for
listings that start with either “First page heading (data)” or “First page footing (data)”.  Start by double-
clicking on the first match (you’ll want to do the steps below for each listed match).

Whether you used the Search facility or manually located the item that you want to change, you
should now have a “Text and Data” dialog open; in the User-entered or calculated data box you should
see the name of a data entry field (“ELEVATION”, “WDEPTH1”, etc.).  To convert the measurements
that will be typed into this data entry field from feet to meters, change the User-entered or calculated

data box to read 62(�JMIPHREQI��������: “fieldname” should be whatever was in the User-

entered or calculated data box when you began typing.  (The “*.3048” converts the measurement from
feet to meters while the “RND(...,2)” part rounds the result to 2 decimal places.)  As examples,
62(�)0):%8-32�������� prints elevations entered in feet as elevations in meters, while

62(�;()48,��������� does the same for groundwater depth measurements.

After entering the new equation, click the Place button then follow these same steps for any other
report heading or footing data that may need to be changed.
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8.2.2 Changing a Report’s Table Section to Convert Units

After adding conversion factors to the report heading and footing the next step is to modify the
report data table.   To do this, select Sections > Table, which displays the Table editor discussed in
Section 4.1.  Go through each column of the table: for each column, begin by checking the column
title (it’s shown just to the right of the word Title) for units such as feet or TSF that will need to be
changed.  Typically you’ll need to change the titles of scale, sampling length, blow counts and density

table columns.  You probably won’t  need to change the title of a column that contains a graph --
these titles are part of the graph and are discussed later.

➾ To change the column’s title (again, it’s shown, underlined, next to the Title prompt), click on
it: LD4 will pop up a title editor box just to the right of the title.

➾ One often over-looked change: if you have a column titled &03;7��z, make sure to change it

to something like &03;7����'1� while &03;7�TIV�*SSX becomes &PS[W�TIV���GQ�.

When the title is correct, check each of the items listed next to Stuff Included in Column and follow
the recommended procedures for that item given in the list below.  When finished, proceed to the

column on its right by clicking on the  toolbar button.

  Converting “Scale of Depth” or “Scale of Elevation”

1. Double-click on the “Scale of Depth” or “Scale of Elevation” Stuff Included in Column entry.

2. From the resulting dialog change the Scale units selection from “Feet” to “Meters”.

3. Close the dialog by clicking on the OK button.
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  Converting “Report” items

Most text items printed on the table don’t need to be modified -- text such as sample numbers,
material descriptions and blow counts don’t depend upon measurement units.

➾ If you have depths buried in your material descriptions, such as )RGSYRXIVIH�E�FSYPHIV

EX������JIIX, LD4 won’t be able to automatically perform the conversion.  Instead, you’ll

need to manually re-enter each such description in metric units.

For printed text that does depend upon a particular measurement system (such as sample or
recovery lengths, densities, pressures or  depths), you’ll need to multiply the data by a conversion
factor:

1. Double-click on the entry that you want to change (e.g., “Report SAMP_LEN”).

2. When the “Place a Text Item in the Current Column” dialog comes up, if there’s a button labeled
Edit... next to the Print what? title then:

a) Click the Edit button.

b) At the top of the following dialog is a list of the data fields that are to be printed (they’ll be
followed by the phrase “(entered or calcd. text)”): for each field that needs to be converted,
click on the field then add the requisite conversion factor at the end of the field name as
it’s listed in the What to print box.  (For example, to convert sample lengths from inches to
centimeters, change the What to print entry to read 7%14C0)2����; to convert depths to

meters, add ����� to the end of the box.)

 Make sure that the It is a number box is checked and type an appropriate number of digits
to the left and right of the decimal point into the Digits left of the decimal and Digits right of

the decimal box and uncheck the It is a measurement in ft. an in. box.

c) Click on the OK button when finished, then OK again to close the previous dialog.

If there isn’t an Edit button next to the Print what? title then:

a) Add the requisite conversion factor to the end of the field name (to convert inches to
centimeters, add ����; to convert depths to meters, add �����, etc.)

b) Click on the Numbers tab.

c) Enter an appropriate number of into the Digits to the left of the decimal point and Digits to

the right of the decimal point fields (� and � for centimeter measurements, � and � for

depth measurements, etc.).

d) Click on the OK button.
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  Converting graphs

Many items being graphed won’t require any type of modifications: Atterberg limit data and
moisture contents, for example, are unitless.  (SPT N-values remain the same whether reported in
blows/foot or blows/30 cm; however, if the marker used to plot the N-values is used in the column title
next to something like Blows/foot you’ll need to follow the procedures below.)

To change a graph item:

1. Double-click on the graph item that you want to change (e.g., “Graph of SHEAR”).

2. Click on the Graph what? tab.

3. At the Graph what? field, tack on any conversion factor necessary to change your data’s units
(e.g., ����� to convert densities in PCF to densities in kg/m3).

4. Click on the Labels tab.

5. Check the Title on the left of the marker and Title on the right of the marker fields for any mention
of units and change as needed.

6. You’ll need to select a new scale for the graph that covers the range of values you can expect
from your data after multiplying by the conversion factor.  As a rough estimate, take the scale’s
current Right-hand value then multiply by your conversion factor.  Next, round the estimate: if
you’re using a semi-log graph, try rounding to the nearest 10, 100 or 1000.  If you’re using a linear
graph, multiply the Right-hand value by your conversion factor then try to pick a number that may
be evenly divided by 1+ the number of labeled vertical grid lines (e.g., if the right-hand value, after
multiplying by a conversion factor, is 90, and there’s 9 labeled vertical grid lines, make the new
right-hand value 100 because 100/(1+9) gives a nice even 10 units per labeled grid line).

7. Click on the OK button.

  Converting everything else (monitoring wells, sampler symbols, etc.)

No conversions are needed: LD4 will automatically convert depths and lengths to their metric
equivalents.
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9. Graphical Symbols

Graphical symbols are pictures that LD4 uses to draw groundwater symbols, stratigraphy
patterns, sampler types, and monitoring well pipes.  Related symbols are stored in symbol libraries:
for example, all stratigraphy patterns are stored in a symbol library called STRATA.  The table below
lists the symbol libraries shipped with the program:

File Used for

SAMPLERS Sampler symbols

STRATA Stratigraphy symbols

PIPES Monitoring well pipes

MISC Groundwater, seepage, caving and
other miscellaneous symbols.

Table 9.1 -- Graphical Symbol Libraries

➾ Symbol libraries are stored on the hard disk in the same subdirectory as LD4, with a .CDT
extension (for example, all of the stratigraphy patterns are stored in a file called
STRATA.CDT).  You can move a symbol library from one computer to another by copying the
appropriate .CDT file.

9.1 Types of Symbols

LD4 symbols fall into three broad categories: pattern symbols, which are used to draw the
stratigraphy columns on boring logs and subsurface profiles, well pipes and top caps, which are used
to draw parts of a monitoring well, and single symbols, which are symbols that can be used by
themselves, such as groundwater and caving symbols, graph markers and sampler symbols.  The
basic requirements for each symbol type are covered in the following sections.
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9.1.1 Pattern Symbols

Pattern symbols (or just patterns) are used individually or in combination to denote stratigraphy
intervals on a boring log or subsurface profile.  (Section 2.9.3 in the User’s Guide provides a good
discussion of how stratigraphy patterns are selected and used.)  The set of stratigraphy patterns
shipped with LD4 are included in the STRATA symbol library.

All patterns fall into two basic types: randomly arranged and evenly spaced.  The difference
between the two types is easily illustrated by drawing a stratigraphy pattern that looks like a square
and plotting the pattern first as a randomly arranged pattern, then as an evenly spaced pattern:

  
Figure 9.1 -- Random and Evenly Spaced Pattern

Both pictures were generated using the same symbol, consisting of a single square:

➾ When the symbol was set up to be randomly arranged, LD4 produced the left-hand picture by
randomly placing the square around the area to be filled then rotating the square in different
directions.

All randomly arranged patterns have a coverage percentage that determines how much of the
area in which the pattern can be drawn will actually be covered by the pattern.  In the
example, the random pattern was produced with a coverage percentage of 50%.

➾ LD4 produced the evenly-spaced picture by drawing the square at the top left edge of the
picture, shifting to the right, drawing the square again,  shifting to the right, etc. until the right
side of the column was encountered.  Next, the program shifted downwards and started the
procedure over again.

The amount that LD4 shifts to the right and downwards between symbols (which, for the
square, is the amount of white space between symbols) is called the horizontal and vertical
symbol spacing.  If there were no space between the symbols, the square pattern would be
drawn like this:



LD4 CUSTOMIZATION GUIDE

207

Figure 9.2 -- Square Pattern Drawn with No Spacing

LD4 simply prints each square directly to the right and bottom of previous squares.

9.1.2 Single Symbols

Single symbols are used to denote sampler types, groundwater and caving depths,  drill rejection,
etc.  Single symbols are never combined like patterns are; they are always drawn by themselves.

➾ Sampler symbols are stored in the SAMPLERS library; most other single symbols are stored
in the MISC library.

➾ When a single symbol is drawn on the subsurface portion of a report, LD4 uses the symbol’s
baseline to determine where the symbol is to be placed vertically in relation to the requested
depth for the symbol.  If the symbol is to be centered vertically at the requested depth (like, for
example, a groundwater symbol, which appears half above and half below the groundwater
depth) the baseline is adjusted so that it is in the center of the symbol.

The following figure shows the design screen for a groundwater symbol: the baseline is the
horizontal line going through the center of the symbol.  When the symbol is printed on the
subsurface portion of a report, the baseline will line up with the groundwater depth.

                 
Figure 9.3 -- Groundwater Symbol and Baseline

Baseline
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In contrast, the drill rejection symbol, which is an upward-pointing arrow drawn at the end of
the boring, has its baseline set at the top of the arrow: This causes the entire symbol to print
below the boring termination depth.

                 
Figure 9.4 -- Drill Rejection Symbol and Baseline

9.1.3 Well Pipes and Top Caps

Well pipes and top caps are special types of single symbols that are stored in a library of their
own: the library must be specifically marked as being for well pipes and top caps, and can store no
other types of symbols.

➾ Well pipes are symbols that LD4 draws inside the backfill of a monitoring well schematic.  The
following figure shows a few of the well pipe symbols that are shipped with LD4:

      
Figure 9.5 -- Well Pipes: BLANKPVC, SLOTDPVC and CASED

When drawing a pipe inside of a well schematic, LD4 takes the chosen pipe symbol and lays
it end over end from the top depth for that pipe installation to the bottom depth.

Baseline



LD4 CUSTOMIZATION GUIDE

209

For cased well sections (sections where the pipe is shown inside a casing) the symbol
designer includes Width of the pipe data entry field that should be filled in with the width of the
interior pipe: this allows LD4 to draw pipes connected to the cased interval at the same width
as the pipe within the cased interval.

For pipe sections that do not include casing, the Width of the pipe field may be left blank or �.

➾ Top caps are symbols that are used at the top of the monitoring well schematic to denote
various methods of capping the well.  Several top cap symbols shipped with the software are
shown in the following figure:

Figure 9.6 -- Top Caps: RECESSED, FLUSH and PROTECT

Top caps may or may not contain a section of pipe (in the figure above, RECESSED and
PROTECT contain pipes).  If the cap does contain a pipe, LD4 needs to know how wide the
pipe is so that any pipes drawn below the top cap can be drawn at the same width as the pipe
in the top cap (i.e., the pipe in the top cap may be fitted to the pipe below the cap). The
symbol design screen for pipes and top caps contains a Width of the pipe data entry field that
should be filled in when drawing top caps that include pipes.
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9.2 Symbol Names and Descriptions

Each symbol has a name associated with it: when adding a symbol to a report form or legend,
you select the symbol by its name.

➾ A pattern symbol’s name may only be one character in length so that you can combine
multiple patterns in the same stratigraphy interval; e.g., ') indicates a combination of the C

pattern and the E pattern.

➾ For historical reasons, all other symbols are limited to names that are less than nine
characters in length.

➾ The comma symbol (‘,’) may not be part of a symbol name.

➾ Upper and lower case names are identical: ;%8)6, [EXIV and [%X)V all refer to the same

symbol.

➾ Symbol names are optional: you may leave the name blank; however, if you do, you will not
be able to use the symbol for any purposes.

➾ No two symbols within the same symbol library may have the same name (although you may
have more than one symbol that was left unnamed).  For example, you may not have two
symbols in the STRATA symbol library called '; you may, however, have a ' symbol in the

STRATA library and a ' symbol in the SAMPLERS library (this is the case with the stock set

of symbol libraries shipped with LD4).

➾ Because LD4’s one-character/eight character maximum name size doesn’t provide much
room for being descriptive, symbols also have descriptions.  Use the symbol description to
describe the general appearance of the symbol.



LD4 CUSTOMIZATION GUIDE

211

9.3 Creating and Modifying Symbols

Caution:  Hard disk failures happen!  If you modify or create a symbol library, be sure to save a copy
of the modified library onto a floppy disk or tape drive.

To modify a symbol:

1. From LD4’s opening screen click on the Symbols tab then double-click on the symbol library that
holds the symbol that you want to modify (see Table 9.1 for help in choosing the correct library).

 or

 Choose Tools > Modify Graphical Symbols...

 or

 Click on the  button at the lower-right of the LD4 data entry screen (see Section 2.5 in the
User’s Guide).

2. Double-click on the symbol in the selection box on the left side of the screen.

To create a new symbol:

1. If you will be adding the symbol to an existing symbol library, follow Steps 1 through 3 above.
Otherwise (if you need to create a new symbol library): from LD4’s opening screen, click on the
Symbols tab then enter a name for the new symbol library that doesn’t match the name of any of
the existing symbol libraries.  (You can also create a new symbol library by selecting File > New
Symbol Library from the Symbol Editor.)

2. If you created a new symbol library in Step 1, make sure to set the Well sections library checkbox
(at the bottom-right of the screen) if the new library will hold well pipes and top caps.

3. Choose Symbol > New.

4. Begin by entering a name and description for the new symbol, following the guidelines given in
Section 9.2.

5. Next, select the type of symbol that you will be drawing (single, evenly spaced pattern or random
pattern) from the box at the bottom left of the editing window (see Section 9.1).

6. Depending upon the type of symbol being created, choose the pipe width (see Section 9.1.3),
horizontal and vertical spacing or coverage percentage (see Section 9.1.1).

7. Draw the symbol.

8. If you’re drawing a single symbol, make sure that the symbol baseline is adjusted so that it is
located where you want the centerline of the symbol to fall (see Section 9.1.2).

9. Refer to Section 9.5  for information on using the new symbol.
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9.4 Drawing a Symbol

The symbol editor is shown below:

Figure 9.7 -- Symbol Editing Screen

Symbols are made up of lines, polygons, circles and splines, which the following sections provide
details on drawing.  Some basic notes:

➾ The symbol grid is initially set up so that one grid step is 1/50th of an inch: for users in the US
this makes it easy to lay out the symbol using the 50th scale on an engineering ruler.

Changing the grid step (by entering a different number into the One grid step is field at the top
of the screen) enlarges or shrinks the size at which the final symbol is drawn.  For example,
changing the grid step for the groundwater symbol from .02 inches to .04 inches doubles the
size of the printed symbol.

Regardless of the grid step, LD4 limits the size of the grid to 50x50 dots.

➾ Normally, every point that you draw (line endpoints, the center of a circle, etc.) is “snapped” to
the nearest grid point.  If you want to be more precise in your drawing, uncheck the Snap box.

➾ You can modify a portion of the symbol (a line, for example) by clicking on it: this causes a
number of “grabhandles” (small squares) to appear on the item.  One grabhandle will be in
red: dragging this handle around shifts the entire item.

➾ Aside from picking between filling polygons in black or white, there is no way to color the
items that make up the symbol.  Single symbols such as groundwater and caving symbols
may have a color assigned to them when you add them to your report form.

Line weights
selection box

Filled, opaque or
transparent

polygon/spline
selection

Symbol baseline
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9.4.1 Basic Drawing Steps

This section lists some tasks that might be needed to modify an existing symbol.  Sections to
follow provide instructions on drawing new symbol elements.

➾ These instructions may be applied to multiple items at once by holding down the Shift key
while you select items for modification.  This can be useful, for example, in deleting multiple
items or for changing the weight of a group of lines.

To modify the weight of the lines used to draw a part of the symbol:

1. Move the mouse cursor over the symbol part to be changed and click on the left mouse button:
“grabhandles” should appear at various positions around the element.

2. Choose the desired weight from the line weight selection box.

 

To delete a part of the symbol:

1. Move the mouse cursor over the symbol part to be changed and click on the left mouse button:
“grabhandles” should appear at various positions around the element.

2. Choose Edit > Delete.

 

To modify the position of a part of the symbol:

1. Move the mouse cursor over the symbol part to be changed and click on the left mouse button:
“grabhandles” should appear at various positions around the element.

2. One grabhandle will be shown in red: click the left mouse button on this handle and, while holding
the button down, move the part to its new position.

 

To change the size or shape of a part of the symbol:

1. Move the mouse cursor over the symbol part to be changed and click on the left mouse button:
“grabhandles” should appear at various positions around the element.

2. Grabhandles around the exterior of the part (these are the handles on either end of a line, the
handles on each vertex of a polygon and at four points around a circle) may be dragged to move
that point on the part: click the left mouse button on the handle and, while holding the button
down, move the handle to its new position.

➾ Note that dragging a grabhandle between two polygon vertices actually creates a new vertex
-- see Section 9.4.3.
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9.4.2 Drawing Lines

Most graphical symbols are just a collection of straight lines, drawn one at a time.  This section
covers how to add a line to a symbol: see Section 9.4.1 for instructions on modifying an existing line.

To draw a line:

1. Begin by clicking on the line drawing button in the toolbar -- it looks like this:  

2. Lines have weights associated with them: LD4 provides eight different weights, along with an
invisible line weight.  Before drawing the line, make sure that the proper line weight is highlighted
in the line weight selection box (see Figure 9.7).

➾ Invisible lines are only useful when drawing evenly spaced pattern symbols: instead of
figuring out an appropriate horizontal and vertical spacing for the symbol, you can draw an
invisible vertical line off to the right of the symbol, spaced at the distance to where the next
symbol should be plotted; similarly, an horizontal invisible horizontal line can be drawn below
the symbol.  Several of the stock STRATA patterns use this technique, including “D”, “M”, “N”
and “[“.

Invisible lines are drawn in red on the symbol editing screen.  They do not appear on
hardcopies.

2. After selecting the line weight, move the mouse cursor to the location of the first point on the line
then click and release the left mouse button.

3. Move the cursor to the location of the second point on the line and again click and release the left
mouse button.

➾ To abort the drawing process, press the right mouse button or the Esc key.
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9.4.3 Drawing Polygons

You can add both “open” and “closed” polygons to a symbol -- the figure below illustrates the
difference between an “open” and “closed” polygon:

      
Figure 9.8 -- Open, Closed and Filled Closed Polygons

Closed polygons can be transparent (like the middle picture), filled (like the picture on the right) or
opaque.  Opaque polygons look identical to the transparent polygon (the middle polygon in the figure
above) except when the symbol is drawn on top of something that already appears on the report: the
transparent polygon allows whatever was underneath the polygon to show through, while the opaque
version doesn’t.

This section covers how to add a polygon to a symbol: see Section 9.4.1 for instructions on
modifying an existing polygon.

To draw a polygon:

1. Begin by clicking on the polygon drawing button in the toolbar -- it looks like this:  .

2. The border of the polygon has a weight: before drawing the polygon, make sure that the proper
weight is highlighted in the line weight selection box (see Figure 9.7).  (The border of a filled
polygon doesn’t show through the fill so you can skip this step if the polygon that you’ll be drawing
will be filled.)

3. If you will be drawing a closed polygon, click either the filled, opaque or transparent button.
(Again, refer to Figure 9.7.)

4. Move the cursor to one of the points to appear on the new polygon then click and release the left
mouse button.

5. Move the cursor to the next point on the polygon and click and release the left mouse button
again.  Do this step for the rest of the points on the polygon.

6. If you are drawing a closed polygon you can either connect the last point back to the first point
then choose Done from the small popup menu that appears.  Alternatively, draw the last point
then select Close to have the program close the polygon for you.
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To change a polygon to filled, opaque or transparent, or to change the weight of the line used to outline
the polygon:

1. Click the left mouse button with the cursor anywhere within the interior of the polygon:
“grabhandles” should appear at each vertex of the polygon, halfway between each vertex and in
the polygon’s center.

2. Click the new line weight or on either the filled, opaque or transparent buttons in the toolbar
shown in Figure 9.7.

 

Once you’ve drawn a polygon you may find that in order to get the shape exactly right, the new
polygon needs another vertex.

To add a new vertex to a polygon:

1. Click the left mouse button with the cursor anywhere within the interior of the polygon:
“grabhandles” should appear at each vertex of the polygon, halfway between each vertex and in
the polygon’s center.

2. Click the left mouse button on the grabhandle that appears between the two vertices closest to
where you want to add the new vertex.  While holding the mouse button down, drag the cursor to
the location of the new vertex.

➾ If a grabhandle doesn’t appear between the two closest vertices, then the gap between the
vertices is too small for LD4 to fit in the middle grabhandle.  The only way to correct this is to
temporarily  move the two vertices far enough apart for the central grabhandle to appear.
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9.4.4 Drawing Circles

Circles are similar to polygons: they may be filled, opaque or transparent.

    
Figure 9.9 -- Filled, Opaque and Transparent Circles

This section covers how to add a circle to a symbol: see Section 9.4.1 for instructions on
modifying an existing circle.

To draw a circle:

1. Begin by clicking on the circle drawing button in the toolbar -- it looks like this:  .

2. The border of the circle has a weight: before drawing the circle, make sure that the proper weight
is highlighted in the line weight selection box (see Figure 9.7).  (The border of a filled circle
doesn’t show through the fill so you can skip this step if the circle that you’ll be drawing will be
filled.)

3. Click either the filled, opaque or transparent button.  (Again, refer to Figure 9.7.)

4. Move the cursor to where the center of the circle is to be located then click and release the left
mouse button.

5. Move the cursor out to a point on the circumference of the circle and click and release the left
mouse button again.  If you have the snap function on LD4 will snap the circumference to the
nearest grid point so you may not get quite the size circle that you were looking for.  You can
avoid this problem by unchecking the Snap box after you’ve drawn the circle’s central point and
before drawing the circumference point.
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9.4.5 Drawing Splines

Splines are similar to polygons, except that instead of using straight lines to connect the vertices,
splines use curves.  Here is the same set of points drawn first as a polygon then as a spline:

   
Figure 9.10 -- A Polygon and Spline Drawn Using the Same Set of Points

Like polygons, splines don’t have to be closed:

Figure 9.11 -- Splines

To draw a spline:

1. Begin by clicking on the spline drawing button in the toolbar -- it looks like this:  .

2. Follow steps 2 onward as given in Section 9.4.3.
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9.4.6 Converting a Sequence of Lines to a Spline

LOGDRAFT III (our MS-DOS based drilling log program) didn’t support symbols with splines, so
curves had to be approximated as a set of connected lines -- the resulting figure usually had a slightly
blocky shape.  LOGDRAFT III users upgrading to LD4 may want to smooth out some of their symbols
by converting curves drawn as a sequence of connected straight lines into splines.

To convert a sequence of connected lines into a spline:

1. While holding the Shift key down, move your mouse cursor over each of the lines comprising the
curve and click the left mouse button: “grabhandles” should appear around the lines as you click
on them.  (If you accidentally click on a line that should not be included, click on it again.)

 It’s important that you hold the Shift key down while clicking, otherwise you will only be able to
select a single line.

2. Choose Tools > Make Spline from Selection.

3. LD4 will discard any lines that you choose which could not be included in the new curve (because
they weren’t connected to the lines that were included).  If you lose some lines, or if the curve
doesn’t look right, use Edit > Undo to go back, then try the process again.  Make sure that you
only select a sequence of lines that are connected at their endpoints to one another.
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9.5 After You’ve Created a New Symbol

If you’ve created a new stratigraphy, sampler, backfill or pipe symbol you’ll need to perform one
more step before you can actually use the new symbol on a report.  Menus of stratigraphy patterns,
samplers and well construction sections presented during data entry are built from legend files: to
include a new graphical symbol on one of these menus, you’ll need to add the symbol to one or more
legend files.

To add a  new symbol to a legend file:

1. Use LD4 to open up a project (you can’t edit a legend until a project has been opened).

2. Once the project is open, if there’s a Legend tab in the lower left of the screen, click on it.
Otherwise, choose Legend > Edit the Default Legend.

 Note that if project had a Legend tab then you will have to go through these same steps for each
additional project which reqiures the new symbol.

 From the left-hand panel, click on the name of symbol library where you added the new symbol,
or,  if you created a new symbol library, choose Legend > Add a New Legend Table and select
your new symbol library from the subsequent dialog.

3. If the symbol was not a well pipe: find a blank data entry card (there’s always one at the bottom
of the list). On the blank card, click on the button next to Symbols.

 You should be able to locate your new symbol in the list: When you do, click on it and then on the
OK button.

 In the Description field, enter a description for the symbol: the description will appear on legend
printouts if you used the symbol in a report.

 If the symbol was a well pipe: You’ll want to create at least one new well section that uses the
pipe.  Find a blank data entry card then enter an appropriate shorthand name into the Well ID

field.  Choose a backfill for the new section, then click on the button next to the Pipe prompt and
select the new pipe.  Finally, enter a description for the well section.  (You can find a discussion of
these prompts in Section 4.2.3 in the User’s Guide.)
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9.6 Step by Step Instructions for Creating a New Sampler Symbol

This section presents instructions for creating the following new sampler symbol:

Figure 9.12 -- New Sampler Symbol

1. Start up LD4 then click on the Symbols tab.

2. We need to figure out which symbol library will be used to hold the new symbol: since the new
symbol will be used to indicate a sampler type, double-click on the “SAMPLERS” selection in the
left-hand panel.

3. From the following screen choose Symbol > New.

4. Next, we need to figure out a name for the new symbol.   If you scroll through the symbol box on
the left side of the screen you’ll notice that all of predefined symbols have one character names.
LD4 doesn’t require this (except for stratigraphy symbols); because the data entry process
involves choosing the type of each sample taken during a boring, the shorter names speed data
entry.

 Since we want to stick with the one character sampler name convention, we need to choose a
character that isn’t already used by a sampler.  No symbol in the SAMPLERS library is named “*”,
so type  into the Name field then press Tab.

 Next comes a description for the new symbol: when we set up the symbol’s legend entry, the
description will help us to pick the symbol out of the list of symbols stored in the SAMPLERS
library.  Type 9T[EVH�JEGMRK�JMPPIH�XVMERKPI�into the Description field.

5. LD4 needs to know what the symbol will be used for: will it be a random or evenly spaced
stratigraphy pattern or a single symbol?  The program should have guessed correctly that the new
symbol will be a single symbol; however, if the box underneath the Name field doesn’t say “Single
symbol”, change it.

6. Next we start drawing the symbol.  This new symbol is similar to the symbol called “S” that is
shipped with the software so to start with we’ll copy “S” to the clipboard then past it onto our new
symbol.
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 Locate “S” in the list of symbols shown on the left side of the screen (it will be a simple opaque
rectangle) and double-click on it.

7. Select Edit > Select All then Edit > Copy.  Now we have a copy of “S” in the clipboard.

8. One of the tabs below the symbol editing area should be “*”, the symbol we’re designing.  Click on
that tab.

9. You should now have the blank symbol editing window for our “*” sampler symbol showing.
Select Edit > Paste  to copy the “S” symbol onto the new symbol.

10. Now that we have the rectangle, what’s left is to draw the triangle.  Begin by clicking on the 
button so that the triangle is filled.

11. Next, click on the polygon button: 

12. Make sure that the Snap setting is checked.

13. Move the mouse cursor to the lower left corner of the box then click and release the left mouse
button.

14. Move the cursor to halfway between the left and right corners of the top of the box (this will be the
top point of the triangle) then again click and release the left mouse button.

15. Move the cursor to the bottom right of the box and click and release the left mouse button.

16. From the small popup menu that appeared when you started to draw the polygon, choose Close:
this draws a line from the last point we drew back to the first point we drew, closing the triangle.

17. Move the mouse cursor to the symbol baseline arrow (this is the small arrow on the left side of the
grid).  Click the left mouse button and, while holding the button down, drag the baseline so that it
lines up with the top of the sampler symbol.  This makes sure that the entire sampler symbol
prints below the sampling depth.

18. Select File > Save and Exit

19. Now that the symbol has been drawn it must be added to LD4’s legend file before it can be used.
From LD4’s opening screen, open any project.

20. Once the project is open, if there’s a Legend tab in the lower left of the screen, click on it.
Otherwise, choose Legend > Edit the Default Legend.

21. We added the new symbol to the SAMPLERS symbol library so click on SAMPLERS in the left-
hand panel.

22. Find a blank data entry card (there’s always one at the bottom of the list): on the blank card, click
on the button next to Symbols.

23. You should be able to locate the new “*” symbol in the list: when you do, click on it and then on
the OK button.

24. In the Description field, type &EK�WEQTPI.
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Appendix A -- LD4 Math

LD4 reports and summaries can use mathematical equations in a variety of situations.  Equations
can be as simple as, for example, converting sampling lengths from inches to feet, or as complex as
one to automatically adjust SPT N-values depending upon whether they were taken above or below
the waterline.  This appendix discusses the general form of a LD4 equation and covers the many
mathematical functions available through the software.

  User-Entered Data

A printed report can include equations that use data entered into currently open project file.
Recall from Section 1.1 that each data entry field has a name assigned to it: this name is what you
use if you want to refer to the contents of the data entry field in an equation.

➾ If your equation is being used on the table section of a report (this is where the subsurface
information is printed on a boring log or profile) it will have multiple values: for each data entry
card filled in on the subsurface portion of the data entry screen, LD4 plugs the data from that
card into your equation.  For example, if you entered three rows on your data entry screen,
with the ()48, field being � on the first row, ��� on the second row and � on the third row,

the equation ()48,�� in a column titled “Depth in Inches” on your boring log (the “*” is the

multiplication operator) will result in three values being printed: � will appear at the top of the

column, �� will appear at 1.5 feet and �� will appear at 5 feet.

Equations used on a report’s table section can also combine information entered into data
entry cards with information entered into the source data entry section (this is the section at
the top of the data entry screen used for typing in information about the boring, such as the
boring number, elevation, etc.).  A column titled “STRATUM ELEVATION” that uses the
equation )0):%8-32�()48, to report the elevations of the various layers encountered

during drilling combines the “Elevation” source data entry field with each “Depth” entry in the
subsurface data entry section.

➾ If your equation tries to either a) reference a non-existent data entry field or b) reference a
data entry field the user didn’t fill in, LD4 will not report any result.  This means that, for
example, with the “STRATUM ELEVATION” column discussed in the previous point if you
don’t enter an elevation that column will remain blank.
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Similarly, if you try to include the contents of a data entry field in an equation and the user
enters something besides a number, LD4 won’t report a result: referring to our “STRATUM
ELEVATION” example, if the user enters n/a as the boring’s elevation, the “STRATUM
ELEVATION” column will remain blank because the ELEVATION-DEPTH equation won’t
report any results.

  Mathematical Operators

Equations can add, subtract, multiply and divide with the �, �,  (this is shift-8 on your keyboard)

and � mathematical operators.  Following are some examples:

&03;7��&03;7�

)0):%8-32�()48,

7%14C0)2���

()48,�����

Table 9.2 -- Example Equations

Multiplication is performed first, then division, addition and subtraction so �������� is 1.

  Comparisons

The   (less than),  ! (less than or equal), " (greater than), "! (greater than or equal), ! (equal)

and  " (not equal) comparisons return numeric values: if the comparison is true, LD4 reports a 1; if

the comparison is false, LD4 reports a 0.  This is sometimes useful for applying part of an equation
only if some condition is met. For example, the equation below adjusts SPT N-values by 10 percent if
they were taken below the groundwater level:

2:%09)����2:%09)�()48,"!;()48,��

If ()48, (the depth at which the N-value was taken) was greater than or equal to ;()48, (the

groundwater level) then the comparison �()48,"!;()48,��is “1” and the equation is equivalent to
2:%09)����2:%09)�

If ()48, is less than the groundwater level then the comparison is “0” and the equation is equivalent

to
2:%09)����2:%09)�

i.e., just 2:%09).

➾ Another use for a comparison function is the equation

����7%14C0)2"!����7%14C0)2�����7%14C0)2 ���

which can be used to vertically center the first blow count value (assuming that sampling
lengths are given in centimeters).
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➾ You can also compare items besides numbers: to compare a data entry field that isn’t a
number, place the item you’re comparing it to inside of double-quotes.  For example,

(6-00C6-+!l'1)���z

returns 1 if the drill rig used for the boring was a CME-45.  (If you were to forget the quotes,
LD4 would try to compare (6-00C6-+ to the value of '1)���; that is, the data entry field

'1) minus the number 45.)  Similarly,
(6-00C6-+ "l'1)���z

returns 1 if the drill rig was not a CME-45.

Non-numeric comparisons are handy when using the printout filters discussed in Section
3.2.1 of the User’s Guide.

Note:  Non-numeric comparisons can only be made using the equals (=)and not-equals (<>)
comparisons -- comparisons such as DRILL_RIG<“CME-45” or DRILL_RIG>=“CME-45” do not return
values.

➾ Date comparisons  are also handy for printout filters: to compare two dates, place (%8)��

around each:
(%8)�&(%8)� (%8)�l��������z�

returns 1 if the boring was started (&(%8)) before “01/01/99”.  If you’ll be using an actual date

such as 01/01/99 in the (%8) function, place the date in quotes -- data entry fields such as

&(%8) should not be placed in quotes.

2SXI�  LD4 interprets dates according to the date setting in the “International” (Windows 3.1) or
“Regional Settings” (Windows95, 98 & NT) section of the Windows Control Panel.  This setting
determines whether LD4 treats “03/01/99” as March 1, 1999 or January 3, 1999.

  Transcendental Functions

Equations can also make use of a variety of built-in transcendental functions.

➾ 7-2, '37 and 8%2 (tangent) all accept angles in degrees; %82 (arc-tangent) returns angles in

degrees.  8%2 will not report a result for 90 or 270 degrees.  Although these functions are of

limited use for geotechnical reports, one commonly used equation is
()48,'37�(6-00-2+C%2+0)�

which converts a drilling interval for an angled boring into a true depth below surface.

➾ 756 calculates square-roots: 756��� returns 2.  756���� returns nothing.

➾ )<4 calculates ex: )<4��� returns 1.  03+ calculates ln(x) -- if “x” is less than or equal to 0

LD4 will not report a result.
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  Other Math Functions

➾ %&7 returns the absolute value of something: %&7���� and %&7��� are both 1.

➾ -28 basically removes the fractional part of a number: -28�������� is 3.  For negative

numbers, -28 is the largest whole number not greater than the argument: -28��������� is

-4.

  RND()

62(�%�&� rounds the number % to & decimal places.  62(��������������� is 3.142;

62(������� is 4.

  INZ() and ISZ()

-2>�� and -7>�� are a lot like the comparison functions discussed earlier:

-2>�VIXYVRZEP�IUYEXMSR� returns the value VIXYVRZEP if IUYEXMSR is not equal to zero -- this

is similar to VIXYVRZEP�IUYEXMSR "��.  -7>�VIXYVRZEP�IUYEXMSR� returns the value

VIXYVRZEP if IUYEXMSR is zero, which is similar to VIXYVRZEP�IUYEXMSR!��.

 However, there’s one big difference: the value of VIXYVRZEP�JMIPH "�� is 0 at depths

where JMIPH was not entered, while -2>�VIXYVRZEP�JMIPH� does not return anything at those

depths.  This distinction is important in cases where you don’t want to report the results of a
calculation unless all of the fields used in the equation were actually entered.  As an example, the
“Print this item at depths entered into another data entry field” option of the “Place a Text Item in the
Current Column” dialog (Section 4.6.3) can be used to only print an item on the report’s table if the
results of an equation is true:

-2>�()48,�7%14C0)2"!���

for instance, will print the item at its appropriate depth only where the sampling length was greater
than or equal to 15 and will not print the item if the sampling length was less than 15, while

()48,�7%14C0)2"!���

will print the item at a depth of 0 when the sampling length was less than 15.  This is because when
the program evaluates -2>�()48,�7%14C0)2"!��� at depths where the sampling length was less

than 15, it doesn’t get any kind of result back so it doesn’t try to print anything, while when it evaluates
()48,�7%14C0)2"!��� at depths where the sampling length was less than 15 it gets a result of 0

and so prints the item at a depth of 0.
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  IFE()

-*)�VIXYVRZEP�JMIPH� returns result VIXYVRZEP only if the data entry field named JMIPH

was filled in.   One use for this function in the old MS-DOS LOGDRAFT III program was in the “Print
this item at depths entered into another data entry field” option discussed for -2>��:

-*)���JMIPH�!�

can be used to only print the item if JMIPH was not entered.

  NXT() and LST()

2<8�JMIPH�VIXYVRZEP� provides the value of VIXYVRZEP on the first row after the current

where a value was entered into JMIPH.   This function is useful for vertically centering items on a

graphic report: for instance, to vertically center a USCS classification between stratum changes
(signified by the rows where the user enters something into the USCS field) on a graphic log, use

�()48,���2<8�97'7�()48,����

as the depth at which the classification is to be printed.  The expression above averages the depth at
which the USCS value was entered and the next lower depth where a USCS value was entered.

➾ 2<8 won’t return a result for data entry rows where JMIPH wasn’t entered.

➾ If the expression 2<8�JMIPH�VIXYVRZEP) is evaluated and there aren’t more values

entered for JMIPH below the current row then the function returns the largest possible value

for VIXYVRZEP: for example, our example equation would center the last USCS entry

between the depth where the last stratum started and the boring termination depth.

The following example may help clarify things:

Depth USCS End of strata depth: NXT(USCS,DEPTH)
� '0 �

� �

� �

� 71 �

� 10 �� (returns the boring termination depth

because no more USCS values were entered)

� ��

��

(boring
termination
depth)

��

Table 9.3 -- Example NXT() Usage
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078�JMIPH�VIXYVRZEP� provides the value of VIXYVRZEP on the first card above the current

where the data entry field named JMIPH was filled in, as is illustrated in the following table:

Depth USCS Previous strata depth: LST(USCS,DEPTH)
� '0 (no result because no previous strata)
� �

� �

� 71 �

� 10 �

� �

�� �

Table 9.4 -- Example LST() Usage

  LNO()

023�� returns the number of the data entry card currently being printed.  Note that although

nothing goes inside them you still need to include the parenthesis: use 023�� instead of 023.

  The MINOR_CONVERT Field

When you’re printing sampling lengths you may want to report them in terms of feet or meters: if
you’re entering your sampling lengths in inches or centimeters you’ll need to convert them.   To report
sampling lengths in feet when you’ve entered them in inches, you’ll need to print SAMP_LEN/12; for
sampling lengths in meters when you’ve entered them in centimeters, you’ll need to print
SAMP_LEN/100.   Either formula ties you to one measurement system: if you have been entering
your project data in US units and you change to SI units you’ll need to edit your report form and
change the SAMP_LEN/12 to SAMP_LEN/100.  To help with this, LD4 provides the
MINOR_CONVERT field.

When a report is printed, LD4 automatically sets MINOR_CONVERT to be either 12 or 100,
depending upon whether your project uses US or SI units (see Section 2.2.1 of the User’s Guide).
You can revise your report form to take advantage of this by printing SAMP_LEN/MINOR_CONVERT
instead of SAMP_LEN/12 or SAMP_LEN/100 -- you’ll get correct results for both US and SI projects
because MINOR_CONVERT becomes 12 when you’re printing a US-unit project and 100 when you’re
printing a SI-unit project.
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Appendix B -- LD4 Calculated Fields

When printing a report, LD4 makes a number of fields available that may be printed or used in
equations without requiring the user to enter any data. The table below summarizes the names
and uses for these fields -- note that not all fields are available when printing every type of report:
for example, the SCALE field, which stores the vertical scale used for printing the subsurface
section of a drilling log, doesn’t have a value when printing a data summary since summaries are
not vertically scaled.

Field Name Description

RESUMED? Set to -1 if the page currently being plotted is not the first page of the
report; in other words, is 0 when the first page of each boring log is
plotted.  Can be used to conditionally print some text only on
subsequent pages of a report (e.g., “BORING CONTINUED”).

CONTINUE? Set to -1 if the page being plotted is not the last page of the boring
log being plotted.  Can be used to print “BORING CONTINUES”
messages -- see Section 3.12.

MINOR_CONVERT Initialized to “12” when plotting projects taken in feet/inches and
“100” when plotting SI projects -- used when converting sampling
lengths from inches to feet and from centimeters to meters.

DT_TODAY Holds the current date, in “short” format (e.g., 10.02.00), as
configured in the Windows “Regional Settings” Control Panel
application.

LONG_DATE Holds the current date, in “long” format (e.g., October 2, 2000) as
configured in the Windows “Regional Settings” Control Panel
application.

CURRENT_TIME12 Holds the current time in am/pm format

CURRENT_TIME Holds the current time, in 24 or 12 hour format depending upon the
“Regional Settings” application.

COMPANY Contains the name of the organization which licensed the package.
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CNAME Contains the name of a logo file appropriate for the licensing
organization.

PAGE Holds a count of the number of pages plotted since the first page of
the current boring log report.  Resets to 1 at the start of printing for
the next drilling log report.

PAGE_L Holds a count of the total number of pages that will need to be
plotted for the current drilling log.

PAGE_T Similar to PAGE but is initialized based upon the Page field at the
bottom of the drilling log data entry screen (see Figure 2.5.1 in the
User’s Guide.).

TPAGE Similar to PAGE_L but starts with the value entered into the Page

field at the bottom of the drilling log data entry screen; e.g., if this

value is � and there are 3 pages to print, TPAGE will be 8.

CPAGE Backwards compatibility.  Holds the same value as TPAGE.

FIGURE For drilling logs, test pits and monitoring wells, holds the value
entered into the Page field at the bottom of the drilling log data entry
screen (see Figure 2.5.1 in the User’s Guide.).  For profiles, holds
the value entered into the Starting Figure number box on the Report

Form tab of the Report Settings dialog.

TOPDEPTH Changes for each page printed -- holds the depth that will be plotted
at the top of the current page.

BOTTOMDEPTH Holds the depth that will be plotted at the bottom of the current page.

BORINGEND Holds the termination depth for the boring being plotted.

SCALE Holds the user’s vertical scale selection in either feet per inch or
meters per centimeter.

UNIT_LENGTH Holds 1 when plotting projects entered in feet/inches; 2/2.54 when
plotting projects entered in meters/cms.  Is used to determine a nice
distance between successive horizontal grid lines on a graph.

ABS_SCALE Holds the vertical scale in terms of feet per inches (even when the
project being plotted was entered in meters).  Used when LD4
expects a measurement in inches and the user will be entering the
measurement in feet or meters of drilling.

HSCALE Holds the horizontal scale chosen for profile plotting.



# symbol ......................................................................................... 109

 (not in table) message .................................................................... 176

+, -, *, / symbols ............................................................................. 222

.BMP............................................................................. See picture file

.CDT ............................................................................................... 203

.DXF ........................................................................................... 23, 38

.PCX ............................................................................. See picture file

<, > and = symbols ......................................................................... 222

@ symbol................................................................................ 108, 182

] symbol .......................................................................................... 109

^ symbol.................................................................... 67, 103, 107, 166

A

Abandon Changes menu ................................................................... 41

above

vertical text location .......................................................... 118, 141

ABS().............................................................................................. 224

abs. centered

vertical text location .......................................................... 118, 119

ABS_SCALE.................................................................................. 228

absolute placement facility ....................................................... 181–84

used with graphs ........................................................................ 158

Add a New Legend Table menu ............................................... 19, 218

Add Column Caption menu .................................................... 104, 107

Add Depth and/or Elevation Scale menu ........................................ 137

Add Graph of Data vs. Depth menu................................ 154, 169, 171

Add Graphical Symbols menu ........................................................ 175

Add Horizontal Lines menu.................................... 145, 147, 151, 152

Add Monitoring Well Schematic menu .......................................... 179

Add Symbolic Representation of Sampler Types menu ................. 134

Add Symbolic Representation of Soil/Rock Layers menu ............. 132

Add User Entered Data, Equations, etc. menu ......................................

........................................................... 113, 120, 126, 128, 188, 197

addition ........................................................................................... 222

Additional space to shift the graph titles and scale upwards prompt 158

Adobe Type Manager ....................................................................... 36

Align prompt................................................................................... 105

Also print at the bottom-of-boring depth checkbox ........................ 125

angle ....................................................................................... 106, 114

Arial ............................................................................................ 36, 37

Atterberg limits ....................................................... 113, 123, 159, 194

automatically calculating PI ......................................................... 16

field widths and............................................................................ 17

graphing ..................................................................... 154, 156, 166

AutoCAD...............................................................................See .DXF

Auto-select the number of minor scale ticks per major tick checkbox

................................................................................................... 138

AVANTEGARDE ............................................................................ 37

B

Bar height in ft. or m. prompt ......................................................... 165

bargraph ............................................................................ 159, 163–65

baseline ........................................................................... 205, 209, 220

BDATE ...........................................................................................223

BLANKPVC...................................................................................206

blow count ........................................................16, 120, 121, 122, 200

BLOWS1...........................................................................................16

BLOWS2...........................................................................................16

BLOWS3...........................................................................................16

BMP..............................................................................See picture file

bold .................................................................................See font: bold

border ..............................................................................................184

including company name in .........................................................45

of report table columns ..........................................................101–2

placing items outside..................................................................181

Border tab .........................................................................................45

BORING ...........................................................................22, 182, 188

boring completion depth .................................................................228

Boring Continues message ..............................................80, 82, 86, 88

boring log..........................................................................................24

boring number ...................................................................................22

on profiles ..................................................................................188

Boring Terminated message....................................................124, 126

boring termination.....................63, 125, 141, 143, 147, 152, 206, 225

BORINGEND ...........................................63, 124, 125, 126, 152, 228

both, labels above scale type ...........................................................137

BOTTOMDEPTH...........................................................................228

Box title and data checkbox ..............................................................65

bracket.............................................................................154, 159, 166

Bracket line type prompt .................................................................166

C

calculated .......................................................................See dictionary

Can't find button ...............................................................................54

caption.............................................................................................103

caret symbol .....................................................................See ^ symbol

CASED ...........................................................................................206

casing ................................................................................................19

caving..............................................................................152, 173, 205

converting from feet to meters ...................................................198

CDEPTH.........................................................................................198

centered

vertical text location ...................................................................149

centimeters ...................................................................See dimensions

CENTURY........................................................................................37

CGTIMES.........................................................................................37

Change How This Form Looks menu ...............................................42

Check here if the interval is entered in inches or centimeters checkbox

...................................................................................................148

checkbox .....................................................................................92–93

Choose labels for each labeled vertical grid line prompt ........157, 167

circle ...............................................................................................215

Close menu (drawing polygons) .....................................213, 214, 220

closed ......................................................................................213, 216

CNAME..................................................................................182, 228

color ..............................................................................38, 44, 59, 185



and picture files............................................................................ 71

changing in report heading or footing .......................................... 70

graphical symbols and ............................................................... 210

Column title prompt ........................................................................ 192

Columns spanned prompt ............................................................... 107

Combine with Another Form menu ................................................ 186

COMPANY .................................................................................... 227

company name .................................................................................. 45

comparison

of dates....................................................................................... 223

of numeric data .......................................................................... 222

of text ......................................................................................... 223

CONDENSED .................................................................................. 37

connecting line ................................................................................ 161

consolidation test ............................................................................ 123

continue symbol ................................................................ 51, 132, 179

Continue symbol at the top and bottom of multi-page wells checkbox

................................................................................................... 179

CONTINUE? ...................................................................... 86, 88, 227

Control field prompt ....................................................................... 148

Copy Table Object menu ................................................................ 128

coring ........................................................................... See rock coring

COS().............................................................................................. 223

Courier New................................................................................ 36, 37

coverage percentage........................................................................ 204

CPAGE ........................................................................................... 228

Create From Scratch menu................................................................ 42

CURRENT_TIME .......................................................................... 227

D

data

on report heading or footing ........................................................ 69

on report’s heading or footing ................................................ 62–63

printed on a report's table ..................................................... 113–30

printing anywhere on a report .................................................... 182

data entry field ........................................................................See field

data entry form

associated with a report form ........................................... 43, 52–54

creating or modifying..................................................................... 5

defined ....................................................................................... 3–4

Data Entry Form menu ................................................................... 197

Data entry picks solid or... .............................................................. 146

data table........................................................................................... 49

date ................................................................................................... 63

comparing .................................................................................. 223

DATE() ........................................................................................... 223

DEFAULT ........................................................................................ 37

Default font for column titles.......................................................... 106

degree symbol .............................................................See type symbol

Delete button..................................................................................... 69

Delete Row menu ............................................................................. 61

DEPTH ....................................... 22, 119, 124, 125, 136–40, 148, 224

Depth scale caption prompt .............................................................. 48

Depth, with no labels selection .......................................................138

Depths specified by prompt ............................................................189

DESCRIPTION.........................................15, 141, 146, 147, 191, 201

printing just the first sentence of ..................................................85

Description column title prompt .......................................................74

DIAMONDP...................................................................................163

dictionary ....................................................................................52, 62

DIDCONS.......................................................................................123

DIDHYD.........................................................................................123

DIDMECH......................................................................................123

DIDSHEAR ....................................................................................123

Digits to the left of the decimal point prompt .................................121

Digits to the left of the decimal prompt ....................................85, 201

dimensions ........................................................................................38

DISCONTINUITY..........................................................................161

discrete marker..........................................................159, 160–61, 169

Distance (in ft. or m.) to offset the graph item below the item’s

starting depth prompt .........................................................160, 166

division ...........................................................................................222

DLINE.............................................................................................183

Do not move to accommodate other items in the column checkbox 120

double lines ..........................................................See line:double lines

Draw a line at a single depth ...........................................................152

Draw a line at every depth where a given data entry field is filled in

...................................................................................................145

Draw a line every ¨x¨scaled depth units ..........................................151

Draw a line every ¨x¨vertical inches-cms. .......................................151

Draw a pair of lines showing sampling intervals ............................148

drill rejection...........................................................................131, 132

drill rejection symbol ..............................................................205, 206

DRILL_ANGLE ...............................................................................92

DRILL_RIG....................................................................................223

drilling angle ...................................................................................223

DT_TODAY ...................................................................................227

DXF .......................................................................................See .DXF

E

east ..............................................................................................10, 22

ELEVATION....................22, 84, 86, 89, 108, 136 –40, 188, 198, 199

converting from feet to meters .............................................84, 198

Elevation scale caption prompt .........................................................48

Elevation, with no labels selection .................................................138

end

vertical text location ...........................................................118, 149

Entered/Calcd. button ...........................................84, 87, 89, 122, 188

equation.........................................................................52, 82, 84, 227

functions used in ................................................................195–226

included in a column title ...........................................................108

reporting in table ........................................................................113

setting up a data entry field to use ...............................................16

used to decide what to print ...................................86, 88, 125, 149

used with checkboxes ............................................................92–93

used with graphs ........................................................................165



Erase the area underneath the item checkbox ................................. 114

evenly spaced.................................................................................. 204

EXP() .............................................................................................. 223

F

FCIRCLE................................................................................ 163, 172

feet ..........................................................................................See units

field

defined ........................................................................................... 4

in the project/source data form designer ................................ 7, 8, 9

name..................................................................................... 4–5, 14

settings in the tabulated data editor ....................................... 14–17

type .............................................................................. 5, 14–16, 20

width .................................................................................. 5, 16, 18

Field used to select the marker type prompt ........................... 162, 172

Field width prompt ..................................................................... 16, 18

FIGURE............................................................................ 94, 182, 228

figure number................................................................ 63, 84, 94, 182

Fill type prompt .............................................................................. 164

filled........................................................................ 213, 214, 215, 220

filled bargraph style ........................................................................ 164

filter ................................................................................................ 223

Find menu ....................................................................................... 198

first page ........................................................................................... 55

First Page Absolute Placement ....................................................... 181

First Page Margins ............................................................................ 50

fixed space font ....................................................See font: fixed space

Fixed text button ........................................... 83, 87, 88, 122, 123, 126

FLUSH............................................................................................ 207

font.................................................................................. 36–38, 44, 64

bold .............................................................................................. 37

changing in report heading or footing .................................... 69, 70

default title font...................................................................... 57, 58

fixed space ................................................................................... 37

italic ............................................................................................. 37

on report heading/footing ............................................................ 46

on report tables and captions ....................................................... 47

pitch ............................................................................................. 37

point size ...................................................................................... 37

proportionally spaced................................................................... 37

footing................................... 46, 50, 56, 170, 184, 186, 193, 194, 198

definition................................................................................ 32–34

editing .................................................................................... 55–96

See also report heading and footing

For each symbol, enter the symbol ID, followed by a “,” and the

symbol name prompt ......................................................... 162, 172

form settings

for data entry forms...................................................... 4, 11, 21–22

for profiles.............................................................. 47–49, 188, 189

for report forms ........................................................ 41, 43–49, 185

for summaries............................................................................... 49

Head/Footing tab ............................................................. 46, 57, 64

form size ........................................................................................... 44

Formatted button .............................................................121, 126, 188

FSQUARE ..............................................................................163, 172

FTRANGLE............................................................................163, 172

FWATER ........................................................................................176

G

GARMOND......................................................................................37

GOTHIC ...........................................................................................37

grain size data .................................................................................123

field widths and ............................................................................17

graph .........................................................................153–72, 200, 202

column title for...........................................................................155

horizontal scale labels ................................................................167

used on multi-source graph reports ......................................27, 191

Graph data as prompt ......................................................................159

graph key ........................................................................................193

Graph what? prompt ...............................................................160, 163

graphical symbol

creating and modifying ..............................................................209

described ....................................................................................203

drawing ................................................................................210–17

on report heading or footing ..................................................78–79

on report table ......................................................................173–76

placing anywhere on the report ..................................................182

greek letters.................................................................See type symbol

grid..................................................................................................210

groundwater ..............................................92, 124, 152, 203, 205, 222

converting from feet to meters ...................................................198

groundwater symbol........................................40, 69, 70, 78, 173, 182

H

hand penetrometer............................................................See shear test

hatched bargraph style ....................................................................164

Head/Footing ...............................See form settings: Head/Footing tab

heading................................................46, 56, 184, 186, 193, 194, 198

definition ................................................................................32–34

editing ....................................................................................55–96

See also report heading and footing

heading and footing .............................See report heading and footing

Heading/Table prompt ......................................................................50

horizontal scale

on graphs....................................................................153, 157, 167

on profiles ....................................................................47, 189, 228

Horizontal scale location prompt ..............................................47, 189

Horizontal strata column offset prompt ............................................49

horizontal symbol spacing ......................................................204, 209

HPSTICK..........................................................................................37

HSCALE.........................................................................................228

I

If so, select the field that will used to specify if the markers are

connected prompt .......................................................................161

IFE()..................................................................................92, 149, 225



IFE() function ................................................................................. 147

inches ........................................................................... See dimensions

Include company name in bottom center of border prompt .............. 45

Include the option to show a “drill refusal” symbol at the end of the

boring? checkbox ....................................................................... 132

Indicate during data entry that successive markers will be connected

checkbox .................................................................................... 161

Inkjet ................................................................................................. 50

Insert Row menu............................................................................... 61

INT() ............................................................................................... 224

IntelliCAD .............................................................................See .DXF

invisible line weight........................................................................ 212

INZ()....................................................................................... 125, 224

ISZ()................................................................................................ 224

It is a measurement in ft. and in. checkbox .............................. 85, 201

It is a number checkbox .................................................................. 201

italic ................................................................................See font:italic

J

justification ........................................................................... 40, 65, 79

Justified setting ............................................................................... 106

L

lab. testing modules ........................................................................ 123

LAB_SAMPLE............................................................................... 128

labeled vertical grid lines prompt ................................................... 156

landscape ......................................................................See orientation

left-hand value prompt .................................................................... 156

legend ............................................................................................. 176

adding to a report form ................................................................ 74

notes....................................................................................... 75, 77

report form design...................................................................... 194

used with monitoring wells ........................................................ 177

legend file ....................................................................................... 220

adding a new symbol to ............................................................. 218

used when graphing shear test results ........................................ 170

used with picklists........................................................................ 19

LEGPROFA...................................................................................... 18

Length of pointer drawn leftwards from the left side of this column

prompt........................................................................................ 130

line

changing weight or color ..................................................... 59, 101

deleting from report heading or footing ....................................... 59

double lines .................................................................................. 39

drawing in report heading or footing ........................................... 58

drawing on a graphical symbol .................................................. 212

extending or shrinking ................................................................. 59

horizontal, across table .............................................................. 141

selecting between solid and dotted/dashed ................................ 147

used on multi-source graph reports ............................................ 191

used to draw a report border ...................................................... 184

weight .................................................... 39, 59, 184, 212, 213, 2 15

Line Properties dialog ................................................................. 58, 90

Line weight of major ticks prompt ..................................................138

linear ...............................................................................................172

linear graph .............................................................................156, 169

liquid limit ............................................................See Atterberg limits

List of items for popup menu during data entry ........................20, 170

LL ........................................................................See Atterberg limits

LNO()..............................................................................................226

LOGDRAFT III .................................23, 37, 41, 44, 71, 182, 185 –86,

...........................................................................................217, 225

logo ...............................................................................See picture file

LONG_DATE.................................................................................227

LST()...............................................................................................225

M

Make Spline from Selection menu ..................................................217

Make Subsequent Pages Identical menu ...........................................56

margins........................................................................................50–51

Marker connecting line type prompt ...............................................161

material description.......................................................See description

MAXDENS.....................................................................................123

Maximum number of sources to graph per page prompt

...................................................................................................192

meters......................................................................................See units

MINOR_CONVERT..............................160, 163, 165, 166, 169, 172,

...........................................................................................226, 227

MISC graphic symbols library ..........................................................15

MISC legend table ............................................................75, 170, 176

MISC symbols library ..........................15, 22, 79, 160, 162, 175, 180,

..................................................................................  182, 203, 205

monitoring well .................................15, 24, 51, 79, 177–80, 203, 218

field widths and ............................................................................17

Move Item Down, Move Item Up menus ........................111-112, 120

MTESTS .....................................................................................15, 18

multiplication ..................................................................................222

multi-source data summary ........................See summary: multi-source

multi-source graph ..........................................................................159

multi-source graph report ............................................27, 155, 191–93

multi-source subsurface report .............................................See profile

N

NARROW.........................................................................................37

natural moisture ......................................................................122, 156

graphing .....................................................................................154

No line selection .............................................................................147

No marker -- line only.....................................................................160

none

horizontal and vertical justification .............................................40

non-linear graphs ............................................................................168

normal

vertical text location ...................................................................118

north ............................................................................................10, 22

NOSYMBOLS..................................................................................77

notes..........................................................................See legend: notes



Number of columns prompt .............................................................. 75

NVALUE.................................................................................. 16, 169

N-value ........................................................................................... 221

adjusting below groundwater level ............................................ 222

calculated by adding blow counts ................................................ 16

graphing ..................................................................... 156, 158, 169

NXT() ..................................................................................... 119, 225

O

OLIVE .............................................................................................. 37

Omit line underneath checkbox ...................................................... 107

Omit source names checkbox ........................................................... 91

Omit the legend notes checkbox ....................................................... 75

One grid step is prompt................................................................... 210

Only print when this equation is "true" or "not zero" prompt ...............

................................................................................................ 86,88

opaque............................................................................. 213, 214, 215

open ........................................................................................ 213, 216

orientation ................................................................................... 44, 50

P

PAGE.......................................................................... 87, 88, 182, 228

page 2,3,4... template ...................................................................... 186

page number ............................................. 63, 80, 84, 87, 94, 182, 228

page size .........................................................................See paper size

PAGE_L ........................................................................... 87, 182, 228

PAGE_T ......................................................................................... 228

paper size .............................................................................. 38–39, 44

paragraph ...................................................................................... 5, 15

pattern symbol ............................................................ 203, 204–5, 208

PCX ..............................................................................See picture file

percent recovery.............................................................................. 114

PI .........................................................................See Atterberg limits

picklist ................................................................................ 18–20, 170

picture file ....................................................... 69, 70, 71–73, 194, 228

placing anywhere on the page .................................................... 182

piezometer ...................................................................................... 180

pipe ..................................................... 15, 17, 178, 203, 206, 209, 218

.................................................................See also monitoring well

PIPES symbols library ...................................................... 79, 177, 203

PIPES2.............................................................................................. 17

PIPES3.............................................................................................. 17

pitch ...............................................................................See font: pitch

PL .........................................................................See Atterberg limits

Place button .......................................................................... 63, 64, 69

plan view..................................................................................... 90–91

symbols used on........................................................................... 22

plastic limit ...........................................................See Atterberg limits

plasticity index......................................................See Atterberg limits

Plot last checkbox ............................................................................. 67

point size.................................................................See font: point size

polygon

drawing on a graphical symbol .................................... 213–14, 220

portrait...........................................................................See orientation

Postscript...........................................................................................36

PRESTIGE........................................................................................37

Print out-of-bound values in red checkbox .....................................158

Print the text even if this is missing checkbox ..................................86

Print the text of any graph values that aren't strictly numbers

checkbox ....................................................................................158

Print this item at depths entered into another data entry field ........188

Print when ...............................................................................114, 124

printer

downloadable fonts ......................................................................36

setup .............................................................................................39

Proctor.............................................................................................123

profile........................................................25, 47–49, 77, 101, 187–89

adding boring number to ............................................................188

horizontal scale .............................See horizontal scale: on profiles

project data..................................................................................4, 6–9

project summary..................................................See summary: project

prompt

on project or source data entry screen ............................................7

on tabulated data entry screen ......................................................14

proportionally spaced font ...................See font:proportionally spaced

PROTECT.......................................................................................207

pump .......................................................................................175, 180

PUMP_DEPTH...............................................................................180

R

randomly arranged ..........................................................................204

range .................................................................................See brackets

RECESSED.....................................................................................207

recovery ..........................................................................................114

rectangle............................................................................................60

Regional Settings

used for date formats ..................................................................223

REJECT ..........................................................................................132

REMARKS .......................................................................................15

report form

associated data entry form......................................................52–54

creating...................................................................................42–43

report heading and footing

defined .........................................................................................55

deleting a row...............................................................................61

inserting a row..............................................................................61

Reset button ................................................................................64, 70

RESUMED?..............................................................................86, 227

Revert to Previous Version menu .....................................................41

right-hand value prompt ..................................................................156

RND() .....................................................................................199, 224

rock coring ......................................................................................148

Rotate the text 270 degrees .............................................................114

rounding ....................................................................................85, 224

Rows are shaded instead of lined prompt .........................................49

RQD................................................................................................148



ruled

vertical text location .......................................................... 118, 151

ruled lines ................................................................................. 150–51

S

SAMP_LEN........................... 114, 119, 127, 134, 135, 147, 148, 160,

........................... 163, 165, 166, 169, 171, 172, 201, 222, 224, 226

SAMP_NUM .......................................................................... 127, 128

SAMP_REC.................................................................................... 114

SAMP_TYPE.................................................... 15, 127, 134, 135, 149

.................................................................  See also sampler symbol

sample

data............................................................................................. 115

depth .................................................................................. 124, 127

length ................................. 141, 143, 144, 147, 160,  171, 200, 201

number ................................................................................. 127–28

recovery ..................................................................................... 114

type .................................................................................... 203, 205

type shown symbolically ..................................................... 133–35

sampler symbol ......................................................................... 15, 218

field widths and............................................................................ 17

SAMPLERS legend table ............................................. 15, 17, 75, 134

SAMPLERS symbols library .................................... 79, 203, 205, 219

sampling length............................................................... 222, 224, 226

SCALE............................................................................................ 228

scale bar ............................................................................ 136–40, 200

on profiles .................................................................... 47, 188, 189

plotted outside the report border ................................................ 184

used on multi-source graph reports ............................................ 191

Scale label orientation prompt ........................................................ 157

SCRIPT............................................................................................. 37

search .............................................................................................. 198

seepage............................................................................................ 173

semi-log graph ................................................................................ 156

shading

rectangles in the report heading/footing ................................ 95–96

summary rows.............................................................................. 49

SHEAR ........................................................................................... 171

shear test ................................................................................... 19, 123

graphing results ............................................ 153, 159, 162, 170–72

SIMPLEX ......................................................................................... 37

SIN() ............................................................................................... 223

single source data summary ......................See summary: single source

single symbol ...................................................................... 203, 205–6

size

of graph marker.................................................................. 160, 162

Skip printing on the top of the first page checkbox ........................ 125

SLOTDPVC.................................................................................... 206

snap........................................................................... 58, 210, 215, 220

soil patterns..................................................................See stratigraphy

soil symbols .................................................................See stratigraphy

Solid/dotted or dashed selection field ............................................. 147

source data .................................................................................. 4, 6–9

Space button........................................................................87, 89, 126

spline

converting lines to ......................................................................217

drawing on a symbol ..................................................................216

SPT.....................................................................................See N-value

SQR() ..............................................................................................223

square root.......................................................................................223

STATION..........................................................................................22

station number.............................................................................10, 22

STRATA.....................................................15, 17, 127, 132, 146, 212

......................................................... See also stratigraphy symbols

STRATA legend table.......................................................................75

STRATA symbols library .................................................79, 177, 203

STRATA_DESC...............................................................................15

STRATA_ID................................................... 15, 131. See also USCS

stratigraphy ......................................................................51, 142, 203.

column .........................................................................110, 131–33

printing transition depths ...................................................126, 127

symbols ........................................................................................79

transition lines ....................................................See transition lines

stratigraphy symbols ...................................................................15, 17

Strip Previous Revisions menu .........................................................41

Stuff Included in Column prompt ...................................................112

style of report ....................................................................................44

STYPE ....................................................................162, 170, 171, 172

subsequent page ................................................................................55

Subsequent Page Absolute Placement ............................................181

Subsequent Page Margins .................................................................50

subtraction.......................................................................................222

summary............................................................49, 113, 115, 124, 137

multi-source .................................................................................26

project ............................................................................25, 28, 190

single source.................................................................................25

...............................................................See also: project summary

Support for a second well pipe? checkbox ......................................180

Symbol column title prompt .............................................................74

symbol library ...................................................................................78

defined .......................................................................................203

where stored ...............................................................................203

Symbol library prompt ....................................................................175

symbol name ...................................................................................208

Symbol square dimension prompt .....................................................75

T

table

definition ......................................................................................35

height on report ......................................................................50, 51

Table height prompt ..........................................................................51

Table/Footing prompt .......................................................................50

tabulated data ..........................................................................4, 12–13

TAN()..............................................................................................223

The sum of the column widths... error message ..............................110

Tick length prompt..........................................................................138



tick marks

on scale bars............................................................................... 138

used on graphs ........................................................................... 157

time ........................................................................................... 63, 227

Times New Roman ........................................................................... 36

title

above table columns .............................................................. 103–9

leaving empty............................................................................. 103

splitting over multiple lines ....................................................... 105

Title and Data Settings dialog ........................................................... 63

Title on the left of the marker prompt ............................. 155, 169, 202

Title to be shown above the key prompt ......................................... 193

Titles/Start of data prompt ................................................................ 50

To draw a line at the boring termination depth... prompt

................................................................................................... 147

TOP................................................................................................. 188

top cap ............................................................................ 203, 206, 209

TOPDEPTH.................................................................................... 228

torvane .............................................................................See shear test

TPAGE ..................................................................................... 94, 228

transcendental functions ................................................................. 223

TRANSITION........................................................... 15, 127, 145, 146

transition line .................................................... 111, 120, 141, 144–47

transparent ...................................................................... 213, 214, 215

TrueType ............................................................................ 36, 44, 185

Type of graph prompt ..................................................................... 156

type symbol............................................................................... 62, 105

Type-1............................................................................................... 36

U

unconfined compression ..................................................See shear test

underline ..................................................................................... 46, 67

data in column titles ................................................................... 109

UNIT_LENGTH............................................................................. 228

units

converting .................................................................... 84, 198–202

converting from inches to feet ................................................... 226

on scale bars............................................................................... 136

shown in scale captions................................................................ 48

used for data entry........................................................................ 14

UNIVERS......................................................................................... 37

unlabeled vertical grid lines ............................................................ 157

USCS ........................................................ 15, 115, 119, 131, 194, 225

Use the default font checkbox ................................ 106, 114, 128, 139

Use the default font for graph scale labels checkbox ..................... 157

User-entered or calculated data ....................................................... 198

user-selectable marker ...................................... 155, 159, 162–63, 171

V

vane shear ........................................................................See shear test

versions............................................................................................. 41

Vertical distance between horizontal lines prompt ......................... 151

vertical scale ................................................................... 115, 142, 228

on graphs....................................................................................153

vertical symbol spacing ..........................................................204, 209

vertical text location .................................................................115–20

Vertically centered over lines drawn at the same depth checkbox 126,

129

W

WATER ..........................................................................................176

water content ........................................................See natural moisture

WATER1 ........................................................................................176

WDEPTH1........................................................................92, 198, 199

weathering...............................................................................157, 167

weight ...........................................................................See line weight

Weight of Line at Bottom of Column prompt .................................101

Weight of Line at Column Right prompt ........................................101

Weight of Line at Top of Column prompt ......................................101

well .......................................................................See monitoring well

Well sections library checkbox .......................................................209

WELL_DESC ...................................................................................15

WELL_ID ......................... 15, 17, 178, 179. See also monitoring well

WELL_NOTES.................................................................................15

WELL_PIPE2 .........................................................................178, 180

What is the data entry field that provides the depth to the top of the

sampling interval prompt ...........................................................148

What is the data entry that the program should use to determine the

interval between the top and bottom lines? prompt ...................148

width

of table column ..........................................................................110

Width of the pipe prompt ........................................................207, 209

Width of the pipe within the well prompt .......................................179

Width of the well section prompt ....................................................179

windows

control panel ................................................................................38

Y

YN field type ....................................................................15, 145, 161




